summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-db/drizzle/drizzle-2010.03.1412.ebuild')
-rw-r--r--dev-db/drizzle/drizzle-2010.03.1412.ebuild46
1 files changed, 33 insertions, 13 deletions
diff --git a/dev-db/drizzle/drizzle-2010.03.1412.ebuild b/dev-db/drizzle/drizzle-2010.03.1412.ebuild
index 570cf588f050..b10a6c507c3e 100644
--- a/dev-db/drizzle/drizzle-2010.03.1412.ebuild
+++ b/dev-db/drizzle/drizzle-2010.03.1412.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/drizzle/drizzle-2010.03.1412.ebuild,v 1.1 2010/04/01 15:01:51 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/drizzle/drizzle-2010.03.1412.ebuild,v 1.2 2010/04/17 18:41:00 robbat2 Exp $
EAPI=2
@@ -11,39 +11,41 @@ HOMEPAGE="http://drizzle.org"
SRC_URI="http://launchpad.net/drizzle/cherry/2010-03-29/+download/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="~amd64"
+KEYWORDS="~amd64 ~x86"
IUSE="debug tcmalloc doc memcache curl pam gearman +md5"
# upstream bug #499911
RESTRICT="memcache? ( test ) !curl? ( test )"
+# for libdrizzle version, check m4/pandora*, PANDORA_LIBDRIZZLE_RECENT
RDEPEND="tcmalloc? ( dev-util/google-perftools )
- dev-db/libdrizzle
+ >=dev-db/libdrizzle-0.8
sys-libs/readline
sys-apps/util-linux
dev-libs/libpcre
- dev-libs/libevent
- dev-libs/protobuf
- gearman? ( sys-cluster/gearmand )
+ >=dev-libs/libevent-1.4
+ >=dev-libs/protobuf-2.1.0
+ gearman? ( >=sys-cluster/gearmand-0.12 )
pam? ( sys-libs/pam )
curl? ( net-misc/curl )
- memcache? ( dev-libs/libmemcached )
- md5? ( dev-libs/libgcrypt )"
+ memcache? ( >=dev-libs/libmemcached-0.39 )
+ md5? ( >=dev-libs/libgcrypt-1.4.2 )
+ >=dev-libs/boost-1.32"
DEPEND="${RDEPEND}
dev-util/gperf
- doc? ( app-doc/doxygen )"
+ doc? ( app-doc/doxygen )
+ >=dev-util/boost-build-1.32"
pkg_setup() {
- elog "This is a work-in-progress ebuild, some features will require"
- elog "manual configuration and others aren't fleshed out just yet."
- elog "Use it at your risk."
-
enewuser drizzle -1 -1 /dev/null nogroup
}
src_prepare() {
+ epatch "${FILESDIR}/${PN}-2010.03.1412-ggdb3-fix.patch"
+ # disable in release after 1412
epatch "${FILESDIR}/${PN}-2009.12.1240-nolint.patch"
+
AT_M4DIR="m4" eautoreconf
elibtoolize
}
@@ -54,19 +56,35 @@ src_configure() {
if use debug; then
append-flags -DDEBUG
fi
+
+ # while I applaud upstreams goal of 0 compiler warnings
+ # the 1412 release didn't achieve it.
+ append-flags -Wno-error
+ # disable-all gets rid of automagic dep
econf \
+ --disable-all \
--disable-static \
--disable-dependency-tracking \
--disable-mtmalloc \
+ --with-debug=$(use debug && echo yes || echo no) \
$(use_enable tcmalloc) \
$(use_enable memcache libmemcached) \
$(use_enable gearman libgearman) \
$(use_with curl auth-http-plugin) \
$(use_with pam auth-pam-plugin) \
$(use_with md5 md5-plugin) \
+ $(use_with gearman gearman_udf-plugin) \
+ $(use_with gearman logging_gearman-plugin) \
+ $(use_with memcache memcache_functions-plugins) \
+ --with-logging_stats \
--without-hello-world-plugin \
${myconf}
+
+ # upstream TODO:
+ # --without-all \
+ # broken atm
+ #$(use_with memcache memcache_stats-plugins) \
}
src_compile() {
@@ -77,7 +95,9 @@ src_compile() {
fi
}
+# 5-10 min eta
src_test() {
+ # If you want to turn off a test, rename to suffix of .DISABLED
# Explicitly allow parallel make check
emake check || die "tests failed"
}