summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ada/xmlada/xmlada-0.7.1-r1.ebuild')
-rw-r--r--dev-ada/xmlada/xmlada-0.7.1-r1.ebuild69
1 files changed, 69 insertions, 0 deletions
diff --git a/dev-ada/xmlada/xmlada-0.7.1-r1.ebuild b/dev-ada/xmlada/xmlada-0.7.1-r1.ebuild
new file mode 100644
index 000000000000..e3abb99e11ab
--- /dev/null
+++ b/dev-ada/xmlada/xmlada-0.7.1-r1.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ada/xmlada/xmlada-0.7.1-r1.ebuild,v 1.1 2003/07/23 01:22:45 george Exp $
+
+inherit gnat
+
+IUSE=""
+
+Name="XmlAda"
+
+DESCRIPTION="XML library for Ada"
+HOMEPAGE="http://libre.act-europe.fr/xmlada/"
+SRC_URI="http://libre.act-europe.fr/xmlada/${Name}-${PV}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+
+DEPEND="dev-lang/gnat"
+
+
+src_unpack()
+{
+ unpack ${A}
+ cd ${S}
+ #making .dvi docs is problemmatic. Skip that for now
+ sed -i -e "s/all: obj test docs/all: obj test/" Makefile.in
+ #increase stack size
+ cd sax
+ sed -i -e "s/Stack_Size : constant Natural := 64;/Stack_Size : constant Natural := 128;/" sax-readers.adb
+}
+
+src_compile()
+{
+ export CFLAGS=$ADACFLAGS
+ ./configure --prefix=/usr \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info \
+ --enable-shared \
+ --host=${CHOST} \
+ --build=${CHOST} \
+ --target=${CHOST} \
+ --with-system-zlib || die
+
+ export COMPILER=gnatmake
+ make || die "make failed"
+}
+
+src_install ()
+{
+ make PREFIX=${D}/usr install || die "install failed"
+
+ #move components to GNAE compliant directories
+ dodir /usr/lib/ada/adalib/${PN} /usr/lib/ada/adainclude
+ cd ${D}/usr/lib/
+ mv * ${D}/usr/lib/ada/adalib/${PN}/
+ cd ${D}/usr/include
+ mv ${PN} ${D}/usr/lib/ada/adainclude/
+ cd ..
+ rmdir include
+ cd ${S}
+
+ dodoc AUTHORS COPYING README TODO docs/xml.ps
+ dohtml docs/*.html
+ doinfo docs/*.info
+ #need to give a proper name to info file
+ cd ${D}/usr/share/info
+ mv xml.info.gz ${PN}.info.gz
+}