summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-sci/pari/pari-2.1.5-r2.ebuild')
-rw-r--r--app-sci/pari/pari-2.1.5-r2.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/app-sci/pari/pari-2.1.5-r2.ebuild b/app-sci/pari/pari-2.1.5-r2.ebuild
new file mode 100644
index 000000000000..6df49cf9f2fc
--- /dev/null
+++ b/app-sci/pari/pari-2.1.5-r2.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-sci/pari/pari-2.1.5-r2.ebuild,v 1.1 2004/03/15 14:05:07 phosphan Exp $
+
+DESCRIPTION="pari (or pari-gp) : a software package for computer-aided number theory"
+HOMEPAGE="http://www.parigp-home.de/"
+SRC_URI="http://www.gn-50uma.de/ftp/pari-2.1/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~sparc ~alpha ~mips ~hppa ~amd64"
+
+IUSE="doc"
+
+DEPEND="doc? ( virtual/tetex )"
+
+src_compile() {
+ ./Configure \
+ --host="$(echo ${CHOST} | cut -f "1 3" -d '-')" \
+ --prefix=/usr \
+ --miscdir=/usr/share/doc/${P} \
+ --datadir=/usr/share/${P} \
+ --mandir=/usr/share/man/man1 || die "./configure failed"
+ addwrite "/var/lib/texmf"
+ addwrite "/usr/share/texmf"
+ addwrite "/var/cache/fonts"
+ emake CFLAGS="${CFLAGS} -DGCC_INLINE" gp || die
+ use doc || rm -rf doc/*.tex
+ use doc && emake doc
+}
+
+src_install () {
+ make DESTDIR=${D} install || die
+ dodoc AUTHORS Announce.2.1 CHANGES README TODO
+}