summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-pda')
-rw-r--r--app-pda/p3nfs/ChangeLog11
-rw-r--r--app-pda/p3nfs/p3nfs-5.19-r1.ebuild (renamed from app-pda/p3nfs/p3nfs-5.19.ebuild)22
2 files changed, 22 insertions, 11 deletions
diff --git a/app-pda/p3nfs/ChangeLog b/app-pda/p3nfs/ChangeLog
index 6bd7e5f01873..0f80ff6183e7 100644
--- a/app-pda/p3nfs/ChangeLog
+++ b/app-pda/p3nfs/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-pda/p3nfs
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-pda/p3nfs/ChangeLog,v 1.18 2008/06/21 09:02:45 mrness Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-pda/p3nfs/ChangeLog,v 1.19 2009/08/16 08:54:32 mrness Exp $
+
+*p3nfs-5.19-r1 (16 Aug 2009)
+
+ 16 Aug 2009; Alin Năstac <mrness@gentoo.org> -p3nfs-5.19.ebuild,
+ +p3nfs-5.19-r1.ebuild:
+ Migrate to EAPI 2. Extend portmap dependency atom (#280931) and move it from
+ DEPEND to RDEPEND.
21 Jun 2008; Alin Năstac <mrness@gentoo.org> p3nfs-5.19.ebuild:
Drop bindnow flags (#226961). Fix type punned QA notices.
diff --git a/app-pda/p3nfs/p3nfs-5.19.ebuild b/app-pda/p3nfs/p3nfs-5.19-r1.ebuild
index c93e4ff2cb16..59b1a79ee6e3 100644
--- a/app-pda/p3nfs/p3nfs-5.19.ebuild
+++ b/app-pda/p3nfs/p3nfs-5.19-r1.ebuild
@@ -1,6 +1,8 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-pda/p3nfs/p3nfs-5.19.ebuild,v 1.5 2008/06/21 09:02:45 mrness Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-pda/p3nfs/p3nfs-5.19-r1.ebuild,v 1.1 2009/08/16 08:54:32 mrness Exp $
+
+EAPI="2"
inherit eutils flag-o-matic
@@ -13,19 +15,21 @@ SLOT="0"
KEYWORDS="~amd64 x86"
IUSE=""
-DEPEND="net-nds/portmap"
-
-src_unpack() {
- unpack ${A}
+DEPEND=""
+RDEPEND="|| ( net-nds/portmap net-nds/rpcbind )"
+src_prepare() {
sed -i "s:.*cd client/epoc32.*:#&:" "${S}/Makefile.in"
}
-src_compile() {
+src_configure() {
append-flags -fno-strict-aliasing # fix QA issues
sed -i "s:\$(LDFLAGS):${LDFLAGS}:" "${S}/server/Makefile.in"
econf || die "econf failed"
+}
+
+src_compile() {
emake CFLAGS="${CFLAGS} -Wall -I." || die "emake failed"
}
@@ -40,7 +44,7 @@ pkg_postinst() {
elog "You need to install one of the nfsapp-*.sis clients on your"
elog "Symbian device to be able to mount it's filesystems."
elog
- elog "Make sure to have portmap running before you start the"
- elog "p3nfsd server."
+ elog "Make sure to have portmap or rpcbind service running"
+ elog "before you start the p3nfsd server."
elog
}