summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-office/qhacc/qhacc-2.9.9.ebuild')
-rw-r--r--app-office/qhacc/qhacc-2.9.9.ebuild51
1 files changed, 51 insertions, 0 deletions
diff --git a/app-office/qhacc/qhacc-2.9.9.ebuild b/app-office/qhacc/qhacc-2.9.9.ebuild
new file mode 100644
index 000000000000..36f574a0110c
--- /dev/null
+++ b/app-office/qhacc/qhacc-2.9.9.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-office/qhacc/qhacc-2.9.9.ebuild,v 1.1 2004/05/01 16:54:50 centic Exp $
+
+inherit libtool
+
+IUSE="mysql xml"
+
+DESCRIPTION="Personal Finance for QT"
+HOMEPAGE="http://qhacc.sourceforge.net"
+SRC_URI="mirror://sourceforge/qhacc/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~sparc ~alpha ~hppa"
+
+DEPEND="mysql? ( dev-db/mysql++ )
+ xml? ( dev-libs/libxml sys-libs/zlib )
+ >=x11-libs/qt-3"
+
+src_compile() {
+
+ elibtoolize
+
+ local myconf=""
+ use mysql || myconf="${myconf} --disable-mysql"
+ use mysql && myconf="${myconf} --enable-mysql"
+ use xml || myconf="${myconf} --disable-xml"
+ use xml && myconf="${myconf} --enable-xml"
+
+ econf ${myconf} || die "configure failed"
+
+ make || die "make failed"
+
+}
+
+src_install() {
+
+ einstall || die "install failed"
+
+ dodir /etc/qhacc
+ cp -R ${S}/contrib/easysetup/* ${D}/etc/qhacc/
+}
+
+pkg_postinst() {
+ einfo "Copy the files in /etc/qhacc to ~/.qhacc,
+ You have to run this program with the command:
+ qhacc -f ~/.qhacc/
+ I prefer to put this in my .bashrc
+ alias qhacc=\"qhacc -f ~/.qhacc\""
+}