summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-mobilephone/obexftp/obexftp-0.23-r1.ebuild')
-rw-r--r--app-mobilephone/obexftp/obexftp-0.23-r1.ebuild9
1 files changed, 6 insertions, 3 deletions
diff --git a/app-mobilephone/obexftp/obexftp-0.23-r1.ebuild b/app-mobilephone/obexftp/obexftp-0.23-r1.ebuild
index 3764f29c5876..d57dfc343197 100644
--- a/app-mobilephone/obexftp/obexftp-0.23-r1.ebuild
+++ b/app-mobilephone/obexftp/obexftp-0.23-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-mobilephone/obexftp/obexftp-0.23-r1.ebuild,v 1.7 2010/01/14 01:27:17 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-mobilephone/obexftp/obexftp-0.23-r1.ebuild,v 1.8 2010/05/27 06:27:59 tove Exp $
EAPI="2"
@@ -63,7 +63,7 @@ src_install() {
# -j1 because "make -fMakefile.ruby install" fails
# upstream added -j1 to that command so it should be removed
# from here in the next version bump
- emake -j1 DESTDIR="${D}" install || die "emake install failed"
+ emake -j1 DESTDIR="${D}" INSTALLDIRS=vendor install || die "emake install failed"
dodoc AUTHORS ChangeLog NEWS README* THANKS TODO
dohtml doc/*.html
@@ -76,7 +76,10 @@ src_install() {
use ruby && doins examples/*.rb
use tcl && doins examples/*.tcl
- use perl && fixlocalpod
+ if use perl ; then
+ perl_delete_localpod
+ perl_delete_packlist
+ fi
}
pkg_postrm() {