summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-misc/lcdproc')
-rw-r--r--app-misc/lcdproc/ChangeLog8
-rw-r--r--app-misc/lcdproc/files/digest-lcdproc-0.4.51
-rw-r--r--app-misc/lcdproc/lcdproc-0.4.5.ebuild97
3 files changed, 105 insertions, 1 deletions
diff --git a/app-misc/lcdproc/ChangeLog b/app-misc/lcdproc/ChangeLog
index 669664166395..00497b8cfad3 100644
--- a/app-misc/lcdproc/ChangeLog
+++ b/app-misc/lcdproc/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-misc/lcdproc
# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/lcdproc/ChangeLog,v 1.13 2004/04/13 15:42:51 avenj Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/lcdproc/ChangeLog,v 1.14 2004/04/14 10:53:53 plasmaroo Exp $
+
+*lcdproc-0.4.5 (14 Apr 2004)
+
+ 14 Apr 2004; <plasmaroo@gentoo.org> lcdproc-0.4.5.ebuild:
+ Version bump in reference to bug #47340 which addresses a security flaw in
+ LCDproc.
13 Apr 2004; Jon Portnoy <avenj@gentoo.org> lcdproc-0.4.4-r1.ebuild :
Stable on x86
diff --git a/app-misc/lcdproc/files/digest-lcdproc-0.4.5 b/app-misc/lcdproc/files/digest-lcdproc-0.4.5
new file mode 100644
index 000000000000..c9fe341a28ff
--- /dev/null
+++ b/app-misc/lcdproc/files/digest-lcdproc-0.4.5
@@ -0,0 +1 @@
+MD5 2d342eb87c550a46629ec3efb1d70f49 lcdproc-0.4.5.tar.bz2 291703
diff --git a/app-misc/lcdproc/lcdproc-0.4.5.ebuild b/app-misc/lcdproc/lcdproc-0.4.5.ebuild
new file mode 100644
index 000000000000..6cd2cccf91b0
--- /dev/null
+++ b/app-misc/lcdproc/lcdproc-0.4.5.ebuild
@@ -0,0 +1,97 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/lcdproc/lcdproc-0.4.5.ebuild,v 1.1 2004/04/14 10:53:53 plasmaroo Exp $
+
+SRC_URI="mirror://sourceforge/lcdproc/${P}.tar.bz2"
+DESCRIPTION="Client/Server suite to drive all kinds of LCD (-like) devices"
+HOMEPAGE="http://lcdproc.org/"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="x86 amd64"
+IUSE="doc ncurses svga"
+
+DEPEND=">=sys-apps/baselayout-1.6.4
+ >=sys-apps/sed-4
+ doc? ( >=app-text/docbook-sgml-utils-0.6.11-r2 )
+ ncurses? ( >=sys-libs/ncurses-5.3 )
+ svga? ( >=media-libs/svgalib-1.4.3 )"
+
+src_unpack() {
+ unpack ${A} ; cd ${S}
+
+ sed -i "889s:-O3:${CFLAGS}:" configure
+}
+
+src_compile() {
+
+ # By default, all drivers that are supported by the given plattform/hardware
+ # are compiled (of course respecting the existing USE flags). If the
+ # LCDPROC_DRIVERS environment variable is set to a comma separated list, only
+ # the specified drivers will be compiled.
+ # Example:
+ #
+ # env LCDPROC_DRIVERS="curses,CFontz" emerge lcdproc
+ #
+ # NOTE: The ebuild still respects your USE variable and will not install any
+ # additional packages unless the corresponding USE flag is set!
+ # You might have to alter it if e.g. ncurses is normally not part of your
+ # USE variable.
+ # Example:
+ #
+ # env USE="$USE ncurses" LCDPROC_DRIVERS="curses,CFontz" emerge lcdproc
+
+ local myconf
+
+ myconf="--enable-drivers=mtxorb,cfontz,cwlnx,text,lb216,"
+ myconf="${myconf}hd44780,joy,irman,lircin,bayrad,glk,stv5730,"
+ myconf="${myconf}stv5730,sed1330,sed1520,lcdm001,"
+ myconf="${myconf}t6963,wirz-sli,sgx120"
+
+ use ncurses && myconf="${myconf},curses"
+ use svga && myconf="${myconf},svgalib"
+
+ [ x"${LCDPROC_DRIVERS}" = x ] || \
+ myconf="--enable-drivers=${LCDPROC_DRIVERS}"
+
+ use samba && myconf="${myconf} --enable-stat-smbfs"
+ myconf="${myconf} --enable-stat-nfs"
+
+ econf ${myconf} || die
+ emake || die
+
+ if [ `use doc` ]; then
+ cd ${S}/docs/lcdproc-user
+ docbook2html lcdproc-user.docbook
+ fi
+}
+
+src_install() {
+ dosbin server/LCDd
+ dobin clients/lcdproc/lcdproc
+
+ doman docs/lcdproc.1 docs/LCDd.8
+
+ dodoc README ChangeLog COPYING INSTALL
+
+ if [ `use doc` ]; then
+ insinto /usr/share/doc/${PF}/lcdproc-user
+ doins docs/lcdproc-user/*.html
+ fi
+
+ docinto olddocs
+ dodoc docs/README.dg* docs/*.txt
+
+ insinto /usr/share/doc/${PF}/clients/examples
+ doins clients/examples/*.pl
+ insinto /usr/share/doc/${PF}/clients/headlines
+ doins clients/headlines/lcdheadlines
+
+ insinto /etc
+ doins LCDd.conf
+ doins scripts/lcdproc.conf
+
+ exeinto /etc/init.d
+ doexe ${FILESDIR}/LCDd
+ doexe ${FILESDIR}/lcdproc
+}