summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-i18n/uim-fep/uim-fep-0.2.8.ebuild')
-rw-r--r--app-i18n/uim-fep/uim-fep-0.2.8.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/app-i18n/uim-fep/uim-fep-0.2.8.ebuild b/app-i18n/uim-fep/uim-fep-0.2.8.ebuild
new file mode 100644
index 000000000000..75dffee3ea8c
--- /dev/null
+++ b/app-i18n/uim-fep/uim-fep-0.2.8.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/uim-fep/uim-fep-0.2.8.ebuild,v 1.1 2004/05/18 22:38:33 usata Exp $
+
+IUSE="unicode"
+
+DESCRIPTION="UIM multilingual input method frontend processor for console"
+HOMEPAGE="http://www.ice.nuie.nagoya-u.ac.jp/~h013177b/uim-fep/"
+SRC_URI="http://www.ice.nuie.nagoya-u.ac.jp/~h013177b/uim-fep/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~x86 ~ppc"
+
+DEPEND=">=app-i18n/uim-0.3.4.2
+ sys-libs/ncurses"
+
+src_compile() {
+
+ local myconf
+ if use unicode ; then
+ myconf="${myconf} --with-enc=utf-8"
+ else
+ myconf="${myconf} --with-enc=euc-jp"
+ fi
+
+ econf ${myconf} || die
+ emake || die
+}
+
+src_install() {
+
+ make DESTDIR=${D} install || die "make install failed"
+
+ dodoc README COPYING INSTALL
+}
+
+pkg_postinst() {
+
+ einfo
+ einfo "uim-fep is configured for skk. If you want to change it, you can set"
+ einfo "UIM_FEP environment variable to one of skk, prime, anthy, canna,"
+ einfo "tcode and tutcode or run uim-fep with -u option with engines listed above."
+ einfo
+}