summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-i18n/scim-hangul')
-rw-r--r--app-i18n/scim-hangul/ChangeLog6
-rw-r--r--app-i18n/scim-hangul/files/scim-hangul-0.4.0+gtk.patch11
-rw-r--r--app-i18n/scim-hangul/scim-hangul-0.4.0.ebuild5
3 files changed, 19 insertions, 3 deletions
diff --git a/app-i18n/scim-hangul/ChangeLog b/app-i18n/scim-hangul/ChangeLog
index 1c3718e9b5e5..4fc70d208bcd 100644
--- a/app-i18n/scim-hangul/ChangeLog
+++ b/app-i18n/scim-hangul/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-i18n/scim-hangul
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-i18n/scim-hangul/ChangeLog,v 1.33 2013/03/04 07:43:45 naota Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/scim-hangul/ChangeLog,v 1.34 2013/04/06 00:00:19 naota Exp $
+
+ 05 Apr 2013; Naohiro Aota <naota@gentoo.org>
+ +files/scim-hangul-0.4.0+gtk.patch, scim-hangul-0.4.0.ebuild:
+ Add patch to support >=gtk-2.24.0. #460714
*scim-hangul-0.4.0 (04 Mar 2013)
diff --git a/app-i18n/scim-hangul/files/scim-hangul-0.4.0+gtk.patch b/app-i18n/scim-hangul/files/scim-hangul-0.4.0+gtk.patch
new file mode 100644
index 000000000000..bc1fd4b673ee
--- /dev/null
+++ b/app-i18n/scim-hangul/files/scim-hangul-0.4.0+gtk.patch
@@ -0,0 +1,11 @@
+--- src/scim_hangul_imengine_setup.cpp.orig 2012-07-08 07:52:07.000000000 -0400
++++ src/scim_hangul_imengine_setup.cpp 2012-11-02 14:13:14.000000000 -0400
+@@ -346,7 +346,7 @@
+ for (i = 0; i < n; i++) {
+ const char* name = hangul_ic_get_keyboard_name(i);
+ #if GTK_CHECK_VERSION(2, 24, 0)
+- gtk_combo_box_text_append(GTK_COMBO_BOX_TEXT(combo_box), NULL, name);
++ gtk_combo_box_text_append_text(GTK_COMBO_BOX_TEXT(combo_box), name);
+ #else
+ gtk_combo_box_append_text(GTK_COMBO_BOX(combo_box), name);
+ #endif
diff --git a/app-i18n/scim-hangul/scim-hangul-0.4.0.ebuild b/app-i18n/scim-hangul/scim-hangul-0.4.0.ebuild
index 2289d2705308..ece9121e9e7b 100644
--- a/app-i18n/scim-hangul/scim-hangul-0.4.0.ebuild
+++ b/app-i18n/scim-hangul/scim-hangul-0.4.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-i18n/scim-hangul/scim-hangul-0.4.0.ebuild,v 1.1 2013/03/04 07:43:45 naota Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/scim-hangul/scim-hangul-0.4.0.ebuild,v 1.2 2013/04/06 00:00:19 naota Exp $
EAPI=5
@@ -24,7 +24,8 @@ DEPEND="${RDEPEND}
PATCHES=(
"${FILESDIR}/${PN}-0.3.2+gcc-4.3.patch"
- "${FILESDIR}/${PN}-0.3.2+gcc-4.7.patch" )
+ "${FILESDIR}/${PN}-0.3.2+gcc-4.7.patch"
+ "${FILESDIR}/${PN}-0.4.0+gtk.patch" )
DOCS=(AUTHORS NEWS)