summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-i18n/ibus-skk/ibus-skk-1.3.2.ebuild')
-rw-r--r--app-i18n/ibus-skk/ibus-skk-1.3.2.ebuild51
1 files changed, 51 insertions, 0 deletions
diff --git a/app-i18n/ibus-skk/ibus-skk-1.3.2.ebuild b/app-i18n/ibus-skk/ibus-skk-1.3.2.ebuild
new file mode 100644
index 000000000000..5d8f16467550
--- /dev/null
+++ b/app-i18n/ibus-skk/ibus-skk-1.3.2.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/ibus-skk/ibus-skk-1.3.2.ebuild,v 1.1 2010/10/26 17:24:46 matsuu Exp $
+
+EAPI="2"
+PYTHON_DEPEND="2:2.5"
+inherit python
+
+DESCRIPTION="Japanese input method Anthy IMEngine for IBus Framework"
+HOMEPAGE="http://github.com/ueno/ibus-skk"
+SRC_URI="http://cloud.github.com/downloads/ueno/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="nls"
+
+RDEPEND=">=app-i18n/ibus-1.3
+ nls? ( virtual/libintl )"
+DEPEND="${RDEPEND}
+ nls? ( >=sys-devel/gettext-0.16.1 )"
+RDEPEND="${RDEPEND}
+ app-i18n/skk-jisyo"
+
+pkg_setup() {
+ python_set_active_version 2
+
+}
+
+src_prepare() {
+ mv py-compile py-compile.orig || die
+ ln -s "$(type -P true)" py-compile || die
+}
+
+src_configure() {
+ econf $(use_enable nls) || die
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+
+ dodoc AUTHORS ChangeLog NEWS README THANKS TODO || die
+}
+
+pkg_postinst() {
+ python_mod_optimize /usr/share/${PN}
+}
+
+pkg_postrm() {
+ python_mod_cleanup /usr/share/${PN}
+}