summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-emulation/lxc')
-rw-r--r--app-emulation/lxc/ChangeLog10
-rw-r--r--app-emulation/lxc/files/lxc.initd.26
-rw-r--r--app-emulation/lxc/lxc-0.8.0_rc2.ebuild (renamed from app-emulation/lxc/lxc-0.8.0_rc1-r5.ebuild)5
3 files changed, 14 insertions, 7 deletions
diff --git a/app-emulation/lxc/ChangeLog b/app-emulation/lxc/ChangeLog
index d6fb50c1f250..a095af53b534 100644
--- a/app-emulation/lxc/ChangeLog
+++ b/app-emulation/lxc/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-emulation/lxc
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/lxc/ChangeLog,v 1.40 2012/06/07 12:59:27 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/lxc/ChangeLog,v 1.41 2012/07/21 05:07:14 flameeyes Exp $
+
+*lxc-0.8.0_rc2 (21 Jul 2012)
+
+ 21 Jul 2012; Diego E. Pettenò <flameeyes@gentoo.org> +lxc-0.8.0_rc2.ebuild,
+ -lxc-0.8.0_rc1-r5.ebuild, files/lxc.initd.2:
+ Version bump; also fixes bug #427078 and #427086, thanks to Alexander Zubkov
+ for the report.
*lxc-0.8.0_rc1-r5 (07 Jun 2012)
@@ -235,4 +242,3 @@
Initial import of lxc; based upon dev-zero's ebuild, modified by me. It
diverges a bit from upstream, in the path used, to stay more
Gentoo-styled. Init scripts will likely be added separately.
-
diff --git a/app-emulation/lxc/files/lxc.initd.2 b/app-emulation/lxc/files/lxc.initd.2
index 0977eb6f958f..9f38dc8e0006 100644
--- a/app-emulation/lxc/files/lxc.initd.2
+++ b/app-emulation/lxc/files/lxc.initd.2
@@ -1,7 +1,7 @@
#!/sbin/runscript
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/lxc/files/lxc.initd.2,v 1.4 2012/06/07 12:59:28 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/lxc/files/lxc.initd.2,v 1.5 2012/07/21 05:07:15 flameeyes Exp $
CONTAINER=${SVCNAME#*.}
@@ -104,7 +104,7 @@ stop() {
return 0
fi
- init_pid=$(lxc-info -n ${CONTAINER} --pid | cut -d: -f 2)
+ init_pid=$(lxc-info -n ${CONTAINER} --pid | awk '{ print $2 }')
if [ "${init_pid}" = "-1" ]; then
ewarn "${CONTAINER} doesn't seem to be running."
@@ -112,7 +112,7 @@ stop() {
fi
ebegin "Shutting down system in ${CONTAINER}"
- kill -INT ${init_pid}
+ kill -PWR ${init_pid}
eend $?
TIMEOUT=${TIMEOUT:-30}
diff --git a/app-emulation/lxc/lxc-0.8.0_rc1-r5.ebuild b/app-emulation/lxc/lxc-0.8.0_rc2.ebuild
index e8db0254570f..180ba88291c0 100644
--- a/app-emulation/lxc/lxc-0.8.0_rc1-r5.ebuild
+++ b/app-emulation/lxc/lxc-0.8.0_rc2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/lxc/lxc-0.8.0_rc1-r5.ebuild,v 1.1 2012/06/07 12:59:27 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/lxc/lxc-0.8.0_rc2.ebuild,v 1.1 2012/07/21 05:07:14 flameeyes Exp $
EAPI="4"
@@ -39,6 +39,7 @@ RDEPEND="${RDEPEND}
sys-apps/util-linux
app-misc/pax-utils
>=sys-apps/openrc-0.9.9.1
+ virtual/awk
)"
CONFIG_CHECK="~CGROUPS ~CGROUP_DEVICE
@@ -88,7 +89,7 @@ DOCS=(AUTHORS CONTRIBUTING MAINTAINERS TODO README doc/FAQ.txt)
src_prepare() {
if [[ -n ${BACKPORTS} ]]; then
- epatch "${S}"/patches/*
+ epatch "${WORKDIR}"/patches/*
eautoreconf
fi
}