summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-emacs/riece/riece-1.0.4.ebuild')
-rw-r--r--app-emacs/riece/riece-1.0.4.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/app-emacs/riece/riece-1.0.4.ebuild b/app-emacs/riece/riece-1.0.4.ebuild
new file mode 100644
index 000000000000..4cf1581527d0
--- /dev/null
+++ b/app-emacs/riece/riece-1.0.4.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/riece/riece-1.0.4.ebuild,v 1.1 2004/10/13 12:29:55 usata Exp $
+
+inherit elisp
+
+IUSE=""
+
+DESCRIPTION="Riece is a redesign of Liece IRC client"
+HOMEPAGE="http://wiliki.designflaw.org/riece.cgi"
+SRC_URI="http://wiliki.designflaw.org/riece/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~alpha ~ppc ~ppc64 ~amd64 ~ppc-macos"
+
+DEPEND="virtual/emacs"
+
+SITEFILE=50riece-gentoo.el
+
+src_compile() {
+
+ econf --with-lispdir=${SITELISP} || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install () {
+
+ einstall lispdir=${D}/${SITELISP} || die "einstall failed"
+ elisp-site-file-install ${FILESDIR}/${SITEFILE}
+
+ dodoc AUTHORS ChangeLog INSTALL NEWS README
+}