summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-emacs/flim')
-rw-r--r--app-emacs/flim/ChangeLog7
-rw-r--r--app-emacs/flim/flim-1.14.6.ebuild6
-rw-r--r--app-emacs/flim/flim-1.14.7.ebuild6
-rw-r--r--app-emacs/flim/flim-1.14.8.ebuild23
4 files changed, 24 insertions, 18 deletions
diff --git a/app-emacs/flim/ChangeLog b/app-emacs/flim/ChangeLog
index 162169765797..abd29c424888 100644
--- a/app-emacs/flim/ChangeLog
+++ b/app-emacs/flim/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-emacs/flim
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emacs/flim/ChangeLog,v 1.17 2007/03/07 09:44:24 opfer Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/flim/ChangeLog,v 1.18 2007/03/13 10:51:06 opfer Exp $
+
+ 13 Mar 2007; Christian Faulhammer <opfer@gentoo.org> flim-1.14.6.ebuild,
+ flim-1.14.7.ebuild, flim-1.14.8.ebuild:
+ adjusted DESCRIPTION in all three; added a lot of quotes and refinements
+ (make -> emake) to the latest testing
07 Mar 2007; Christian Faulhammer <opfer@gentoo.org>
files/60flim-gentoo.el:
diff --git a/app-emacs/flim/flim-1.14.6.ebuild b/app-emacs/flim/flim-1.14.6.ebuild
index 88c09c9a62cd..c448d7262940 100644
--- a/app-emacs/flim/flim-1.14.6.ebuild
+++ b/app-emacs/flim/flim-1.14.6.ebuild
@@ -1,12 +1,12 @@
-# Copyright 1999-2005 Gentoo Foundation
+# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emacs/flim/flim-1.14.6.ebuild,v 1.9 2005/01/01 13:46:00 eradicator Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/flim/flim-1.14.6.ebuild,v 1.10 2007/03/13 10:51:06 opfer Exp $
inherit elisp
IUSE=""
-DESCRIPTION="A library to provide basic features about message representation or encoding -- FLIM"
+DESCRIPTION="A library to provide basic features about message representation or encoding"
HOMEPAGE="http://cvs.m17n.org/elisp/FLIM/"
SRC_URI="ftp://ftp.m17n.org/pub/mule/flim/flim-1.14/${P}.tar.gz"
diff --git a/app-emacs/flim/flim-1.14.7.ebuild b/app-emacs/flim/flim-1.14.7.ebuild
index fc5c6be797d4..cf5527cab3a1 100644
--- a/app-emacs/flim/flim-1.14.7.ebuild
+++ b/app-emacs/flim/flim-1.14.7.ebuild
@@ -1,12 +1,12 @@
-# Copyright 1999-2005 Gentoo Foundation
+# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emacs/flim/flim-1.14.7.ebuild,v 1.3 2005/07/01 18:14:57 mkennedy Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/flim/flim-1.14.7.ebuild,v 1.4 2007/03/13 10:51:06 opfer Exp $
inherit elisp
IUSE=""
-DESCRIPTION="A library to provide basic features about message representation or encoding -- FLIM"
+DESCRIPTION="A library to provide basic features about message representation or encoding"
HOMEPAGE="http://cvs.m17n.org/elisp/FLIM/"
SRC_URI="ftp://ftp.m17n.org/pub/mule/flim/flim-1.14/${P}.tar.gz"
diff --git a/app-emacs/flim/flim-1.14.8.ebuild b/app-emacs/flim/flim-1.14.8.ebuild
index 65778e0d9a71..5070ae029802 100644
--- a/app-emacs/flim/flim-1.14.8.ebuild
+++ b/app-emacs/flim/flim-1.14.8.ebuild
@@ -1,37 +1,38 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emacs/flim/flim-1.14.8.ebuild,v 1.1 2006/03/05 23:09:56 mkennedy Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/flim/flim-1.14.8.ebuild,v 1.2 2007/03/13 10:51:06 opfer Exp $
inherit elisp
IUSE=""
-DESCRIPTION="A library to provide basic features about message representation or encoding -- FLIM"
+DESCRIPTION="A library to provide basic features about message representation or encoding"
HOMEPAGE="http://cvs.m17n.org/elisp/FLIM/"
SRC_URI="ftp://ftp.m17n.org/pub/mule/flim/flim-1.14/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~x86 ~alpha ~sparc ~ppc ~ppc-macos ~amd64"
-
DEPEND="virtual/emacs
!virtual/flim
>=app-emacs/apel-10.3"
PROVIDE="virtual/flim"
+SITEFILE=60flim-gentoo.el
+
src_compile() {
- make PREFIX=${D}/usr \
- LISPDIR=${D}/${SITELISP} \
- VERSION_SPECIFIC_LISPDIR=${D}/${SITELISP} || die
+ emake PREFIX="${D}/usr" \
+ LISPDIR="${D}/${SITELISP}" \
+ VERSION_SPECIFIC_LISPDIR="${D}/${SITELISP}" || die "emake failed"
}
src_install() {
- make PREFIX=${D}/usr \
- LISPDIR=${D}/${SITELISP} \
- VERSION_SPECIFIC_LISPDIR=${D}/${SITELISP} install || die
+ emake PREFIX="${D}/usr" \
+ LISPDIR="${D}/${SITELISP}" \
+ VERSION_SPECIFIC_LISPDIR="${D}/${SITELISP}" install || die "emake install failed"
- elisp-site-file-install ${FILESDIR}/60flim-gentoo.el
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}"
dodoc FLIM-API.en NEWS VERSION README* ChangeLog
}