summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-editors/cooledit/cooledit-3.17.17.ebuild')
-rw-r--r--app-editors/cooledit/cooledit-3.17.17.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/app-editors/cooledit/cooledit-3.17.17.ebuild b/app-editors/cooledit/cooledit-3.17.17.ebuild
new file mode 100644
index 000000000000..a02ff9ba2d5b
--- /dev/null
+++ b/app-editors/cooledit/cooledit-3.17.17.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-editors/cooledit/cooledit-3.17.17.ebuild,v 1.1 2006/03/12 20:58:52 agriffis Exp $
+
+inherit eutils
+
+DESCRIPTION="Cooledit is a full featured multiple window text editor"
+HOMEPAGE="http://freshmeat.net/projects/cooledit/"
+SRC_URI="ftp://ftp.ibiblio.org/pub/Linux/apps/editors/X/cooledit/${P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc-macos ~x86"
+IUSE="nls spell"
+
+RDEPEND="|| ( x11-libs/libX11 virtual/x11 )
+ spell? ( app-text/ispell )"
+DEPEND="${RDEPEND}
+ || ( x11-libs/libXpm virtual/x11 )"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch ${FILESDIR}/cooledit-3.17.17-gcc4.patch
+}
+
+src_compile() {
+ # Fix for bug 40152 (04 Feb 2004 agriffis)
+ addwrite /dev/ptym/clone:/dev/ptmx
+ econf $(use_enable nls)
+ emake || die "emake failed"
+}
+
+src_install() {
+ make install DESTDIR=${D} || die "install failed"
+}