summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-backup/sarab/sarab-0.2.2-r2.ebuild')
-rw-r--r--app-backup/sarab/sarab-0.2.2-r2.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/app-backup/sarab/sarab-0.2.2-r2.ebuild b/app-backup/sarab/sarab-0.2.2-r2.ebuild
new file mode 100644
index 000000000000..0a56c4aee0f5
--- /dev/null
+++ b/app-backup/sarab/sarab-0.2.2-r2.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-backup/sarab/sarab-0.2.2-r2.ebuild,v 1.1 2006/03/03 18:16:13 mkennedy Exp $
+
+inherit eutils
+
+DESCRIPTION="SaraB is a powerful and automated backup scheduling system based on DAR."
+HOMEPAGE="http://sarab.sourceforge.net/"
+SRC_URI="mirror://sourceforge/sarab/${P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND="app-backup/dar
+ mail-client/mailx"
+
+S=${WORKDIR}/${PN}
+
+src_unpack() {
+ unpack ${A}
+ epatch ${FILESDIR}/${PV}-test-with-encryption-gentoo.patch || die
+ epatch ${FILESDIR}/${PV}-better-defaults-gentoo.patch || die
+ epatch ${FILESDIR}/${PV}-fix-rotation-gentoo.patch || die
+ epatch ${FILESDIR}/${PV}-refname-calculation-gentoo.patch || die
+}
+
+src_install() {
+ dobin sarab.sh
+ insinto /etc/sarab
+ doins -r etc/*
+ # sarab.conf could contain passphrase information
+ fperms 600 /etc/sarab/sarab.conf
+ dodoc CHANGELOG FAQ INSTALL LICENSE README
+ dodoc ${FILESDIR}/README.Gentoo
+}