summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-arch/pbzip2/pbzip2-1.1.2.ebuild')
-rw-r--r--app-arch/pbzip2/pbzip2-1.1.2.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/app-arch/pbzip2/pbzip2-1.1.2.ebuild b/app-arch/pbzip2/pbzip2-1.1.2.ebuild
new file mode 100644
index 000000000000..ec0d236655c6
--- /dev/null
+++ b/app-arch/pbzip2/pbzip2-1.1.2.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-arch/pbzip2/pbzip2-1.1.2.ebuild,v 1.1 2011/02/20 22:24:38 spatz Exp $
+
+EAPI=2
+
+inherit multilib eutils
+
+DESCRIPTION="Parallel bzip2 (de)compressor using libbz2"
+HOMEPAGE="http://compression.ca/pbzip2/"
+SRC_URI="http://compression.ca/${PN}/${P}.tar.gz"
+
+LICENSE="PBZIP2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="static symlink"
+
+DEPEND="app-arch/bzip2"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-makefile.patch
+ tc-export CXX
+}
+
+src_compile() {
+ if use static ; then
+ cp -f /usr/$(get_libdir)/libbz2.a "${S}"
+ emake pbzip2-static || die "Failed to build"
+ else
+ emake pbzip2 || die "Failed to build"
+ fi
+}
+
+src_install() {
+ dobin pbzip2 || die "Failed to install"
+ dodoc AUTHORS ChangeLog README || die
+ doman pbzip2.1 || die "Failed to install man page"
+ dosym /usr/bin/pbzip2 /usr/bin/pbunzip2
+
+ if use symlink; then
+ dosym /usr/bin/pbzip2 /usr/bin/bzip2
+ dosym /usr/bin/pbzip2 /usr/bin/bunzip2
+ dosym /usr/bin/pbzip2 /usr/bin/bzcat
+ fi
+}