summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-admin/cancd/cancd-0.1.0-r1.ebuild')
-rw-r--r--app-admin/cancd/cancd-0.1.0-r1.ebuild25
1 files changed, 13 insertions, 12 deletions
diff --git a/app-admin/cancd/cancd-0.1.0-r1.ebuild b/app-admin/cancd/cancd-0.1.0-r1.ebuild
index b4320c83ade2..72a5f8cb46e9 100644
--- a/app-admin/cancd/cancd-0.1.0-r1.ebuild
+++ b/app-admin/cancd/cancd-0.1.0-r1.ebuild
@@ -1,13 +1,13 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/cancd/cancd-0.1.0-r1.ebuild,v 1.4 2008/11/14 15:00:41 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/cancd/cancd-0.1.0-r1.ebuild,v 1.5 2009/01/14 05:27:34 vapier Exp $
inherit eutils
-DESCRIPTION="This is the CA NetConsole Daemon, a daemon to receive output from
-the Linux netconsole driver."
+DESCRIPTION="the CA NetConsole Daemon, a daemon to receive output from the Linux netconsole driver"
HOMEPAGE="http://oss.oracle.com/projects/cancd/"
SRC_URI="http://oss.oracle.com/projects/cancd/dist/files/source/${P}.tar.gz"
+
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~x86"
@@ -15,13 +15,15 @@ IUSE=""
src_unpack() {
unpack ${A}
- epatch ${FILESDIR}/${P}-c-cleanup.patch
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-build.patch #246734
+ epatch "${FILESDIR}"/${P}-c-cleanup.patch
# slight makefile cleanup
- sed -i.orig \
+ sed -i \
-e '/^CFLAGS/s,-g,,' \
-e '/^CFLAGS/s,-O2,-Wall -W -Wextra -Wundef -Wendif-labels -Wshadow -Wpointer-arith -Wbad-function-cast -Wcast-qual -Wcast-align -Wwrite-strings -Wconversion -Wsign-compare -Waggregate-return -Wstrict-prototypes -Wredundant-decls -Wunreachable-code -Wlong-long,' \
-e '/rm cancd cancd.o/s,rm,rm -f,' \
- ${S}/Makefile
+ Makefile || die
}
src_compile() {
@@ -29,12 +31,11 @@ src_compile() {
}
src_install() {
- into /usr
dosbin cancd || die "dosbin failed"
- newinitd ${FILESDIR}/cancd-init.d cancd
- newconfd ${FILESDIR}/cancd-conf.d cancd
- newinitd ${FILESDIR}/netconsole-init.d netconsole
- newconfd ${FILESDIR}/netconsole-conf.d netconsole
+ newinitd "${FILESDIR}"/cancd-init.d cancd
+ newconfd "${FILESDIR}"/cancd-conf.d cancd
+ newinitd "${FILESDIR}"/netconsole-init.d netconsole
+ newconfd "${FILESDIR}"/netconsole-conf.d netconsole
keepdir /var/crash
fowners adm:nobody /var/crash
fperms 700 /var/crash