summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-emulation/wine/ChangeLog7
-rw-r--r--app-emulation/wine/files/80wine4
-rw-r--r--app-emulation/wine/files/digest-wine-200205091
-rw-r--r--app-emulation/wine/wine-20020509.ebuild102
4 files changed, 113 insertions, 1 deletions
diff --git a/app-emulation/wine/ChangeLog b/app-emulation/wine/ChangeLog
index 0d715a4b6d79..69ebf9b281b8 100644
--- a/app-emulation/wine/ChangeLog
+++ b/app-emulation/wine/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-emulation/wine
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/ChangeLog,v 1.7 2002/04/14 16:23:55 danarmak Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/ChangeLog,v 1.8 2002/05/11 08:30:37 verwilst Exp $
+
+*wine-20020509 (11 May 2002)
+
+ 11 May 2002; Bart Verwilst <verwilst@gentoo.org>: new upstream release,
+ new reworked ebuilds
*wine-20020411 (14 Apr 2002)
diff --git a/app-emulation/wine/files/80wine b/app-emulation/wine/files/80wine
new file mode 100644
index 000000000000..b26aea5feaad
--- /dev/null
+++ b/app-emulation/wine/files/80wine
@@ -0,0 +1,4 @@
+PATH=/usr/wine/bin
+ROOTPATH=/usr/wine/bin
+LDPATH=/usr/wine/lib
+MANPATH=/usr/wine/man
diff --git a/app-emulation/wine/files/digest-wine-20020509 b/app-emulation/wine/files/digest-wine-20020509
new file mode 100644
index 000000000000..5f426f3dc21b
--- /dev/null
+++ b/app-emulation/wine/files/digest-wine-20020509
@@ -0,0 +1 @@
+MD5 5d636433a54c6252635d2f2c58f10590 Wine-20020509.tar.gz 7147380
diff --git a/app-emulation/wine/wine-20020509.ebuild b/app-emulation/wine/wine-20020509.ebuild
new file mode 100644
index 000000000000..f35e3ec1fb37
--- /dev/null
+++ b/app-emulation/wine/wine-20020509.ebuild
@@ -0,0 +1,102 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# Author Dan Armak <danarmak@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/wine-20020509.ebuild,v 1.1 2002/05/11 08:30:37 verwilst Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="Wine is a free implementation of Windows on Unix."
+SRC_URI="ftp://metalab.unc.edu/pub/Linux/ALPHA/wine/development/Wine-${PV}.tar.gz"
+HOMEPAGE="http://www.winehq.com/"
+
+DEPEND="virtual/glibc
+ virtual/x11
+ sys-devel/gcc
+ sys-devel/flex
+ dev-util/yacc
+ opengl? ( virtual/opengl )
+ >=sys-libs/ncurses-5.2
+ cups? ( net-print/cups )
+ >=media-libs/freetype-2.0.0
+ dev-lang/tcl dev-lang/tk"
+
+src_compile() {
+
+ cd ${S}
+ local myconf
+
+ use opengl && myconf="--enable-opengl" || myconf="--disable-opengl"
+ [ -z $DEBUG ] && myconf="$myconf --disable-trace --disable-debug" || myconf="$myconf --enable-trace --enable-debug"
+ # there's no configure flag for cups, it's supposed to be autodetected
+
+ # the folks at #winehq were really angry about custom optimization
+ export CFLAGS=""
+ export CXXFLAGS=""
+
+ ./configure --prefix=/usr \
+ --exec_prefix=/usr/wine \
+ --sysconfdir=/etc/wine \
+ --mandir=/usr/share/man \
+ --host=${CHOST} \
+ --enable-curses \
+ ${myconf} || die
+
+ cd ${S}/programs/winetest
+ cp Makefile 1
+ sed -e 's:wine.pm:include/wine.pm:' 1 > Makefile
+
+ cd ${S}
+ make depend all manpages || die
+ cd programs && emake || die
+
+}
+
+src_install () {
+
+ local WINEMAKEOPTS="prefix=${D}/usr \
+ mandir=${D}/usr/wine/man \
+ includedir=${D}/usr/wine/include \
+ exec_prefix=${D}/usr/wine"
+
+ cd ${S}
+ make ${WINEMAKEOPTS} install || die
+ cd ${S}/programs
+ make ${WINEMAKEOPTS} install || die
+
+ # these .so's are strange. they are from the make in programs/ above,
+ # and are for apps built with winelib (windows sources built directly
+ # against wine). Apparently the sources go into a <program name>.so file
+ # and you run it via a symlink <program name> -> wine. Unfortunately both
+ # the symlink and the .so apparently must reside in /usr/bin.
+ cd ${D}/usr/wine/bin
+ chmod a-x *.so
+
+ cd ${S}
+ dodoc ANNOUNCE AUTHORS BUGS ChangeLog DEVELOPERS-HINTS LICENSE README
+
+ cd ${S}/documentation
+ DESTTREE=/usr/wine doman man3w/*
+ # sgml was being filtered without -a sgml
+ dohtml -a sgml *.sgml
+
+ insinto /etc/wine
+ doins samples/*
+ doins ${S}/winedefault.reg
+
+ dodir /etc/skel/.wine
+ dosym /etc/wine/config /etc/skel/.wine/config
+
+ insinto /etc/env.d
+ doins ${FILESDIR}/80wine
+}
+
+pkg_postinst() {
+
+ einfo "If you are installing wine for the first time,
+copy /etc/wine/config (global configuration) to ~/.wine/config
+and edit that for per-user configuration. Otherwise, wine will
+not run.
+Also, run \"regapi setValue < /etc/wine/winedefault.reg\" to setup
+per-user registry for using wine. More info in /usr/share/doc/wine-${PV}."
+
+}
+