summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--xfce-extra/xfce4-linelight-plugin/ChangeLog7
-rw-r--r--xfce-extra/xfce4-linelight-plugin/files/xfce4-linelight-plugin-0.1.6-libxfce4panel_h.patch25
-rw-r--r--xfce-extra/xfce4-linelight-plugin/xfce4-linelight-plugin-0.1.6.ebuild7
3 files changed, 35 insertions, 4 deletions
diff --git a/xfce-extra/xfce4-linelight-plugin/ChangeLog b/xfce-extra/xfce4-linelight-plugin/ChangeLog
index ad36272ee8a1..8d201c9d3074 100644
--- a/xfce-extra/xfce4-linelight-plugin/ChangeLog
+++ b/xfce-extra/xfce4-linelight-plugin/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for xfce-extra/xfce4-linelight-plugin
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/xfce-extra/xfce4-linelight-plugin/ChangeLog,v 1.3 2010/01/15 03:17:00 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/xfce-extra/xfce4-linelight-plugin/ChangeLog,v 1.4 2010/09/22 11:51:49 ssuominen Exp $
+
+ 22 Sep 2010; Samuli Suominen <ssuominen@gentoo.org>
+ xfce4-linelight-plugin-0.1.6.ebuild,
+ +files/xfce4-linelight-plugin-0.1.6-libxfce4panel_h.patch:
+ Fix building with xfce4-panel >= 4.7.
15 Jan 2010; Samuli Suominen <ssuominen@gentoo.org>
xfce4-linelight-plugin-0.1.6.ebuild:
diff --git a/xfce-extra/xfce4-linelight-plugin/files/xfce4-linelight-plugin-0.1.6-libxfce4panel_h.patch b/xfce-extra/xfce4-linelight-plugin/files/xfce4-linelight-plugin-0.1.6-libxfce4panel_h.patch
new file mode 100644
index 000000000000..cca95d55bc4d
--- /dev/null
+++ b/xfce-extra/xfce4-linelight-plugin/files/xfce4-linelight-plugin-0.1.6-libxfce4panel_h.patch
@@ -0,0 +1,25 @@
+--- panel-plugin/linelight.c
++++ panel-plugin/linelight.c
+@@ -21,8 +21,7 @@
+
+ #include <libxfcegui4/libxfcegui4.h>
+
+-#include <libxfce4panel/xfce-panel-plugin.h>
+-#include <libxfce4panel/xfce-panel-convenience.h>
++#include <libxfce4panel/libxfce4panel.h>
+
+ #include <thunar-vfs/thunar-vfs.h>
+
+--- panel-plugin/main.c
++++ panel-plugin/main.c
+@@ -32,9 +32,7 @@
+
+ #include <libxfcegui4/libxfcegui4.h>
+
+-#include <libxfce4panel/xfce-panel-window.h>
+-#include <libxfce4panel/xfce-panel-plugin.h>
+-#include <libxfce4panel/xfce-panel-convenience.h>
++#include <libxfce4panel/libxfce4panel.h>
+
+ #include "linelight.h"
+ #include "defines.h"
diff --git a/xfce-extra/xfce4-linelight-plugin/xfce4-linelight-plugin-0.1.6.ebuild b/xfce-extra/xfce4-linelight-plugin/xfce4-linelight-plugin-0.1.6.ebuild
index 0588280a1bf8..ea085936507d 100644
--- a/xfce-extra/xfce4-linelight-plugin/xfce4-linelight-plugin-0.1.6.ebuild
+++ b/xfce-extra/xfce4-linelight-plugin/xfce4-linelight-plugin-0.1.6.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/xfce-extra/xfce4-linelight-plugin/xfce4-linelight-plugin-0.1.6.ebuild,v 1.3 2010/01/15 03:17:00 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/xfce-extra/xfce4-linelight-plugin/xfce4-linelight-plugin-0.1.6.ebuild,v 1.4 2010/09/22 11:51:49 ssuominen Exp $
EAPI=2
inherit xfconf
@@ -16,7 +16,7 @@ IUSE=""
RDEPEND=">=xfce-base/xfce4-panel-4.4
>=xfce-base/libxfcegui4-4.4
- <xfce-base/thunar-1.1.0
+ || ( xfce-extra/thunar-vfs <xfce-base/thunar-1.1.0 )
>=x11-libs/gtk+-2.12:2
>=dev-libs/glib-2.16:2"
DEPEND="${RDEPEND}
@@ -24,6 +24,7 @@ DEPEND="${RDEPEND}
sys-devel/gettext"
pkg_setup() {
- DOCS="AUTHORS ChangeLog NEWS"
+ PATCHES=( "${FILESDIR}"/${P}-libxfce4panel_h.patch )
XFCONF="--disable-dependency-tracking"
+ DOCS="AUTHORS ChangeLog NEWS"
}