summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--media-sound/xmms2/ChangeLog7
-rw-r--r--media-sound/xmms2/files/xmms2-0.8-memset.patch19
-rw-r--r--media-sound/xmms2/xmms2-0.8-r1.ebuild4
-rw-r--r--media-sound/xmms2/xmms2-0.8-r2.ebuild3
4 files changed, 30 insertions, 3 deletions
diff --git a/media-sound/xmms2/ChangeLog b/media-sound/xmms2/ChangeLog
index a9cf8f93d441..5ba8fefdc198 100644
--- a/media-sound/xmms2/ChangeLog
+++ b/media-sound/xmms2/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-sound/xmms2
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/xmms2/ChangeLog,v 1.34 2013/08/05 19:41:46 slyfox Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/xmms2/ChangeLog,v 1.35 2013/11/22 13:10:47 slyfox Exp $
+
+ 22 Nov 2013; Sergei Trofimovich <slyfox@gentoo.org>
+ +files/xmms2-0.8-memset.patch, xmms2-0.8-r1.ebuild, xmms2-0.8-r2.ebuild:
+ Fix build failure in stable 0.8-r1 (backported cython tweak). Thanks to Yury
+ Gavrilovich. Pull missing 'memset()' declaration on new glibc.
*xmms2-0.8-r2 (05 Aug 2013)
diff --git a/media-sound/xmms2/files/xmms2-0.8-memset.patch b/media-sound/xmms2/files/xmms2-0.8-memset.patch
new file mode 100644
index 000000000000..6f8377d9f928
--- /dev/null
+++ b/media-sound/xmms2/files/xmms2-0.8-memset.patch
@@ -0,0 +1,19 @@
+commit 00f4736bbb8ebc88a08e24e98d384b43d5afbbe4
+Author: Raphaël Bois <virtualdust@gmail.com>
+Date: Sun Feb 12 16:39:46 2012 +0100
+
+ OTHER: fix erroneous sizeof usage
+
+diff --git a/src/plugins/daap/daap_md5.c b/src/plugins/daap/daap_md5.c
+index d4d8d74..69c84a5 100644
+--- a/src/plugins/daap/daap_md5.c
++++ b/src/plugins/daap/daap_md5.c
+@@ -191,7 +191,7 @@ OpenDaap_MD5Final (MD5_CTX *ctx,
+ MD5Transform (ctx->buf, (guint32 *) ctx->in, ctx->version);
+ byteReverse ((unsigned char *) ctx->buf, 4);
+ memcpy (digest, ctx->buf, 16);
+- memset (ctx, 0, sizeof (ctx)); /* In case it's sensitive */
++ memset (ctx, 0, sizeof (*ctx)); /* In case it's sensitive */
+
+ return;
+ }
diff --git a/media-sound/xmms2/xmms2-0.8-r1.ebuild b/media-sound/xmms2/xmms2-0.8-r1.ebuild
index 8cac9b681311..b629ffad3e54 100644
--- a/media-sound/xmms2/xmms2-0.8-r1.ebuild
+++ b/media-sound/xmms2/xmms2-0.8-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/xmms2/xmms2-0.8-r1.ebuild,v 1.13 2013/01/18 08:05:25 slyfox Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/xmms2/xmms2-0.8-r1.ebuild,v 1.14 2013/11/22 13:10:47 slyfox Exp $
EAPI=3
@@ -110,6 +110,8 @@ src_prepare() {
epatch "${FILESDIR}/${P}"-ffmpeg-0.11.patch #443256
epatch "${FILESDIR}/${P}"-libav-9-p2.patch #443256
epatch "${FILESDIR}/${P}"-libav-9.patch #443256
+ epatch "${FILESDIR}/${P}"-cython-0.19.1.patch
+ epatch "${FILESDIR}/${P}"-memset.patch
if has_version dev-libs/libcdio-paranoia; then
sed -i -e 's:cdio/cdda.h:cdio/paranoia/cdda.h:' src/plugins/cdda/cdda.c || die
diff --git a/media-sound/xmms2/xmms2-0.8-r2.ebuild b/media-sound/xmms2/xmms2-0.8-r2.ebuild
index 00a8da7d9d58..481407354773 100644
--- a/media-sound/xmms2/xmms2-0.8-r2.ebuild
+++ b/media-sound/xmms2/xmms2-0.8-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/xmms2/xmms2-0.8-r2.ebuild,v 1.1 2013/08/05 19:41:46 slyfox Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/xmms2/xmms2-0.8-r2.ebuild,v 1.2 2013/11/22 13:10:47 slyfox Exp $
EAPI=3
@@ -111,6 +111,7 @@ src_prepare() {
epatch "${FILESDIR}/${P}"-libav-9-p2.patch #443256
epatch "${FILESDIR}/${P}"-libav-9.patch #443256
epatch "${FILESDIR}/${P}"-cython-0.19.1.patch
+ epatch "${FILESDIR}/${P}"-memset.patch
if has_version dev-libs/libcdio-paranoia; then
sed -i -e 's:cdio/cdda.h:cdio/paranoia/cdda.h:' src/plugins/cdda/cdda.c || die