summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net-mail/dbmail/ChangeLog9
-rw-r--r--net-mail/dbmail/dbmail-2.2.7_rc1.ebuild101
-rw-r--r--net-mail/dbmail/dbmail-2.2.7_rc2.ebuild101
-rw-r--r--net-mail/dbmail/files/digest-dbmail-2.2.7_rc13
-rw-r--r--net-mail/dbmail/files/digest-dbmail-2.2.7_rc23
5 files changed, 216 insertions, 1 deletions
diff --git a/net-mail/dbmail/ChangeLog b/net-mail/dbmail/ChangeLog
index 5891fd4d3763..2edf8dbb768b 100644
--- a/net-mail/dbmail/ChangeLog
+++ b/net-mail/dbmail/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-mail/dbmail
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-mail/dbmail/ChangeLog,v 1.7 2007/09/10 18:14:20 lordvan Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-mail/dbmail/ChangeLog,v 1.8 2007/09/30 08:21:11 lordvan Exp $
+
+*dbmail-2.2.7_rc2 (30 Sep 2007)
+*dbmail-2.2.7_rc1 (30 Sep 2007)
+
+ 30 Sep 2007; Thomas Raschbacher <lordvan@gentoo.org>
+ +dbmail-2.2.7_rc1.ebuild, +dbmail-2.2.7_rc2.ebuild:
+ added 2.2.7 rc1 and rc2 ebuilds
*dbmail-2.2.6_rc2 (10 Sep 2007)
diff --git a/net-mail/dbmail/dbmail-2.2.7_rc1.ebuild b/net-mail/dbmail/dbmail-2.2.7_rc1.ebuild
new file mode 100644
index 000000000000..4fca79f4ba36
--- /dev/null
+++ b/net-mail/dbmail/dbmail-2.2.7_rc1.ebuild
@@ -0,0 +1,101 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-mail/dbmail/dbmail-2.2.7_rc1.ebuild,v 1.1 2007/09/30 08:21:11 lordvan Exp $
+
+inherit eutils
+
+MY_P="${P/_/-}" # for rcX
+#MY_P="${P}" # releases
+DESCRIPTION="A mail storage and retrieval daemon that uses MySQL or PostgreSQL as its data store"
+HOMEPAGE="http://www.dbmail.org/"
+SRC_URI="http://www.dbmail.org/download/2.2/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="ldap mysql postgres sieve sqlite3 ssl static"
+
+DEPEND="ssl? ( dev-libs/openssl )
+ postgres? ( >=dev-db/postgresql-7.4 )
+ mysql? ( >=virtual/mysql-4.1 )
+ sqlite3? ( >=dev-db/sqlite-3.0 )
+ sieve? ( >=mail-filter/libsieve-2.2.1 )
+ app-text/asciidoc
+ app-text/xmlto
+ sys-libs/zlib
+ >=dev-libs/gmime-2.1.18
+ >=dev-libs/glib-2.8"
+
+S=${WORKDIR}/${P/_/-}
+
+pkg_setup() {
+ enewgroup dbmail
+ enewuser dbmail -1 -1 /var/lib/dbmail dbmail
+}
+
+src_compile() {
+ use sqlite3 && myconf="--with-sqlite"
+ use ldap && myconf=${myconf}" --with-auth-ldap"
+
+ econf \
+ --sysconfdir=/etc/dbmail \
+ ${myconf} \
+ $(use_enable static) \
+ $(use_with sieve) \
+ $(use_with ssl) \
+ $(use_with postgres pgsql) \
+ $(use_with mysql) \
+ || die "econf failed"
+
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+
+ dodoc AUTHORS BUGS UPGRADING ChangeLog README* INSTALL* NEWS THANKS
+ dodoc sql/mysql/*
+ dodoc sql/postgresql/*
+ dodoc sql/sqlite/*
+
+ cp dbmail.conf.dist dbmail.conf
+ sed -i -e "s:nobody:dbmail:" dbmail.conf
+ sed -i -e "s:nogroup:dbmail:" dbmail.conf
+ #sed -i -e "s:#library_directory:library_directory:" dbmail.conf
+ insinto /etc/dbmail
+ newins dbmail.conf dbmail.conf.dist
+
+ newinitd "${FILESDIR}"/dbmail-imapd.initd dbmail-imapd
+ newinitd "${FILESDIR}"/dbmail-lmtpd.initd dbmail-lmtpd
+ newinitd "${FILESDIR}"/dbmail-pop3d.initd dbmail-pop3d
+ use sieve && newinitd "${FILESDIR}"/dbmail-timsieved.initd dbmail-timsieved
+
+ dobin contrib/mailbox2dbmail/mailbox2dbmail
+ doman contrib/mailbox2dbmail/mailbox2dbmail.1
+
+ keepdir /var/lib/dbmail
+ fperms 750 /var/lib/dbmail
+
+}
+
+pkg_postinst() {
+ elog "Please read /usr/share/doc/${PF}/INSTALL.gz"
+ elog "for remaining instructions on setting up dbmail users and "
+ elog "for finishing configuration to connect to your MTA and "
+ elog "to connect to your db."
+ echo
+ elog "Database schemes can be found in /usr/share/doc/${PF}/"
+ elog "You will also want to follow the installation instructions"
+ elog "on setting up the maintenance program to delete old messages."
+ elog "Don't forget to edit /etc/dbmail/dbmail.conf as well."
+ echo
+ elog "For regular maintenance, add this to crontab:"
+ elog "0 3 * * * /usr/bin/dbmail-util -cpdy >/dev/null 2>&1"
+ echo
+ elog "Please make sure to run etc-update."
+ elog "If you get an error message about plugins not found"
+ elog "please add the library_directory configuration switch to"
+ elog "dbmail.conf and set it to the correct path"
+ elog "(usually /usr/lib/dbmail or /usr/lib64/dbmail on amd64)"
+ elog "A sample can be found in dbmail.conf.dist after etc-update."
+}
diff --git a/net-mail/dbmail/dbmail-2.2.7_rc2.ebuild b/net-mail/dbmail/dbmail-2.2.7_rc2.ebuild
new file mode 100644
index 000000000000..b5191a4dd0fa
--- /dev/null
+++ b/net-mail/dbmail/dbmail-2.2.7_rc2.ebuild
@@ -0,0 +1,101 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-mail/dbmail/dbmail-2.2.7_rc2.ebuild,v 1.1 2007/09/30 08:21:11 lordvan Exp $
+
+inherit eutils
+
+MY_P="${P/_/-}" # for rcX
+#MY_P="${P}" # releases
+DESCRIPTION="A mail storage and retrieval daemon that uses MySQL or PostgreSQL as its data store"
+HOMEPAGE="http://www.dbmail.org/"
+SRC_URI="http://www.dbmail.org/download/2.2/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="ldap mysql postgres sieve sqlite3 ssl static"
+
+DEPEND="ssl? ( dev-libs/openssl )
+ postgres? ( >=dev-db/postgresql-7.4 )
+ mysql? ( >=virtual/mysql-4.1 )
+ sqlite3? ( >=dev-db/sqlite-3.0 )
+ sieve? ( >=mail-filter/libsieve-2.2.1 )
+ app-text/asciidoc
+ app-text/xmlto
+ sys-libs/zlib
+ >=dev-libs/gmime-2.1.18
+ >=dev-libs/glib-2.8"
+
+S=${WORKDIR}/${P/_/-}
+
+pkg_setup() {
+ enewgroup dbmail
+ enewuser dbmail -1 -1 /var/lib/dbmail dbmail
+}
+
+src_compile() {
+ use sqlite3 && myconf="--with-sqlite"
+ use ldap && myconf=${myconf}" --with-auth-ldap"
+
+ econf \
+ --sysconfdir=/etc/dbmail \
+ ${myconf} \
+ $(use_enable static) \
+ $(use_with sieve) \
+ $(use_with ssl) \
+ $(use_with postgres pgsql) \
+ $(use_with mysql) \
+ || die "econf failed"
+
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+
+ dodoc AUTHORS BUGS UPGRADING ChangeLog README* INSTALL* NEWS THANKS
+ dodoc sql/mysql/*
+ dodoc sql/postgresql/*
+ dodoc sql/sqlite/*
+
+ cp dbmail.conf.dist dbmail.conf
+ sed -i -e "s:nobody:dbmail:" dbmail.conf
+ sed -i -e "s:nogroup:dbmail:" dbmail.conf
+ #sed -i -e "s:#library_directory:library_directory:" dbmail.conf
+ insinto /etc/dbmail
+ newins dbmail.conf dbmail.conf.dist
+
+ newinitd "${FILESDIR}"/dbmail-imapd.initd dbmail-imapd
+ newinitd "${FILESDIR}"/dbmail-lmtpd.initd dbmail-lmtpd
+ newinitd "${FILESDIR}"/dbmail-pop3d.initd dbmail-pop3d
+ use sieve && newinitd "${FILESDIR}"/dbmail-timsieved.initd dbmail-timsieved
+
+ dobin contrib/mailbox2dbmail/mailbox2dbmail
+ doman contrib/mailbox2dbmail/mailbox2dbmail.1
+
+ keepdir /var/lib/dbmail
+ fperms 750 /var/lib/dbmail
+
+}
+
+pkg_postinst() {
+ elog "Please read /usr/share/doc/${PF}/INSTALL.gz"
+ elog "for remaining instructions on setting up dbmail users and "
+ elog "for finishing configuration to connect to your MTA and "
+ elog "to connect to your db."
+ echo
+ elog "Database schemes can be found in /usr/share/doc/${PF}/"
+ elog "You will also want to follow the installation instructions"
+ elog "on setting up the maintenance program to delete old messages."
+ elog "Don't forget to edit /etc/dbmail/dbmail.conf as well."
+ echo
+ elog "For regular maintenance, add this to crontab:"
+ elog "0 3 * * * /usr/bin/dbmail-util -cpdy >/dev/null 2>&1"
+ echo
+ elog "Please make sure to run etc-update."
+ elog "If you get an error message about plugins not found"
+ elog "please add the library_directory configuration switch to"
+ elog "dbmail.conf and set it to the correct path"
+ elog "(usually /usr/lib/dbmail or /usr/lib64/dbmail on amd64)"
+ elog "A sample can be found in dbmail.conf.dist after etc-update."
+}
diff --git a/net-mail/dbmail/files/digest-dbmail-2.2.7_rc1 b/net-mail/dbmail/files/digest-dbmail-2.2.7_rc1
new file mode 100644
index 000000000000..50a3c235429b
--- /dev/null
+++ b/net-mail/dbmail/files/digest-dbmail-2.2.7_rc1
@@ -0,0 +1,3 @@
+MD5 da3322c60a47118d1356d6f2c3a7a556 dbmail-2.2.7-rc1.tar.gz 893945
+RMD160 50f400e9c09a6f3f353ecfd9fc27e21a7d7a499d dbmail-2.2.7-rc1.tar.gz 893945
+SHA256 62a0b61b32f1aa9b86a9555cf9ce92114eec05074ac357551e9ff72888dea4bd dbmail-2.2.7-rc1.tar.gz 893945
diff --git a/net-mail/dbmail/files/digest-dbmail-2.2.7_rc2 b/net-mail/dbmail/files/digest-dbmail-2.2.7_rc2
new file mode 100644
index 000000000000..d123385ed3f3
--- /dev/null
+++ b/net-mail/dbmail/files/digest-dbmail-2.2.7_rc2
@@ -0,0 +1,3 @@
+MD5 82dbf903895ff785b22b0fdeee833b9c dbmail-2.2.7-rc2.tar.gz 894380
+RMD160 ef1299c748c3fb9349f8ed9d56a64674761053a0 dbmail-2.2.7-rc2.tar.gz 894380
+SHA256 6676a982a406f96a5a8e809ec576f9b04cebdf8326ef4311f5bfb1ed1fb584d8 dbmail-2.2.7-rc2.tar.gz 894380