summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-python/pycdf/ChangeLog7
-rw-r--r--dev-python/pycdf/Manifest2
-rw-r--r--dev-python/pycdf/files/digest-pycdf-0.5.21
-rw-r--r--dev-python/pycdf/metadata.xml5
-rw-r--r--dev-python/pycdf/pycdf-0.5.2.ebuild28
5 files changed, 43 insertions, 0 deletions
diff --git a/dev-python/pycdf/ChangeLog b/dev-python/pycdf/ChangeLog
new file mode 100644
index 000000000000..52ef2df526eb
--- /dev/null
+++ b/dev-python/pycdf/ChangeLog
@@ -0,0 +1,7 @@
+# ChangeLog for dev-python/pycdf
+# Copyright 2000-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pycdf/ChangeLog,v 1.1 2004/05/25 09:17:39 kloeri Exp $
+
+ 25 May 2004; Bryan Østergaard <kloeri@gentoo.org> +metadata.xml:
+ Initial import, bug #46691.
+
diff --git a/dev-python/pycdf/Manifest b/dev-python/pycdf/Manifest
new file mode 100644
index 000000000000..0c52baac82af
--- /dev/null
+++ b/dev-python/pycdf/Manifest
@@ -0,0 +1,2 @@
+MD5 ef9cb2b1770918839c144458f9c8a6eb pycdf-0.5.2.ebuild 691
+MD5 21a94dfa5dfdd3fc5cbc23d21a5bbd75 files/digest-pycdf-0.5.2 62
diff --git a/dev-python/pycdf/files/digest-pycdf-0.5.2 b/dev-python/pycdf/files/digest-pycdf-0.5.2
new file mode 100644
index 000000000000..be30bb46cff9
--- /dev/null
+++ b/dev-python/pycdf/files/digest-pycdf-0.5.2
@@ -0,0 +1 @@
+MD5 2960376d91153bb8d1fb4d5ebe3e0d28 pycdf-0.5-2.tar.gz 76368
diff --git a/dev-python/pycdf/metadata.xml b/dev-python/pycdf/metadata.xml
new file mode 100644
index 000000000000..de483c53568f
--- /dev/null
+++ b/dev-python/pycdf/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>python</herd>
+</pkgmetadata>
diff --git a/dev-python/pycdf/pycdf-0.5.2.ebuild b/dev-python/pycdf/pycdf-0.5.2.ebuild
new file mode 100644
index 000000000000..436417426ac9
--- /dev/null
+++ b/dev-python/pycdf/pycdf-0.5.2.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pycdf/pycdf-0.5.2.ebuild,v 1.1 2004/05/25 09:17:39 kloeri Exp $
+
+inherit distutils
+
+MY_P=${PN}-${PV:0:3}-${PV:4:1}
+S=${WORKDIR}/${MY_P}
+
+DESCRIPTION="The pycdf package wraps the complete functionality of the Unidata netcdf library..."
+HOMEPAGE="ftp://nordet.qc.dfo-mpo.gc.ca/pub/soft/pycdf"
+SRC_URI="ftp://nordet.qc.dfo-mpo.gc.ca/pub/soft/pycdf/${MY_P}.tar.gz"
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE="doc"
+
+DEPEND="virtual/python
+ >=app-sci/netcdf-3.5.0-r3"
+
+DOCS="CHANGES doc/pycdf.txt"
+
+src_install() {
+ distutils_src_install
+ use doc && ( cp -R examples ${D}/usr/share/doc/${PF}
+ dohtml doc/pycdf.html )
+}