summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sci-chemistry/relax/ChangeLog10
-rw-r--r--sci-chemistry/relax/files/relax-2.2.1-gentoo.patch49
-rw-r--r--sci-chemistry/relax/metadata.xml10
-rw-r--r--sci-chemistry/relax/relax-2.2.1.ebuild59
4 files changed, 121 insertions, 7 deletions
diff --git a/sci-chemistry/relax/ChangeLog b/sci-chemistry/relax/ChangeLog
index 557f781a3ed9..df31c81ee3cd 100644
--- a/sci-chemistry/relax/ChangeLog
+++ b/sci-chemistry/relax/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sci-chemistry/relax
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/relax/ChangeLog,v 1.1 2012/07/19 16:05:51 jlec Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/relax/ChangeLog,v 1.2 2013/02/04 07:57:56 jlec Exp $
+
+*relax-2.2.1 (04 Feb 2013)
+
+ 04 Feb 2013; Justin Lecher <jlec@gentoo.org> +relax-2.2.1.ebuild,
+ +files/relax-2.2.1-gentoo.patch, metadata.xml:
+ Version BUmp
*relax-2.1.0 (19 Jul 2012)
diff --git a/sci-chemistry/relax/files/relax-2.2.1-gentoo.patch b/sci-chemistry/relax/files/relax-2.2.1-gentoo.patch
new file mode 100644
index 000000000000..073a46eb386d
--- /dev/null
+++ b/sci-chemistry/relax/files/relax-2.2.1-gentoo.patch
@@ -0,0 +1,49 @@
+ scons/install.py | 10 ----------
+ sconstruct | 6 +++++-
+ 2 files changed, 5 insertions(+), 11 deletions(-)
+
+diff --git a/scons/install.py b/scons/install.py
+index b2d355a..d7c7911 100644
+--- a/scons/install.py
++++ b/scons/install.py
+@@ -109,16 +109,6 @@ def install(target, source, env):
+ symlink(env['RELAX_PATH'] + sep + 'relax', env['SYMLINK'])
+
+
+- # Byte compile.
+- ###############
+-
+- # Run relax to create the *.pyc files.
+- print("\nCreating the byte-compiled *.pyc files.")
+- python_path = sys.prefix + path.sep + 'bin' + path.sep + 'python' + `sys.version_info[0]` + '.' + `sys.version_info[1]`
+- cmd = "cd %s; %s -m compileall . ; %s -O -m compileall ." % (env['RELAX_PATH'], python_path, python_path)
+- print(cmd)
+- system(cmd)
+-
+ # Final printout.
+ print("\n\n\n")
+
+diff --git a/sconstruct b/sconstruct
+index 8e968cd..8e7d949 100644
+--- a/sconstruct
++++ b/sconstruct
+@@ -26,7 +26,7 @@
+
+ # Import statements.
+ from numpy import get_include
+-from os import getcwd, path, remove, rmdir, sep, walk
++from os import getcwd, path, remove, rmdir, sep, walk, environ
+ import platform
+ from re import search
+ from shutil import rmtree
+@@ -596,6 +596,10 @@ class Main:
+ for file in files:
+ nodes.append(env.SharedObject(dir + path.sep + file, CCFLAGS=cflags))
+
++ env.Append(LINKFLAGS = environ['LDFLAGS'])
++ env.Append(CFLAGS = environ['CFLAGS'])
++ env.Replace(CC = environ['CC'])
++
+ # Build the relaxation curve fitting module.
+ self.relax_fit_object = env.SharedLibrary(target=dir + path.sep + 'relax_fit', source=nodes, SHLIBPREFIX=prefix, SHLIBSUFFIX=suffix)
+
diff --git a/sci-chemistry/relax/metadata.xml b/sci-chemistry/relax/metadata.xml
index b1c325bde991..617e574f7c34 100644
--- a/sci-chemistry/relax/metadata.xml
+++ b/sci-chemistry/relax/metadata.xml
@@ -1,11 +1,11 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <herd>sci-chemistry</herd>
- <maintainer>
- <email>jlec@gentoo.org</email>
- </maintainer>
- <longdescription>
+ <herd>sci-chemistry</herd>
+ <maintainer>
+ <email>jlec@gentoo.org</email>
+ </maintainer>
+ <longdescription>
The program relax is a software package designed for the study of molecular
dynamics through the analysis of experimental NMR data. Organic molecules,
proteins, RNA, DNA, sugars, and other biomolecules are all supported. It
diff --git a/sci-chemistry/relax/relax-2.2.1.ebuild b/sci-chemistry/relax/relax-2.2.1.ebuild
new file mode 100644
index 000000000000..999a43b65adb
--- /dev/null
+++ b/sci-chemistry/relax/relax-2.2.1.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/relax/relax-2.2.1.ebuild,v 1.1 2013/02/04 07:57:56 jlec Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_5,2_6,2_7,3_1,3_2} )
+
+WX_GTK_VER="2.8"
+
+inherit eutils python-single-r1 scons-utils toolchain-funcs wxwidgets
+
+DESCRIPTION="Molecular dynamics by NMR data analysis"
+HOMEPAGE="http://www.nmr-relax.com/"
+SRC_URI="http://download.gna.org/relax/${P}.src.tar.bz2"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+RDEPEND="
+ dev-python/numpy[${PYTHON_USEDEP}]
+ >=sci-libs/bmrblib-1.0.1_pre198[${PYTHON_USEDEP}]
+ >=sci-libs/minfx-1.0.4_pre98[${PYTHON_USEDEP}]
+ sci-libs/scipy
+ x11-libs/wxGTK:2.8[X]"
+DEPEND="${RDEPEND}"
+
+pkg_setup() {
+ wxwidgets_pkg_setup
+ python-single-r1_pkg_setup
+}
+
+src_prepare() {
+ rm -rf minfx bmrblib || die
+ epatch "${FILESDIR}"/${P}-gentoo.patch
+ echo true > devel_scripts/byte_compile || die
+ tc-export CC
+}
+
+src_compile() {
+ escons
+}
+
+src_test() {
+ ${EPYTHON} ./${PN}.py -s || die
+ ${EPYTHON} ./${PN}.py -x || die
+}
+
+src_install() {
+ dodoc README
+ rm ${PN} README || die
+
+ python_moduleinto ${PN}
+ python_domodule *
+
+ make_wrapper ${PN} "${EPYTHON} $(python_get_sitedir)/${PN}/${PN}.py $@"
+}