summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net-print/cups-filters/ChangeLog9
-rw-r--r--net-print/cups-filters/cups-filters-1.0.30.ebuild104
-rw-r--r--net-print/cups-filters/cups-filters-9999-r1.ebuild4
-rw-r--r--net-print/cups-filters/files/cups-filters-1.0.30-noavahi.patch35
4 files changed, 149 insertions, 3 deletions
diff --git a/net-print/cups-filters/ChangeLog b/net-print/cups-filters/ChangeLog
index 47f09275c60c..ae4e4dc7e8c7 100644
--- a/net-print/cups-filters/ChangeLog
+++ b/net-print/cups-filters/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-print/cups-filters
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-print/cups-filters/ChangeLog,v 1.51 2013/02/21 11:41:20 scarabeus Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-print/cups-filters/ChangeLog,v 1.52 2013/03/17 15:39:45 dilfridge Exp $
+
+*cups-filters-1.0.30 (17 Mar 2013)
+
+ 17 Mar 2013; Andreas K. Huettel <dilfridge@gentoo.org>
+ +cups-filters-1.0.30.ebuild, +files/cups-filters-1.0.30-noavahi.patch,
+ cups-filters-9999-r1.ebuild:
+ Version bump; poppler subslot dependencies
*cups-filters-1.0.29-r1 (21 Feb 2013)
*cups-filters-9999-r1 (21 Feb 2013)
diff --git a/net-print/cups-filters/cups-filters-1.0.30.ebuild b/net-print/cups-filters/cups-filters-1.0.30.ebuild
new file mode 100644
index 000000000000..cc9f14630407
--- /dev/null
+++ b/net-print/cups-filters/cups-filters-1.0.30.ebuild
@@ -0,0 +1,104 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-print/cups-filters/cups-filters-1.0.30.ebuild,v 1.1 2013/03/17 15:39:45 dilfridge Exp $
+
+EAPI=5
+
+GENTOO_DEPEND_ON_PERL=no
+
+inherit base eutils perl-module autotools
+
+if [[ "${PV}" == "9999" ]] ; then
+ inherit bzr
+ EBZR_REPO_URI="http://bzr.linuxfoundation.org/openprinting/cups-filters"
+ KEYWORDS=""
+else
+ SRC_URI="http://www.openprinting.org/download/${PN}/${P}.tar.xz"
+ KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-fbsd"
+fi
+DESCRIPTION="Cups PDF filters"
+HOMEPAGE="http://www.linuxfoundation.org/collaborate/workgroups/openprinting/pdfasstandardprintjobformat"
+
+LICENSE="MIT GPL-2"
+SLOT="0"
+IUSE="avahi jpeg perl png static-libs tiff"
+
+RDEPEND="
+ app-text/ghostscript-gpl
+ app-text/poppler:=[cxx,jpeg?,lcms,tiff?,xpdf-headers(+)]
+ >=app-text/qpdf-3.0.2
+ media-libs/fontconfig
+ media-libs/freetype:2
+ media-libs/lcms:2
+ >net-print/cups-1.5.9999
+ !<=net-print/cups-1.5.9999
+ sys-devel/bc
+ sys-libs/zlib
+ avahi? ( net-dns/avahi )
+ jpeg? ( virtual/jpeg )
+ perl? ( dev-lang/perl )
+ png? ( media-libs/libpng )
+ tiff? ( media-libs/tiff )
+"
+DEPEND="${RDEPEND}"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-1.0.29-openrc.patch"
+ "${FILESDIR}/${PN}-1.0.30-noavahi.patch"
+)
+
+src_prepare() {
+ base_src_prepare
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --docdir="${EPREFIX}/usr/share/doc/${PF}" \
+ $(use_enable avahi) \
+ $(use_enable static-libs static) \
+ --with-fontdir="fonts/conf.avail" \
+ --with-pdftops=pdftops \
+ --enable-imagefilters \
+ $(use_with jpeg) \
+ $(use_with png) \
+ $(use_with tiff) \
+ --without-php
+}
+
+src_compile() {
+ default
+
+ if use perl; then
+ pushd "${S}/scripting/perl" > /dev/null
+ perl-module_src_prep
+ perl-module_src_compile
+ popd > /dev/null
+ fi
+}
+
+src_install() {
+ default
+
+ if use perl; then
+ pushd "${S}/scripting/perl" > /dev/null
+ perl-module_src_install
+ fixlocalpod
+ popd > /dev/null
+ fi
+
+ prune_libtool_files --all
+
+ use avahi && newinitd "${FILESDIR}"/cups-browsed.init.d cups-browsed
+}
+
+pkg_postinst() {
+ perl-module_pkg_postinst
+
+ if use avahi; then
+ elog "This version of cups-filters includes cups-browsed, a daemon that autodiscovers"
+ elog "remote queues via avahi and adds them to your cups configuration. You may want"
+ elog "to add it to your default runlevel. Then again, you may not want to do that,"
+ elog "since it is completely untested, may kill kittens or get you r00ted. Your choice."
+ fi
+}
diff --git a/net-print/cups-filters/cups-filters-9999-r1.ebuild b/net-print/cups-filters/cups-filters-9999-r1.ebuild
index eb8e71011bca..3002fe86a0a2 100644
--- a/net-print/cups-filters/cups-filters-9999-r1.ebuild
+++ b/net-print/cups-filters/cups-filters-9999-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-print/cups-filters/cups-filters-9999-r1.ebuild,v 1.1 2013/02/21 11:41:20 scarabeus Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-print/cups-filters/cups-filters-9999-r1.ebuild,v 1.2 2013/03/17 15:39:45 dilfridge Exp $
EAPI=5
@@ -25,7 +25,7 @@ IUSE="avahi jpeg perl png static-libs tiff"
RDEPEND="
app-text/ghostscript-gpl
- app-text/poppler[cxx,jpeg?,lcms,tiff?,xpdf-headers(+)]
+ app-text/poppler:=[cxx,jpeg?,lcms,tiff?,xpdf-headers(+)]
>=app-text/qpdf-3.0.2
media-libs/fontconfig
media-libs/freetype:2
diff --git a/net-print/cups-filters/files/cups-filters-1.0.30-noavahi.patch b/net-print/cups-filters/files/cups-filters-1.0.30-noavahi.patch
new file mode 100644
index 000000000000..1177f4d8f99e
--- /dev/null
+++ b/net-print/cups-filters/files/cups-filters-1.0.30-noavahi.patch
@@ -0,0 +1,35 @@
+diff -ruN cups-filters-1.0.30.orig/configure.ac cups-filters-1.0.30/configure.ac
+--- cups-filters-1.0.30.orig/configure.ac 2013-03-07 19:19:51.000000000 +0100
++++ cups-filters-1.0.30/configure.ac 2013-03-17 16:34:35.000000000 +0100
+@@ -204,6 +204,10 @@
+ dnl Check for pkg-config, which is used for some other tests later on...
+ AC_PATH_PROG(PKGCONFIG, pkg-config)
+
++PKG_CHECK_MODULES(GLIB, [glib-2.0 >= 2.30.2])
++AC_SUBST(GLIB_CFLAGS)
++AC_SUBST(GLIB_LIBS)
++
+ dnl Avahi for cups-browsed
+ AVAHI_LIBS=""
+ AVAHI_CFLAGS=""
+@@ -229,6 +233,8 @@
+ AVAHI_CFLAGS="$AVAHI_CFLAGS `$PKGCONFIG --cflags avahi-client`"
+ AVAHI_LIBS="$AVAHI_LIBS `$PKGCONFIG --libs avahi-client`"
+ AC_DEFINE(HAVE_AVAHI, [], [Define if you have the avahi library])
++
++ PKG_CHECK_MODULES(AVAHI_GLIB, [avahi-glib])
+ else
+ AC_MSG_RESULT(no)
+ fi
+@@ -237,11 +243,6 @@
+ AC_SUBST(AVAHI_LIBS)
+ AC_SUBST(AVAHI_CFLAGS)
+
+-PKG_CHECK_MODULES(GLIB, [glib-2.0 >= 2.30.2])
+-AC_SUBST(GLIB_CFLAGS)
+-AC_SUBST(GLIB_LIBS)
+-
+-PKG_CHECK_MODULES(AVAHI_GLIB, [avahi-glib])
+ AC_SUBST(AVAHI_GLIB_CFLAGS)
+ AC_SUBST(AVAHI_GLIB_LIBS)
+