summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net-im/mercury-bin/ChangeLog8
-rw-r--r--net-im/mercury-bin/Manifest23
-rw-r--r--net-im/mercury-bin/files/digest-mercury-bin-1709_rc11
-rw-r--r--net-im/mercury-bin/files/digest-mercury-bin-17101
-rw-r--r--net-im/mercury-bin/files/mercury.sh11
-rw-r--r--net-im/mercury-bin/mercury-bin-1710.ebuild (renamed from net-im/mercury-bin/mercury-bin-1709_rc1.ebuild)50
6 files changed, 58 insertions, 36 deletions
diff --git a/net-im/mercury-bin/ChangeLog b/net-im/mercury-bin/ChangeLog
index 5532424c026b..4608d35afd6f 100644
--- a/net-im/mercury-bin/ChangeLog
+++ b/net-im/mercury-bin/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-im/mercury-bin
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-im/mercury-bin/ChangeLog,v 1.4 2005/03/17 18:41:20 axxo Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-im/mercury-bin/ChangeLog,v 1.5 2005/12/29 00:06:42 humpback Exp $
+
+*mercury-bin-1710 (29 Dec 2005)
+
+ 29 Dec 2005; Gustavo Felisberto <humpback@gentoo.org>; files/mercury.sh,
+ -mercury-bin-1709_rc1.ebuild, +mercury-bin-1710.ebuild:
+ Adding mercury 1710 to portage and removing older releases.
*mercury-bin-1709_rc1 (17 Mar 2005)
diff --git a/net-im/mercury-bin/Manifest b/net-im/mercury-bin/Manifest
index 73132c2b3a82..6d3ab1a9c2ac 100644
--- a/net-im/mercury-bin/Manifest
+++ b/net-im/mercury-bin/Manifest
@@ -1,16 +1,11 @@
------BEGIN PGP SIGNED MESSAGE-----
-Hash: SHA1
-
-MD5 db64959ca5ce9c020a13dcd2b9ab5970 mercury-bin-1709_rc1.ebuild 1570
MD5 9b1cab5624d2988449e5056c4281cb8e ChangeLog 921
-MD5 16021df92c2051cb101ec0833e9cc116 metadata.xml 634
-MD5 037a6938a09ec22db8941a747726772d files/icon32.gif 1262
-MD5 63491834fd49c7eb2696650ee9f2d4f3 files/mercury.sh 242
MD5 1060171931d5b6a95e652650f4e2507e files/digest-mercury-bin-1709_rc1 58
------BEGIN PGP SIGNATURE-----
-Version: GnuPG v1.4.1 (GNU/Linux)
-
-iD8DBQFCOc/q/rLF9B432nYRAgWrAJ0ayl+h/1ET+n5GGVfO0DLOVieLxwCcCqDL
-zdHUIX0PCSLe8T7zDLwM2Hk=
-=auW8
------END PGP SIGNATURE-----
+MD5 7a3d1654ab6a142b9b6918fcbe8e3199 files/digest-mercury-bin-1710 54
+MD5 2e353fb2a762e77265e18cd788b9c3de files/digest-mercury-bin-1710_rc4 58
+MD5 037a6938a09ec22db8941a747726772d files/icon32.gif 1262
+MD5 a43bc8b85bbb061e66e91e9f2f2d7c32 files/mercury.sh 384
+MD5 83aece61adec23db36338a048fa8e759 mercury-bin-1709.ebuild 2661
+MD5 db64959ca5ce9c020a13dcd2b9ab5970 mercury-bin-1709_rc1.ebuild 1570
+MD5 7c2c3ad78b9113cd8616b20891ca1b76 mercury-bin-1709_rc8.ebuild 2716
+MD5 356ec3e0f58a019922b28db405137698 mercury-bin-1710.ebuild 1937
+MD5 16021df92c2051cb101ec0833e9cc116 metadata.xml 634
diff --git a/net-im/mercury-bin/files/digest-mercury-bin-1709_rc1 b/net-im/mercury-bin/files/digest-mercury-bin-1709_rc1
deleted file mode 100644
index 974a74d5c9e6..000000000000
--- a/net-im/mercury-bin/files/digest-mercury-bin-1709_rc1
+++ /dev/null
@@ -1 +0,0 @@
-MD5 bad1005d167e40ec3f6f928321dfa543 1709_RC1.zip 4956284
diff --git a/net-im/mercury-bin/files/digest-mercury-bin-1710 b/net-im/mercury-bin/files/digest-mercury-bin-1710
new file mode 100644
index 000000000000..fcf1ecb4c72d
--- /dev/null
+++ b/net-im/mercury-bin/files/digest-mercury-bin-1710
@@ -0,0 +1 @@
+MD5 f68b64e2ecf833d06876f4901eeec92d 1710.zip 5461124
diff --git a/net-im/mercury-bin/files/mercury.sh b/net-im/mercury-bin/files/mercury.sh
index 956db56ca5ca..cc2125462198 100644
--- a/net-im/mercury-bin/files/mercury.sh
+++ b/net-im/mercury-bin/files/mercury.sh
@@ -1,4 +1,13 @@
#!/bin/bash
MERCURY_INSTALL_PATH="/opt/mercury-bin"
+SHARE_DIR="/usr/share/mercury-bin"
+OPTIONS="-Djava.library.path=$(java-config -i jdictrayapi)"
+CLASSPATH=$(java-config -p jdom-1.0,xpp3,jgoodies-looks-1.3)
+
+for file in $(ls $SHARE_DIR/lib)
+do
+ CLASSPATH=$CLASSPATH:$SHARE_DIR/lib/$file
+done
cd ${MERCURY_INSTALL_PATH}
-java -Djava.library.path=$(java-config -i jdictrayapi) -classpath $(java-config -p jdom-1.0,jdictrayapi,jmf-bin,mercury-bin,xpp3,jgoodies-looks-1.3) com.dMSN.Main
+java $OPTIONS -classpath $CLASSPATH com.dMSN.Main
+
diff --git a/net-im/mercury-bin/mercury-bin-1709_rc1.ebuild b/net-im/mercury-bin/mercury-bin-1710.ebuild
index c69c0759d70f..080b25d6c4ff 100644
--- a/net-im/mercury-bin/mercury-bin-1709_rc1.ebuild
+++ b/net-im/mercury-bin/mercury-bin-1710.ebuild
@@ -1,46 +1,53 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-im/mercury-bin/mercury-bin-1709_rc1.ebuild,v 1.1 2005/03/17 18:41:20 axxo Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-im/mercury-bin/mercury-bin-1710.ebuild,v 1.1 2005/12/29 00:06:42 humpback Exp $
inherit eutils java-pkg
-MY_PV="1709_B7"
-DESCRIPTION="MSN and Jabber client in Java"
+MY_PVR=${PVR/rc/RC}
+DESCRIPTION="MSN and Jabber client in Java"
HOMEPAGE="http://www.mercury.to/"
-##Mercury.to dos not provided http or ftp links so i did a mirror
-SRC_URI="http://www.keanu.be/1709_RC1.zip"
+
+##Mercury.to does not provided http or ftp links so i provide here
+SRC_URI="http://felisberto.net/~humpback/${MY_PVR}.zip"
+
LICENSE="mercury"
SLOT="0"
-KEYWORDS="~x86"
+KEYWORDS="~x86 ~amd64"
+RESTRICT="nostrip"
+
+##No webcam support, requires JNI files that are only for x86
+IUSE=""
+
+
DEPEND="app-arch/unzip
>=virtual/jdk-1.4"
-
-RDEPEND=">=virtual/jre-1.4
+RDEPEND=">=virtual/jre-1.5
=dev-java/jgoodies-looks-1.3*
- dev-java/jmf-bin
dev-java/jdictrayapi
dev-java/xpp3
- ~dev-java/jdom-1.0"
-IUSE=""
+ =dev-java/jdom-1.0"
S=${WORKDIR}
+
src_unpack() {
- unpack ${A}
+ unpack ${MY_PVR}.zip
cd ${S}
rm -f *.dll *.so
-
#Clean the dllStuff.jar from things we dont need
cd lib
mkdir dllStuff
cd dllStuff
unzip ../dllStuff.jar
- rm -rf ../dllStuff.jar org/jdesktop x10gimli/platform
-
+# rm -rf ../dllStuff.jar org/jdesktop x10gimli com/jeans
+ rm -rf ../dllStuff.jar x10gimli com/jeans # Problems with jdictrayapi in amd64
+ # it looks to me that one can use the .so file that comes with the package
+ # but not the one in portage
cd ${S}
- rm lib/XML.jar # jdom
- rm lib/looks-*.jar #jgoodies-looks
- rm lib/JFlash.jar # seems to be trial from http://www.javaapis.com/jflashplayer/ which says its windows only
+ rm lib/jdom1_0.jar # jdom
+ rm lib/JFlash.jar # seems to be trial from http://www.javaapis.com/jflashplayer/
+ #which says its windows only
rm lib/xmlpull.jar # xpp3
}
@@ -54,7 +61,8 @@ src_install() {
#Start installing stuff
insinto /opt/${PN}/resources
doins -r resources/*
- java-pkg_dojar lib/*
+ dojar lib/*
+
insinto /usr/share/pixmaps
newins ${FILESDIR}/icon32.gif mercury.gif
@@ -63,4 +71,8 @@ src_install() {
newexe ${FILESDIR}/mercury.sh mercury
make_desktop_entry mercury "Mercury MSN client" /usr/share/pixmaps/mercury.gif
+
+ # Adding env.d LDPATH setting to prevent a Mercury bug
+ echo 'LDPATH="/opt/mercury-bin"' > 30mercury
+ doenvd 30mercury
}