summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-perl/HTML-Mason/ChangeLog7
-rw-r--r--dev-perl/HTML-Mason/HTML-Mason-1.470.0.ebuild63
2 files changed, 69 insertions, 1 deletions
diff --git a/dev-perl/HTML-Mason/ChangeLog b/dev-perl/HTML-Mason/ChangeLog
index 977fe984edb7..f31123fcaba7 100644
--- a/dev-perl/HTML-Mason/ChangeLog
+++ b/dev-perl/HTML-Mason/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-perl/HTML-Mason
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-perl/HTML-Mason/ChangeLog,v 1.100 2011/09/21 02:07:01 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/HTML-Mason/ChangeLog,v 1.101 2011/10/23 07:14:10 tove Exp $
+
+*HTML-Mason-1.470.0 (23 Oct 2011)
+
+ 23 Oct 2011; Torsten Veller <tove@gentoo.org> +HTML-Mason-1.470.0.ebuild:
+ Version bump. Remove README files from /usr/bin (#368937)
*HTML-Mason-1.460.0 (21 Sep 2011)
diff --git a/dev-perl/HTML-Mason/HTML-Mason-1.470.0.ebuild b/dev-perl/HTML-Mason/HTML-Mason-1.470.0.ebuild
new file mode 100644
index 000000000000..41688a734cc0
--- /dev/null
+++ b/dev-perl/HTML-Mason/HTML-Mason-1.470.0.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/HTML-Mason/HTML-Mason-1.470.0.ebuild,v 1.1 2011/10/23 07:14:10 tove Exp $
+
+EAPI=4
+
+MODULE_AUTHOR=DROLSKY
+MODULE_VERSION=1.47
+inherit depend.apache perl-module
+
+DESCRIPTION="A HTML development and delivery Perl Module"
+HOMEPAGE="http://www.masonhq.com/ ${HOMEPAGE}"
+
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="modperl doc test"
+
+RDEPEND="!modperl? ( virtual/perl-CGI )
+ modperl? (
+ www-apache/libapreq2
+ >=www-apache/mod_perl-2
+ )
+ >=dev-perl/Params-Validate-0.7
+ >=dev-perl/Class-Container-0.08
+ >=dev-perl/Exception-Class-1.15
+ dev-perl/HTML-Parser
+ virtual/perl-Scalar-List-Utils
+ virtual/perl-File-Spec
+ >=dev-perl/Cache-Cache-1.01
+ dev-perl/Log-Any"
+
+DEPEND="${RDEPEND}
+ virtual/perl-Module-Build
+ test? ( dev-perl/Test-Deep )"
+
+want_apache2 modperl
+
+SRC_TEST="do"
+mydoc="CREDITS UPGRADE"
+myconf="--noprompts"
+
+pkg_setup() {
+ depend.apache_pkg_setup modperl
+ perl-module_pkg_setup
+}
+
+perl-module_src_prep() {
+ # Note about new modperl use flag
+ if use !modperl ; then
+ ewarn "HTML-Mason will only install with modperl support"
+ ewarn "if the use flag modperl is enabled."
+ sleep 5
+ fi
+ # rendhalver - needed to set an env var for the build script so it finds our apache.
+ APACHE="${APACHE_BIN}" perl "${S}"/Build.PL installdirs=vendor destdir="${ED}" ${myconf}
+}
+
+src_install () {
+ perl-module_src_install
+ rm "${ED}"/usr/bin/*.README # 368937
+ # rendhalver - the html docs have subdirs so this gets all of them
+ use doc && dohtml -r htdocs/*
+}