summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-admin/mtools/mtools-3.9.8-r1.ebuild16
-rw-r--r--app-admin/powertweak/powertweak-0.99.4.ebuild20
2 files changed, 16 insertions, 20 deletions
diff --git a/app-admin/mtools/mtools-3.9.8-r1.ebuild b/app-admin/mtools/mtools-3.9.8-r1.ebuild
index cd80e59f3be7..fe200120e251 100644
--- a/app-admin/mtools/mtools-3.9.8-r1.ebuild
+++ b/app-admin/mtools/mtools-3.9.8-r1.ebuild
@@ -1,13 +1,10 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/mtools/mtools-3.9.8-r1.ebuild,v 1.15 2002/10/20 18:14:57 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/mtools/mtools-3.9.8-r1.ebuild,v 1.16 2002/11/30 01:37:27 vapier Exp $
-S=${WORKDIR}/${P}
-DESCRIPTION="Mtools is a collection of utilities to access MS-DOS disks
-from Unix without mounting them. It supports Win95 style long file names,..."
+DESCRIPTION="utilities to access MS-DOS disks from Unix without mounting them"
SRC_URI="http://mtools.linux.lu/mtools-3.9.8.tar.gz"
-HOMEPAGE="http://mtools.linux.lu"
-IUSE=""
+HOMEPAGE="http://mtools.linux.lu/"
SLOT="0"
LICENSE="GPL-2"
@@ -16,13 +13,12 @@ KEYWORDS="x86 ppc sparc sparc64"
DEPEND="sys-apps/texinfo"
src_compile() {
- econf --sysconfdir=/etc/mtools || die
+ econf --sysconfdir=/etc/mtools
make || die
}
-src_install () {
- einstall \
- sysconfdir=${D}/etc/mtools || die
+src_install() {
+ einstall sysconfdir=${D}/etc/mtools
insinto /etc/mtools
newins mtools.conf mtools.conf.example
dodoc COPYING ChangeLog NEWPARAMS README* Release.notes
diff --git a/app-admin/powertweak/powertweak-0.99.4.ebuild b/app-admin/powertweak/powertweak-0.99.4.ebuild
index 4ae6c9d21d61..9007c40f665e 100644
--- a/app-admin/powertweak/powertweak-0.99.4.ebuild
+++ b/app-admin/powertweak/powertweak-0.99.4.ebuild
@@ -1,17 +1,15 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/powertweak/powertweak-0.99.4.ebuild,v 1.4 2002/10/05 05:39:05 drobbins Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/powertweak/powertweak-0.99.4.ebuild,v 1.5 2002/11/30 01:40:58 vapier Exp $
-IUSE="gtk"
-
-S=${WORKDIR}/${PN}
-DESCRIPTION="Powertweak"
+DESCRIPTION="tune your kernel and hardware settings for optimal performance"
SRC_URI="mirror://sourceforge/powertweak/${P}.tar.bz2"
-HOMEPAGE="http://powertweak.sourceforge.net"
+HOMEPAGE="http://powertweak.sourceforge.net/"
SLOT="0"
LICENSE="GPL-2"
KEYWORDS="x86 -ppc"
+IUSE="gtk"
DEPEND="gtk? ( =x11-libs/gtk+-1.2* )
>=dev-libs/libxml-1.8.10
@@ -21,6 +19,8 @@ DEPEND="gtk? ( =x11-libs/gtk+-1.2* )
RDEPEND=">=sys-apps/pciutils-2.1.0
gtk? ( =x11-libs/gtk+-1.2* )"
+S=${WORKDIR}/${PN}
+
inherit libtool
src_unpack() {
@@ -29,10 +29,10 @@ src_unpack() {
cd ${S} ; patch -l -p1 < ${FILESDIR}/${P}-gentoo.diff
for FILE in `find . -iname "Makefile*"`;do
+ cp ${FILE} ${FILE}.hacked
sed -e "s:\(^CFLAGS =.*\):\1 ${CFLAGS}:" \
-e "s:\(^CPPFLAGS =.*\):\1 ${CPPFLAGS}:" \
- ${FILE} > ${FILE}.hacked || die "Hack failed"
- mv ${FILE}.hacked ${FILE}
+ ${FILE}.hacked > ${FILE} || die "Hack failed"
done
}
@@ -44,7 +44,7 @@ src_compile() {
CFLAGS="${CPPFLAGS} -Wno-error"
CPPFLAGS="${CPPFLAGS} -Wno-deprecated"
- econf ${myconf} || die
+ econf ${myconf}
emake || die
}
@@ -55,7 +55,7 @@ src_install() {
dodoc Documentation/* Documentation/Hackers/*
use gtk || rm ${D}/usr/bin/gpowertweak
-
+
exeinto /etc/init.d ; newexe ${FILESDIR}/powertweakd.rc6 powertweakd
}