summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--media-sound/audacity/ChangeLog8
-rw-r--r--media-sound/audacity/audacity-1.3.12.ebuild5
-rw-r--r--media-sound/audacity/files/audacity-1.3.12-automagic.patch27
-rw-r--r--media-sound/audacity/files/audacity-1.3.12-gcc45.patch95
4 files changed, 117 insertions, 18 deletions
diff --git a/media-sound/audacity/ChangeLog b/media-sound/audacity/ChangeLog
index 8144014b0841..d024b71a1e03 100644
--- a/media-sound/audacity/ChangeLog
+++ b/media-sound/audacity/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-sound/audacity
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/audacity/ChangeLog,v 1.141 2010/06/16 12:42:44 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/audacity/ChangeLog,v 1.142 2010/10/04 08:52:58 dirtyepic Exp $
+
+ 04 Oct 2010; Ryan Hill <dirtyepic@gentoo.org> audacity-1.3.12.ebuild,
+ files/audacity-1.3.12-automagic.patch, +files/audacity-1.3.12-gcc45.patch:
+ Add patch from upstream to fix configure error w/ GCC 4.5 (bug #322145 by
+ Bartosz Brachaczek/Thomas Pfaff). Tweak automagic patch to avoid
+ collision. Fix wxGTK DEPEND (bug #327801 by Arttu Valo).
16 Jun 2010; Alexis Ballier <aballier@gentoo.org>
-files/audacity-1.3.7-cflags.patch, -audacity-1.3.9.ebuild,
diff --git a/media-sound/audacity/audacity-1.3.12.ebuild b/media-sound/audacity/audacity-1.3.12.ebuild
index 9f0c7e2f0bda..7182eba25e8a 100644
--- a/media-sound/audacity/audacity-1.3.12.ebuild
+++ b/media-sound/audacity/audacity-1.3.12.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/audacity/audacity-1.3.12.ebuild,v 1.1 2010/04/12 08:38:53 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/audacity/audacity-1.3.12.ebuild,v 1.2 2010/10/04 08:52:58 dirtyepic Exp $
EAPI=2
@@ -20,7 +20,7 @@ SLOT="0"
KEYWORDS="~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
RESTRICT="test"
-COMMON_DEPEND="=x11-libs/wxGTK-2.8*
+COMMON_DEPEND="x11-libs/wxGTK:2.8[X]
>=app-arch/zip-2.3
>=media-libs/libsndfile-1.0.0
dev-libs/expat
@@ -49,6 +49,7 @@ S=${WORKDIR}/${MY_P}
src_prepare() {
epatch "${FILESDIR}/${PN}-1.3.12-automagic.patch"
+ epatch "${FILESDIR}/${PN}-1.3.12-gcc45.patch"
AT_M4DIR="${S}/m4" eautoreconf
}
diff --git a/media-sound/audacity/files/audacity-1.3.12-automagic.patch b/media-sound/audacity/files/audacity-1.3.12-automagic.patch
index a7aa66d83d46..92405e9413ae 100644
--- a/media-sound/audacity/files/audacity-1.3.12-automagic.patch
+++ b/media-sound/audacity/files/audacity-1.3.12-automagic.patch
@@ -1,7 +1,6 @@
-diff -ur ../audacity-src-1.3.12-beta.orig/configure.in ./configure.in
---- ../audacity-src-1.3.12-beta.orig/configure.in 2010-03-30 12:32:42.000000000 +0100
-+++ ./configure.in 2010-04-02 17:03:07.154028262 +0100
-@@ -559,6 +559,8 @@
+--- a/configure.in
++++ b/configure.in
+@@ -559,6 +559,8 @@ case "${host_os}" in
esac
dnl PortAudio configuration
@@ -10,7 +9,7 @@ diff -ur ../audacity-src-1.3.12-beta.orig/configure.in ./configure.in
LOCAL_LIBS="$LOCAL_LIBS portaudio-v19/lib/libportaudio.a"
EXTRAOBJS="$EXTRAOBJS ../lib-src/portaudio-v19/lib/libportaudio.a"
-@@ -575,13 +577,21 @@
+@@ -575,13 +577,21 @@ case "${host_os}" in
;;
*)
dnl Unix
@@ -39,19 +38,18 @@ diff -ur ../audacity-src-1.3.12-beta.orig/configure.in ./configure.in
fi
AC_CHECK_LIB(hpi, HPI_SubSysCreate, have_asihpi=yes, have_asihpi=no, -lm)
if [[ $have_asihpi = "yes" ]] ; then
-Only in .: configure.in.orig
-diff -ur ../audacity-src-1.3.12-beta.orig/lib-src/portmixer/configure.ac ./lib-src/portmixer/configure.ac
---- ../audacity-src-1.3.12-beta.orig/lib-src/portmixer/configure.ac 2010-03-30 12:29:47.000000000 +0100
-+++ ./lib-src/portmixer/configure.ac 2010-04-02 17:03:07.154028262 +0100
-@@ -97,6 +97,7 @@
- AC_CHECK_HEADER(alsa/asoundlib.h, have_alsa=yes, have_alsa=no)
- AC_CHECK_HEADER(CoreAudio/CoreAudio.h, have_coreaudio=yes, have_coreaudio=no)
+--- a/lib-src/portmixer/configure.ac
++++ b/lib-src/portmixer/configure.ac
+@@ -31,6 +31,8 @@ AC_ARG_ENABLE([debug],
+ [AC_SUBST( cflags, ["$cflags -g"] ) AC_MSG_RESULT(yes)],
+ [AC_SUBST( cflags, ["$cflags -O2"] ) AC_MSG_RESULT(no)])
+AC_ARG_WITH([alsa], AS_HELP_STRING([--without-alsa], [Build without alsa library (default: test)]))
++
#
- # Set up to use the identified ones
+ # Check for portaudio path
#
-@@ -107,7 +108,7 @@
+@@ -107,7 +109,7 @@ if [[ $have_oss = "yes" ]] ; then
objects="$objects px_unix_oss.o"
fi
@@ -60,4 +58,3 @@ diff -ur ../audacity-src-1.3.12-beta.orig/lib-src/portmixer/configure.ac ./lib-s
AC_MSG_NOTICE(Including support for ALSA);
AC_DEFINE(PX_USE_LINUX_ALSA)
objects="$objects px_linux_alsa.o"
-Only in ./lib-src/portmixer: configure.ac.orig
diff --git a/media-sound/audacity/files/audacity-1.3.12-gcc45.patch b/media-sound/audacity/files/audacity-1.3.12-gcc45.patch
new file mode 100644
index 000000000000..198873c57f90
--- /dev/null
+++ b/media-sound/audacity/files/audacity-1.3.12-gcc45.patch
@@ -0,0 +1,95 @@
+https://bugs.gentoo.org/322145
+http://bugzilla.audacityteam.org/show_bug.cgi?id=221
+
+--- lib-src/portmixer/configure.ac
++++ lib-src/portmixer/configure.ac
+@@ -49,34 +49,57 @@
+ fi
+
+ #
++# Check which APIs are available
++#
++
++have_oss=no
++AC_CHECK_HEADERS([sys/soundcard.h linux/soundcard.h machine/soundcard.h], have_oss=yes)
++
++AC_CHECK_HEADER(alsa/asoundlib.h, have_alsa=yes, have_alsa=no)
++AC_CHECK_HEADER(CoreAudio/CoreAudio.h, have_coreaudio=yes, have_coreaudio=no)
++AC_CHECK_HEADER(windows.h, have_windows=yes, have_windows=no)
++
++#
+ # Make sure the support is there
+ #
+ have_support=yes
+-AC_EGREP_HEADER([PaWinDS_GetStreamInputGUID], [pa_win_ds.h], , [have_support=no])
+-if [[ $have_support = "no" ]] ; then
+- AC_MSG_WARN("Missing support in pa_win_ds.h");
+-fi
+-AC_EGREP_HEADER([PaAlsa_GetStreamInputCard], [pa_linux_alsa.h], , [have_support=no])
+-if [[ $have_support = "no" ]] ; then
++
++if [[ $have_alsa = "yes" ]] ; then
++ AC_EGREP_HEADER([PaAlsa_GetStreamInputCard], [pa_linux_alsa.h], , [have_support=no])
++ if [[ $have_support = "no" ]] ; then
+ AC_MSG_WARN("Missing support in pa_linux_alsa.h");
++ fi
+ fi
+-AC_EGREP_HEADER([PaWinMME_GetStreamInputHandle], [pa_win_wmme.h], , [have_support=no])
+-if [[ $have_support = "no" ]] ; then
+- AC_MSG_WARN("Missing support in pa_win_wmme.h");
+-fi
+-AC_EGREP_HEADER([PaMacCore_GetStreamInputDevice], [pa_mac_core.h], , [have_support=no])
+-if [[ $have_support = "no" ]] ; then
++
++if [[ $have_coreaudio = "yes" ]] ; then
++ AC_EGREP_HEADER([PaMacCore_GetStreamInputDevice], [pa_mac_core.h], , [have_support=no])
++ if [[ $have_support = "no" ]] ; then
+ AC_MSG_WARN("Missing support in pa_mac_core.h");
++ fi
+ fi
+-AC_EGREP_HEADER([PaOSS_GetStreamInputDevice], [pa_unix_oss.h], , [have_support=no])
+-if [[ $have_support = "no" ]] ; then
++
++if [[ $have_oss = "yes" ]] ; then
++ AC_EGREP_HEADER([PaOSS_GetStreamInputDevice], [pa_unix_oss.h], , [have_support=no])
++ if [[ $have_support = "no" ]] ; then
+ AC_MSG_WARN("Missing support in pa_unix_oss.h");
++ fi
+ fi
++
++if [[ $have_windows = "yes" ]] ; then
++ AC_EGREP_HEADER([PaWinDS_GetStreamInputGUID], [pa_win_ds.h], , [have_support=no])
++ if [[ $have_support = "no" ]] ; then
++ AC_MSG_WARN("Missing support in pa_win_ds.h");
++ fi
++ AC_EGREP_HEADER([PaWinMME_GetStreamInputHandle], [pa_win_wmme.h], , [have_support=no])
++ if [[ $have_support = "no" ]] ; then
++ AC_MSG_WARN("Missing support in pa_win_wmme.h");
++ fi
++fi
++
+ AC_EGREP_HEADER([Pa_GetStreamHostApiType], [portaudio.h], , [have_support=no])
+ if [[ $have_support = "no" ]] ; then
+ AC_MSG_WARN("Missing support in portaudio.h");
+ fi
+-
+ if [[ $have_support = "no" ]] ; then
+ AC_MSG_ERROR("Your version of portaudio does not include required functions");
+ fi
+@@ -88,16 +111,6 @@
+ AC_SUBST( objects, [px_mixer.o] )
+
+ #
+-# Check which APIs are available
+-#
+-
+-have_oss=no
+-AC_CHECK_HEADERS([sys/soundcard.h linux/soundcard.h machine/soundcard.h], have_oss=yes)
+-
+-AC_CHECK_HEADER(alsa/asoundlib.h, have_alsa=yes, have_alsa=no)
+-AC_CHECK_HEADER(CoreAudio/CoreAudio.h, have_coreaudio=yes, have_coreaudio=no)
+-
+-#
+ # Set up to use the identified ones
+ #
+ AC_MSG_NOTICE(---------------------------------------);