summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-crypt/asedriveiiie-serial/ChangeLog10
-rw-r--r--app-crypt/asedriveiiie-serial/asedriveiiie-serial-3.5.ebuild47
2 files changed, 55 insertions, 2 deletions
diff --git a/app-crypt/asedriveiiie-serial/ChangeLog b/app-crypt/asedriveiiie-serial/ChangeLog
index b78aa7ae8d03..ead8f706bd2f 100644
--- a/app-crypt/asedriveiiie-serial/ChangeLog
+++ b/app-crypt/asedriveiiie-serial/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-crypt/asedriveiiie-serial
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-crypt/asedriveiiie-serial/ChangeLog,v 1.5 2008/06/01 03:38:07 dragonheart Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/asedriveiiie-serial/ChangeLog,v 1.6 2009/04/10 21:11:49 arfrever Exp $
+
+*asedriveiiie-serial-3.5 (10 Apr 2009)
+
+ 10 Apr 2009; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ +asedriveiiie-serial-3.5.ebuild:
+ Version bump (bug #263299).
01 Jun 2008; Daniel Black <dragonheart@gentoo.org>
asedriveiiie-serial-3.4.ebuild:
diff --git a/app-crypt/asedriveiiie-serial/asedriveiiie-serial-3.5.ebuild b/app-crypt/asedriveiiie-serial/asedriveiiie-serial-3.5.ebuild
new file mode 100644
index 000000000000..be1d154090ee
--- /dev/null
+++ b/app-crypt/asedriveiiie-serial/asedriveiiie-serial-3.5.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/asedriveiiie-serial/asedriveiiie-serial-3.5.ebuild,v 1.1 2009/04/10 21:11:49 arfrever Exp $
+
+DESCRIPTION="ASEDriveIIIe Serial Card Reader"
+HOMEPAGE="http://www.athena-scs.com"
+SRC_URI="http://www.athena-scs.com/downloads/${P}.tar.bz2"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+KEYWORDS="~amd64 ~x86"
+RDEPEND=">=sys-apps/pcsc-lite-1.3.0
+ >=dev-libs/libusb-0.1.10"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+src_install() {
+ local conf="/etc/reader.conf.d/${PN}.conf"
+
+ emake DESTDIR="${D}" install || die "emake install failed"
+
+ dodoc ChangeLog README
+
+ dodir "$(dirname "${conf}")"
+ insinto "$(dirname "${conf}")"
+ newins "etc/reader.conf" "$(basename "${conf}")"
+}
+
+pkg_postinst() {
+ elog "NOTICE:"
+ elog "1. Update ${conf} file"
+ elog "2. Run update-reader.conf, yes this is a command..."
+ elog "3. Restart pcscd"
+}
+
+pkg_postrm() {
+ #
+ # Without this, pcscd will not start next time.
+ #
+ local conf="/etc/reader.conf.d/${PN}.conf"
+ if ! [ -f "$(grep LIBPATH "${conf}" | sed 's/LIBPATH *//' | sed 's/ *$//g' | head -n 1)" ]; then
+ rm "${conf}"
+ update-reader.conf
+ elog "NOTICE:"
+ elog "You need to restart pcscd"
+ fi
+}