summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net-mail/safecat/ChangeLog8
-rw-r--r--net-mail/safecat/safecat-1.12.ebuild28
2 files changed, 22 insertions, 14 deletions
diff --git a/net-mail/safecat/ChangeLog b/net-mail/safecat/ChangeLog
index 32265edf4433..8b144b1dc651 100644
--- a/net-mail/safecat/ChangeLog
+++ b/net-mail/safecat/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-mail/safecat
-# Copyright 2000-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-mail/safecat/ChangeLog,v 1.13 2005/12/12 08:22:21 robbat2 Exp $
+# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-mail/safecat/ChangeLog,v 1.14 2006/02/22 17:39:48 agriffis Exp $
+
+ 22 Feb 2006; Aron Griffis <agriffis@gentoo.org> safecat-1.12.ebuild:
+ Move compilation settings to src_compile where they belong. Refrain from
+ building with gcc-4.0 -Os which causes safecat to segfault on x86
*safecat-1.12 (12 Dec 2005)
diff --git a/net-mail/safecat/safecat-1.12.ebuild b/net-mail/safecat/safecat-1.12.ebuild
index 781f040bdf20..ac49f8499683 100644
--- a/net-mail/safecat/safecat-1.12.ebuild
+++ b/net-mail/safecat/safecat-1.12.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2005 Gentoo Foundation
+# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-mail/safecat/safecat-1.12.ebuild,v 1.1 2005/12/12 08:22:21 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-mail/safecat/safecat-1.12.ebuild,v 1.2 2006/02/22 17:39:48 agriffis Exp $
-inherit fixheadtails eutils toolchain-funcs
+inherit fixheadtails eutils toolchain-funcs flag-o-matic
IUSE=""
@@ -19,22 +19,26 @@ KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~mips ~ppc ~sparc ~x86"
src_unpack() {
unpack ${P}.tar.gz
-
- # applying errno-patch and maildir-patch
- EPATCH_OPTS="-p1 -d ${S}" epatch ${FILESDIR}/safecat-1.11-gentoo.patch
-
cd ${S}
- echo "/usr" > conf-root
- echo "$(tc-getCC) ${CFLAGS}" > conf-cc
- echo "$(tc-getCC) ${LDFLAGS}" > conf-ld
+
+ # applying maildir-patch
+ epatch ${FILESDIR}/safecat-1.11-gentoo.patch
ht_fix_file Makefile make-compile.sh
- egrep -v 'man|doc' hier.c > hier.c.new
- mv hier.c.new hier.c
+ sed -ni '/man\|doc/!p' hier.c
}
src_compile() {
+ # safecat segfaults on gcc-4.0 x86 with -Os, seems to be okay with -O2
+ if [[ $(gcc-major-version).$(gcc-minor-version) == 4.0 ]]; then
+ replace-flags -Os -O2
+ fi
+
+ echo "/usr" > conf-root
+ echo "$(tc-getCC) ${CFLAGS}" > conf-cc
+ echo "$(tc-getCC) ${LDFLAGS}" > conf-ld
+
make it man || die
}