summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--games-sports/xmoto/ChangeLog7
-rw-r--r--games-sports/xmoto/files/digest-xmoto-0.3.36
-rw-r--r--games-sports/xmoto/xmoto-0.3.3.ebuild76
3 files changed, 88 insertions, 1 deletions
diff --git a/games-sports/xmoto/ChangeLog b/games-sports/xmoto/ChangeLog
index 972b1563a340..3a448976ec30 100644
--- a/games-sports/xmoto/ChangeLog
+++ b/games-sports/xmoto/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for games-sports/xmoto
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-sports/xmoto/ChangeLog,v 1.18 2007/08/08 23:13:52 genstef Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-sports/xmoto/ChangeLog,v 1.19 2007/09/02 18:53:51 genstef Exp $
+
+*xmoto-0.3.3 (02 Sep 2007)
+
+ 02 Sep 2007; Stefan Schweizer <genstef@gentoo.org> +xmoto-0.3.3.ebuild:
+ Version bump and enable zoom always, bug 188651
*xmoto-0.3.2 (08 Aug 2007)
diff --git a/games-sports/xmoto/files/digest-xmoto-0.3.3 b/games-sports/xmoto/files/digest-xmoto-0.3.3
new file mode 100644
index 000000000000..a97dc609cb66
--- /dev/null
+++ b/games-sports/xmoto/files/digest-xmoto-0.3.3
@@ -0,0 +1,6 @@
+MD5 1509555c6cfd71f5775ab1b997d4c8a3 svg2lvl-0.4.0.tar.gz 48766
+RMD160 84244cd82fc1ba0737207dfd64fd865dd9fcf032 svg2lvl-0.4.0.tar.gz 48766
+SHA256 ffda6cf46ba2fb2a280c1229bbc5b458b3ac72595cdfee0a269c0fcd099a9f13 svg2lvl-0.4.0.tar.gz 48766
+MD5 f1f7726a8856f9c9efa2ae8e3192bb7f xmoto-0.3.3-src.tar.gz 16958347
+RMD160 0e1f2c01f93c887ea1a3693979b6b8810ae2704c xmoto-0.3.3-src.tar.gz 16958347
+SHA256 c5fa955733f4ea785a3bc78002082507d7e9f99eab5ba1dd28710761893be9b4 xmoto-0.3.3-src.tar.gz 16958347
diff --git a/games-sports/xmoto/xmoto-0.3.3.ebuild b/games-sports/xmoto/xmoto-0.3.3.ebuild
new file mode 100644
index 000000000000..4b8faa23c00c
--- /dev/null
+++ b/games-sports/xmoto/xmoto-0.3.3.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-sports/xmoto/xmoto-0.3.3.ebuild,v 1.1 2007/09/02 18:53:51 genstef Exp $
+
+inherit eutils games
+
+LVL="svg2lvl-0.4.0"
+DESCRIPTION="A challenging 2D motocross platform game"
+HOMEPAGE="http://xmoto.tuxfamily.org"
+SRC_URI="http://download.tuxfamily.org/${PN}/${PN}/${PV}/${P}-src.tar.gz
+ editor? ( http://download.tuxfamily.org/xmoto/svg2lvl/${LVL/*-}/${LVL}.tar.gz )"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="nls editor"
+
+RDEPEND="media-libs/jpeg
+ media-libs/libpng
+ media-libs/libsdl
+ media-libs/sdl-mixer
+ media-libs/sdl-ttf
+ net-misc/curl
+ dev-lang/lua
+ dev-games/ode
+ virtual/opengl
+ virtual/glu
+ nls? ( virtual/libintl )
+ editor? ( >=media-gfx/inkscape-0.45 )"
+DEPEND="${RDEPEND}
+ >=dev-db/sqlite-3
+ nls? ( sys-devel/gettext )"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ sed -i 's:$(localedir):/usr/share/locale:' po/Makefile.in.in \
+ || die "sed Makefile.in.in failed"
+ use editor && rm -f "${WORKDIR}"/${LVL}/{bezmisc,inkex}.py
+}
+
+src_compile() {
+ egamesconf \
+ --disable-dependency-tracking \
+ --with-enable-zoom=1 \
+ --with-localesdir=/usr/share/locale \
+ $(use_enable nls) \
+ || die
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+
+ dodoc README TODO ChangeLog
+
+ doicon extra/xmoto.xpm
+ domenu extra/xmoto.desktop
+
+ prepgamesdirs
+
+ if use editor; then
+ insinto /usr/share/inkscape/extensions
+ doins "${WORKDIR}"/${LVL}/*.{inx,py,xml} || die "doins failed"
+ fi
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+ if use editor; then
+ elog "If you want to know how to create Xmoto levels"
+ elog "have a look at this Tutorial:"
+ elog "http://wiki.xmoto.free.fr/index.php?title=Inkscape-0.3.0#Tutorial"
+ elog "You can share your levels on the Xmoto homepage."
+ fi
+}