summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net-p2p/nicotine+/ChangeLog8
-rw-r--r--net-p2p/nicotine+/nicotine+-1.2.14.ebuild32
-rw-r--r--net-p2p/nicotine+/nicotine+-1.2.8.ebuild44
3 files changed, 39 insertions, 45 deletions
diff --git a/net-p2p/nicotine+/ChangeLog b/net-p2p/nicotine+/ChangeLog
index c4bf4afc8eb1..9f4c5b7d08e1 100644
--- a/net-p2p/nicotine+/ChangeLog
+++ b/net-p2p/nicotine+/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-p2p/nicotine+
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/nicotine+/ChangeLog,v 1.37 2009/09/27 12:59:41 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/nicotine+/ChangeLog,v 1.38 2009/10/07 01:06:24 dirtyepic Exp $
+
+*nicotine+-1.2.14 (07 Oct 2009)
+
+ 07 Oct 2009; Ryan Hill <dirtyepic@gentoo.org> -nicotine+-1.2.8.ebuild,
+ +nicotine+-1.2.14.ebuild:
+ Version bump, bug #287847.
27 Sep 2009; Markus Meier <maekke@gentoo.org> nicotine+-1.2.12.ebuild:
amd64/x86 stable, bug #286606
diff --git a/net-p2p/nicotine+/nicotine+-1.2.14.ebuild b/net-p2p/nicotine+/nicotine+-1.2.14.ebuild
new file mode 100644
index 000000000000..df4b776bedfa
--- /dev/null
+++ b/net-p2p/nicotine+/nicotine+-1.2.14.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/nicotine+/nicotine+-1.2.14.ebuild,v 1.1 2009/10/07 01:06:24 dirtyepic Exp $
+
+inherit distutils multilib toolchain-funcs
+
+DESCRIPTION="A fork of nicotine, a Soulseek client in Python"
+HOMEPAGE="http://nicotine-plus.sourceforge.net"
+#SRC_URI="http://www.nicotine-plus.org/files/${P}.tar.bz2"
+SRC_URI="http://129.125.101.92/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-3 LGPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~x86-fbsd"
+IUSE="geoip spell"
+
+RDEPEND="virtual/python
+ >=dev-python/pygtk-2.10
+ media-libs/mutagen
+ geoip? ( >=dev-python/geoip-python-0.2.0
+ >=dev-libs/geoip-1.2.1 )
+ spell? ( dev-python/sexy-python )
+ !net-p2p/nicotine"
+
+DEPEND="${RDEPEND}"
+
+src_install() {
+ distutils_python_version
+ distutils_src_install \
+ --install-lib /usr/$(get_libdir)/python${PYVER}/site-packages
+ dosym nicotine.py /usr/bin/nicotine
+}
diff --git a/net-p2p/nicotine+/nicotine+-1.2.8.ebuild b/net-p2p/nicotine+/nicotine+-1.2.8.ebuild
deleted file mode 100644
index 88ef1ce71fff..000000000000
--- a/net-p2p/nicotine+/nicotine+-1.2.8.ebuild
+++ /dev/null
@@ -1,44 +0,0 @@
-# Copyright 1999-2007 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/nicotine+/nicotine+-1.2.8.ebuild,v 1.7 2007/09/11 13:37:46 coldwind Exp $
-
-inherit distutils eutils multilib toolchain-funcs
-
-DESCRIPTION="A fork of nicotine, a Soulseek client in Python"
-HOMEPAGE="http://nicotine-plus.sourceforge.net"
-SRC_URI="mirror://sourceforge/nicotine-plus/${P}.tar.bz2"
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ppc x86 ~x86-fbsd"
-IUSE="geoip vorbis"
-
-RDEPEND="virtual/python
- >=dev-python/pygtk-2
- vorbis? ( >=dev-python/pyvorbis-1.4-r1
- >=dev-python/pyogg-1 )
- geoip? ( >=dev-python/geoip-python-0.2.0
- >=dev-libs/geoip-1.2.1 )
- !net-p2p/nicotine"
-
-DEPEND="${RDEPEND}
- dev-util/pkgconfig
- >=sys-apps/sed-4"
-
-src_compile() {
- distutils_src_compile
-
- cd "${S}"/trayicon/
- sed -i -e "s:/lib/:/$(get_libdir)/:" \
- Makefile.in || die "sed failed"
- ./autogen.py
- emake CC="$(tc-getCC)" || die "emake failed"
-}
-
-src_install() {
- distutils_python_version
- distutils_src_install --install-lib \
- /usr/$(get_libdir)/python${PYVER}/site-packages
-
- cd "${S}"/trayicon/
- emake DESTDIR="${D}" install || die "emake install failed"
-}