summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sci-physics/xfoil/ChangeLog6
-rw-r--r--sci-physics/xfoil/files/xfoil-6.97-overflow.patch2
-rw-r--r--sci-physics/xfoil/xfoil-6.96.ebuild75
3 files changed, 6 insertions, 77 deletions
diff --git a/sci-physics/xfoil/ChangeLog b/sci-physics/xfoil/ChangeLog
index d795262e0b11..98502878c57f 100644
--- a/sci-physics/xfoil/ChangeLog
+++ b/sci-physics/xfoil/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sci-physics/xfoil
# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-physics/xfoil/ChangeLog,v 1.9 2008/08/23 11:43:27 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-physics/xfoil/ChangeLog,v 1.10 2008/11/24 15:47:11 bicatali Exp $
+
+ 24 Nov 2008; Sébastien Fabbro <bicatali@gentoo.org>
+ files/xfoil-6.97-overflow.patch, -xfoil-6.96.ebuild:
+ Fixed patch for overflow, thanks to Joel Soete
23 Aug 2008; Sébastien Fabbro <bicatali@gentoo.org> xfoil-6.97.ebuild:
Fixed for propagation with fortran compilers and flags, bug #235501
diff --git a/sci-physics/xfoil/files/xfoil-6.97-overflow.patch b/sci-physics/xfoil/files/xfoil-6.97-overflow.patch
index d86b52a4aaa1..73656f927a48 100644
--- a/sci-physics/xfoil/files/xfoil-6.97-overflow.patch
+++ b/sci-physics/xfoil/files/xfoil-6.97-overflow.patch
@@ -16,7 +16,7 @@
DO I=1, NINPUT
IF(ABS(RINPUT(I)) .GT. 2.1E9) THEN
- IINPUT(I) = 2**31
-+ IINPUT(I) = 1.99**31
++ IINPUT(I) = HUGE(0)
ELSE
IINPUT(I) = INT(RINPUT(I))
ENDIF
diff --git a/sci-physics/xfoil/xfoil-6.96.ebuild b/sci-physics/xfoil/xfoil-6.96.ebuild
deleted file mode 100644
index 579a8f4aeaaa..000000000000
--- a/sci-physics/xfoil/xfoil-6.96.ebuild
+++ /dev/null
@@ -1,75 +0,0 @@
-# Copyright 1999-2007 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-physics/xfoil/xfoil-6.96.ebuild,v 1.3 2007/09/27 08:12:16 bicatali Exp $
-
-inherit toolchain-funcs fortran
-
-DESCRIPTION="Design and analysis of subsonic isolated airfoils"
-HOMEPAGE="http://raphael.mit.edu/xfoil/"
-SRC_URI="http://web.mit.edu/drela/Public/web/${PN}/${PN}${PV}.tar.gz
-doc? ( http://web.mit.edu/drela/Public/web/${PN}/dataflow.pdf )"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~x86 ~amd64 ~ppc"
-IUSE="doc examples"
-
-DEPEND="x11-libs/libX11"
-
-RESTRICT="test"
-
-S="${WORKDIR}/Xfoil"
-
-FORTRAN="gfortran ifc g77"
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
-
- sed -e 's/-O3//g' -i plotlib/config.make || die "sed plotlib/config.make failed"
- echo "CC = $(tc-getCC)" >> plotlib/config.make
- echo "FC = ${FORTRANC}" >> plotlib/config.make
- echo "CFLAGS += ${CFLAGS}" >> plotlib/config.make
- echo "FFLAGS += ${FFLAGS:--O2}" >> plotlib/config.make
-
- sed -i \
- -e "s/^\(FC.*\)/FC = ${FORTRANC}/g" \
- -e "s/^\(CC.*\)/CC = $(tc-getCC)/g" \
- -e "s/^\(FFLAGS .*\)/FFLAGS = ${FFLAGS}/g" \
- -e "s/^\(FFLOPT .*\)/FFLOPT = \$(FFLAGS)/g" \
- -e "s/^\(FFLAGS2 .*\)/FFLAGS2 = \$(FFLAGS)/g" \
- bin/Makefile orrs/bin/Makefile \
- || die "sed for flags and compilers failed"
-
- # fix bug #147033
- [[ ${FORTRANC} == gfortran ]] && epatch "${FILESDIR}"/${P}-gfortran.patch
-
- # make everything double precision
- sed -i \
- -e 's:/var/local/codes/orrs/osmap.dat:/usr/share/xfoil/orrs/osmap.dat:' \
- -e 's:REAL*4:REAL:g' \
- orrs/src/osmap.f || die "sed osmap.f failed"
-}
-
-src_compile() {
- cd "${S}"/orrs/bin
- emake FLG="${FFLAGS}" FTNLIB="" OS || die "failed to build orrs"
- cd "${S}"/orrs
- bin/osgen osmaps_ns.lst
- cd "${S}"/plotlib
- emake DP="" || die "failed to build plotlib"
- cd "${S}"/bin
- for i in xfoil pplot pxplot; do
- emake CFLAGS="${CFLAGS} -DUNDERSCORE" ${i} || die "failed to build ${i}"
- done
-}
-
-src_install() {
- dobin bin/pplot bin/pxplot bin/xfoil || die "dobin failed"
- insinto /usr/share/xfoil/orrs
- doins orrs/osm*.dat || die "orrs data install failed"
- dodoc *.txt README || die "dodoc failed"
- insinto /usr/share/doc/${PF}/
- use examples && { doins -r runs || die "examples install failed"; }
- use doc && { doins "${DISTDIR}"/dataflow.pdf || die "doc install failed"; }
-}