summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-emacs/yatex/ChangeLog7
-rw-r--r--app-emacs/yatex/files/yatex-1.76-direntry.patch60
-rw-r--r--app-emacs/yatex/yatex-1.76.ebuild19
3 files changed, 77 insertions, 9 deletions
diff --git a/app-emacs/yatex/ChangeLog b/app-emacs/yatex/ChangeLog
index 652aeee15d9b..3b997713794b 100644
--- a/app-emacs/yatex/ChangeLog
+++ b/app-emacs/yatex/ChangeLog
@@ -1,9 +1,10 @@
# ChangeLog for app-emacs/yatex
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emacs/yatex/ChangeLog,v 1.35 2012/10/11 16:31:17 ulm Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/yatex/ChangeLog,v 1.36 2012/10/11 18:59:14 ulm Exp $
- 11 Oct 2012; Ulrich Müller <ulm@gentoo.org> yatex-1.76.ebuild:
- Fix installation of GNU Info files, bug 437612.
+ 11 Oct 2012; Ulrich Müller <ulm@gentoo.org> yatex-1.76.ebuild,
+ +files/yatex-1.76-direntry.patch:
+ Fix GNU Info files, bug 437612. Drop ppc to unstable again.
11 Oct 2012; Chema Alonso <nimiux@gentoo.org> yatex-1.76.ebuild:
Missed the blocker bug (#437612) marking unstable for amd64
diff --git a/app-emacs/yatex/files/yatex-1.76-direntry.patch b/app-emacs/yatex/files/yatex-1.76-direntry.patch
new file mode 100644
index 000000000000..8dc0c5f310f7
--- /dev/null
+++ b/app-emacs/yatex/files/yatex-1.76-direntry.patch
@@ -0,0 +1,60 @@
+--- yatex1.76-orig/docs/yahtmle.tex
++++ yatex1.76/docs/yahtmle.tex
+@@ -1,9 +1,10 @@
+ \def\lang{eng} % -*- texinfo -*- for Texinfo V.3.1
+ \input texinfo
+-@setfilename yahtmle
++@setfilename yahtml.info
+ @settitle Yet Another html-mode for Emacs
++@dircategory Emacs
+ @direntry
+-* yahtml-e: (yahtmle). Yet Another html-mode for Emacs (English).
++* yahtml: (yahtml). Yet Another html-mode for Emacs (English).
+ @end direntry
+
+ @iftex
+--- yatex1.76-orig/docs/yahtmlj.tex
++++ yatex1.76/docs/yahtmlj.tex
+@@ -1,9 +1,10 @@
+ \def\lang{jp} % -*- texinfo -*- for Texinfo V.3.1
+ \input texinfo
+-@setfilename yahtmlj
++@setfilename yahtml-ja.info
+ @settitle Yet Another html-mode for Emacs
++@dircategory Emacs
+ @direntry
+-* yahtml: (yahtmlj). Yet Another html-mode for Emacs (Japanese).
++* yahtml-ja: (yahtml-ja). Yet Another html-mode for Emacs (Japanese).
+ @end direntry
+
+ @iftex
+--- yatex1.76-orig/docs/yatexe.tex
++++ yatex1.76/docs/yatexe.tex
+@@ -1,9 +1,10 @@
+ \def\lang{jp} % -*- texinfo -*-
+ \input texinfo.tex
+-@setfilename yatexe
++@setfilename yatex.info
+ @settitle Yet Another tex-mode for Emacs
++@dircategory Emacs
+ @direntry
+-* YaTeX-e: (yatexe). Yet Another tex-mode for Emacs (English).
++* YaTeX: (yatex). Yet Another tex-mode for Emacs (English).
+ @end direntry
+
+ @iftex
+--- yatex1.76-orig/docs/yatexj.tex
++++ yatex1.76/docs/yatexj.tex
+@@ -1,9 +1,10 @@
+ \def\lang{jp} % -*- texinfo -*- for Texinfo V.3.1
+ \input texinfo
+-@setfilename yatexj
++@setfilename yatex-ja.info
+ @settitle Yet Another tex-mode for Emacs
++@dircategory Emacs
+ @direntry
+-* YaTeX: (yatexj). Yet Another tex-mode for Emacs (Japanese).
++* YaTeX-ja: (yatex-ja). Yet Another tex-mode for Emacs (Japanese).
+ @end direntry
+
+ @iftex
diff --git a/app-emacs/yatex/yatex-1.76.ebuild b/app-emacs/yatex/yatex-1.76.ebuild
index 9e8403e5c1c5..b1cc6b72ccfd 100644
--- a/app-emacs/yatex/yatex-1.76.ebuild
+++ b/app-emacs/yatex/yatex-1.76.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emacs/yatex/yatex-1.76.ebuild,v 1.8 2012/10/11 16:31:17 ulm Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/yatex/yatex-1.76.ebuild,v 1.9 2012/10/11 18:59:14 ulm Exp $
EAPI=4
@@ -10,19 +10,26 @@ DESCRIPTION="Yet Another TeX mode for Emacs"
HOMEPAGE="http://www.yatex.org/"
SRC_URI="http://www.yatex.org/${P/-/}.tar.gz"
-KEYWORDS="~alpha ~amd64 ppc ~ppc64 ~sparc ~x86"
+KEYWORDS="~alpha ~amd64 ~ppc ~ppc64 ~sparc ~x86"
SLOT="0"
LICENSE="YaTeX"
IUSE="linguas_ja"
S="${WORKDIR}/${P/-/}"
-ELISP_PATCHES="${PN}-1.76-gentoo.patch"
+ELISP_PATCHES="${PN}-1.76-gentoo.patch
+ ${PN}-1.76-direntry.patch"
SITEFILE="50${PN}-gentoo.el"
src_compile() {
# byte-compilation fails (as of 1.74): yatexlib.el requires fonts
# that are only available under X
- :
+
+ local texi="yatexe.tex yahtmle.tex"
+ use linguas_ja && texi+=" yatexj.tex yahtmlj.tex"
+
+ cd docs
+ # makeinfo fails, so use Emacs to generate Info from Texinfo
+ ${EMACS} ${EMACSFLAGS} -l texinfmt -f batch-texinfo-format ${texi} || die
}
src_install() {
@@ -31,12 +38,12 @@ src_install() {
insinto ${SITEETC}/${PN}
doins help/YATEXHLP.eng
- doinfo docs/yatexe docs/yahtmle
+ doinfo docs/yatex.info docs/yahtml.info
dodoc docs/*.eng
if use linguas_ja; then
doins help/YATEXHLP.jp
- doinfo docs/yatexj docs/yahtmlj
+ doinfo docs/yatex-ja.info docs/yahtml-ja.info
dodoc 00readme install docs/{htmlqa,qanda} docs/*.doc
fi
}