summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-python/cython/ChangeLog8
-rw-r--r--dev-python/cython/cython-0.12_rc1.ebuild66
2 files changed, 73 insertions, 1 deletions
diff --git a/dev-python/cython/ChangeLog b/dev-python/cython/ChangeLog
index 3782f9f7f00a..1f99cb24ecb9 100644
--- a/dev-python/cython/ChangeLog
+++ b/dev-python/cython/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/cython
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/cython/ChangeLog,v 1.33 2009/11/14 16:37:28 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/cython/ChangeLog,v 1.34 2009/11/21 00:48:02 arfrever Exp $
+
+*cython-0.12_rc1 (21 Nov 2009)
+
+ 21 Nov 2009; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ +cython-0.12_rc1.ebuild:
+ Version bump.
14 Nov 2009; Raúl Porcel <armin76@gentoo.org> cython-0.11.3.ebuild:
ia64/sparc stable wrt #291193
diff --git a/dev-python/cython/cython-0.12_rc1.ebuild b/dev-python/cython/cython-0.12_rc1.ebuild
new file mode 100644
index 000000000000..7663bd2ba1b7
--- /dev/null
+++ b/dev-python/cython/cython-0.12_rc1.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/cython/cython-0.12_rc1.ebuild,v 1.1 2009/11/21 00:48:02 arfrever Exp $
+
+EAPI="2"
+SUPPORT_PYTHON_ABIS="1"
+
+inherit distutils flag-o-matic
+
+MY_PN="Cython"
+MY_P="${MY_PN}-${PV/_/.}"
+
+DESCRIPTION="A language for writing Python extension modules based on pyrex"
+HOMEPAGE="http://www.cython.org/ http://pypi.python.org/pypi/Cython"
+SRC_URI="http://pypi.python.org/packages/source/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz
+ http://www.cython.org/release/${MY_P}.tar.gz"
+
+LICENSE="PSF-2.4"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x64-solaris ~x86-solaris"
+IUSE="doc examples"
+
+DEPEND=""
+RDEPEND=""
+
+S="${WORKDIR}/${MY_P}"
+
+PYTHON_MODNAME="${MY_PN} pyximport"
+DOCS="ToDo.txt USAGE.txt"
+
+pkg_setup() {
+ if use amd64; then
+ # Tests fail with some optimizations.
+ replace-flags -O[2-9s]* -O1
+ fi
+}
+
+src_prepare() {
+ distutils_src_prepare
+
+ # Delete needless file which breaks tests.
+ rm -f Cython/Compiler/._Version.py
+}
+
+src_test() {
+ testing() {
+ rm -fr BUILD
+ # Tests sometimes hang with forking enabled.
+ "$(PYTHON)" runtests.py --no-fork -vv
+ }
+ python_execute_function testing
+}
+
+src_install() {
+ distutils_src_install
+
+ # '-A c' is for ignoring of Doc/primes.c.
+ use doc && dohtml -A c -r Doc/*
+
+ if use examples; then
+ # Demos/ has files with .so,~ suffixes.
+ # So we have to specify precisely what to install.
+ insinto /usr/share/doc/${PF}/examples
+ doins Demos/Makefile* Demos/setup.py Demos/*.{py,pyx}
+ fi
+}