summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-crypt/mcrypt/ChangeLog6
-rw-r--r--app-crypt/mcrypt/files/mcrypt-2.6.5-build.patch46
-rw-r--r--app-crypt/mcrypt/mcrypt-2.6.5.ebuild11
3 files changed, 57 insertions, 6 deletions
diff --git a/app-crypt/mcrypt/ChangeLog b/app-crypt/mcrypt/ChangeLog
index 041db2adfac3..b92d3eca8489 100644
--- a/app-crypt/mcrypt/ChangeLog
+++ b/app-crypt/mcrypt/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-crypt/mcrypt
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-crypt/mcrypt/ChangeLog,v 1.19 2007/05/01 06:53:55 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/mcrypt/ChangeLog,v 1.20 2007/05/11 19:52:12 alonbl Exp $
+
+ 11 May 2007; Alon Bar-Lev <alonbl@gentoo.org>
+ +files/mcrypt-2.6.5-build.patch, mcrypt-2.6.5.ebuild:
+ Fixed build errors, bug#176672
01 May 2007; Robin H. Johnson <robbat2@gentoo.org> metadata.xml:
This is a crypto package, mark metadata as such.
diff --git a/app-crypt/mcrypt/files/mcrypt-2.6.5-build.patch b/app-crypt/mcrypt/files/mcrypt-2.6.5-build.patch
new file mode 100644
index 000000000000..a4b42c1c2d93
--- /dev/null
+++ b/app-crypt/mcrypt/files/mcrypt-2.6.5-build.patch
@@ -0,0 +1,46 @@
+diff -urNp mcrypt-2.6.5.org/Makefile.am mcrypt-2.6.5/Makefile.am
+--- mcrypt-2.6.5.org/Makefile.am 2003-01-19 20:09:30.000000000 +0200
++++ mcrypt-2.6.5/Makefile.am 2007-05-11 22:52:14.000000000 +0300
+@@ -3,10 +3,10 @@
+ EXTRA_DIST = config.rpath INSTALL.generic THANKS NEWS
+ SUBDIRS = m4 doc src po
+ install-exec-hook:
+- -$(RM) -f $(bindir)/mdecrypt
+- $(LN_S) mcrypt $(bindir)/mdecrypt
++ -$(RM) -f $(DESTDIR)$(bindir)/mdecrypt
++ $(LN_S) mcrypt $(DESTDIR)$(bindir)/mdecrypt
+ uninstall-local:
+- -$(RM) -f $(bindir)/mdecrypt
++ -$(RM) -f $(DESTDIR)$(bindir)/mdecrypt
+
+ ChangeLog:
+ cvs2cl --utc --fsf -t -S --prune
+diff -urNp mcrypt-2.6.5.org/Makefile.in mcrypt-2.6.5/Makefile.in
+--- mcrypt-2.6.5.org/Makefile.in 2007-02-19 08:47:03.000000000 +0200
++++ mcrypt-2.6.5/Makefile.in 2007-05-11 22:52:33.000000000 +0300
+@@ -636,10 +636,10 @@ uninstall-info: uninstall-info-recursive
+ uninstall uninstall-am uninstall-info-am uninstall-local
+
+ install-exec-hook:
+- -$(RM) -f $(bindir)/mdecrypt
+- $(LN_S) mcrypt $(bindir)/mdecrypt
++ -$(RM) -f $(DESTDIR)$(bindir)/mdecrypt
++ $(LN_S) mcrypt $(DESTDIR)$(bindir)/mdecrypt
+ uninstall-local:
+- -$(RM) -f $(bindir)/mdecrypt
++ -$(RM) -f $(DESTDIR)$(bindir)/mdecrypt
+
+ ChangeLog:
+ cvs2cl --utc --fsf -t -S --prune
+diff -urNp mcrypt-2.6.5.org/po/Makefile.in.in mcrypt-2.6.5/po/Makefile.in.in
+--- mcrypt-2.6.5.org/po/Makefile.in.in 2003-02-21 19:45:55.000000000 +0200
++++ mcrypt-2.6.5/po/Makefile.in.in 2007-05-11 22:50:07.000000000 +0300
+@@ -27,7 +27,7 @@ gettextsrcdir = $(datadir)/gettext/po
+ INSTALL = @INSTALL@
+ INSTALL_DATA = @INSTALL_DATA@
+ MKINSTALLDIRS = @MKINSTALLDIRS@
+-mkinstalldirs = $(SHELL) `case "$(MKINSTALLDIRS)" in /*) echo "$(MKINSTALLDIRS)" ;; *) echo "$(top_builddir)/$(MKINSTALLDIRS)" ;; esac`
++mkinstalldirs = $(MKINSTALLDIRS)
+
+ GMSGFMT = @GMSGFMT@
+ MSGFMT = @MSGFMT@
diff --git a/app-crypt/mcrypt/mcrypt-2.6.5.ebuild b/app-crypt/mcrypt/mcrypt-2.6.5.ebuild
index 6aa52573573a..b2eed77420b2 100644
--- a/app-crypt/mcrypt/mcrypt-2.6.5.ebuild
+++ b/app-crypt/mcrypt/mcrypt-2.6.5.ebuild
@@ -1,6 +1,8 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-crypt/mcrypt/mcrypt-2.6.5.ebuild,v 1.2 2007/05/01 06:51:56 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/mcrypt/mcrypt-2.6.5.ebuild,v 1.3 2007/05/11 19:52:12 alonbl Exp $
+
+inherit eutils
DESCRIPTION="replacement of the old unix crypt(1)"
HOMEPAGE="http://mcrypt.sourceforge.net/"
@@ -12,13 +14,12 @@ KEYWORDS="~amd64 ~ppc ~sparc ~x86"
IUSE="nls"
DEPEND=">=dev-libs/libmcrypt-2.5.8
- >=app-crypt/mhash-0.8.15"
+ >=app-crypt/mhash-0.9.9"
src_unpack() {
unpack ${A}
- for f in ${S}/Makefile.am ${S}/Makefile.in; do
- sed -e 's,$(bindir),$(DESTDIR)$(bindir),g' -i ${f} || die 'sed failed'
- done
+ cd "${S}"
+ epatch "${FILESDIR}/${P}-build.patch"
}
src_compile() {