summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-vim/c-support/ChangeLog10
-rw-r--r--app-vim/c-support/c-support-5.13.ebuild28
-rw-r--r--app-vim/c-support/metadata.xml5
3 files changed, 43 insertions, 0 deletions
diff --git a/app-vim/c-support/ChangeLog b/app-vim/c-support/ChangeLog
new file mode 100644
index 000000000000..abe3dab8239b
--- /dev/null
+++ b/app-vim/c-support/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for app-vim/c-support
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-vim/c-support/ChangeLog,v 1.1 2011/04/29 04:28:46 radhermit Exp $
+
+*c-support-5.13 (29 Apr 2011)
+
+ 29 Apr 2011; Tim Harder <radhermit@gentoo.org> +c-support-5.13.ebuild,
+ +metadata.xml:
+ Initial import.
+
diff --git a/app-vim/c-support/c-support-5.13.ebuild b/app-vim/c-support/c-support-5.13.ebuild
new file mode 100644
index 000000000000..b443a9dd2d86
--- /dev/null
+++ b/app-vim/c-support/c-support-5.13.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-vim/c-support/c-support-5.13.ebuild,v 1.1 2011/04/29 04:28:46 radhermit Exp $
+
+EAPI="4"
+VIM_PLUGIN_VIM_VERSION="7.0"
+
+inherit vim-plugin
+
+DESCRIPTION="vim plugin: C/C++-IDE -- Write and run programs using menus and hotkeys"
+HOMEPAGE="http://www.vim.org/scripts/script.php?script_id=213"
+SRC_URI="http://www.vim.org/scripts/download_script.php?src_id=14859 -> ${P}.zip"
+LICENSE="public-domain"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+VIM_PLUGIN_HELPFILES="csupport.txt"
+
+DEPEND="app-arch/unzip"
+
+S=${WORKDIR}
+
+src_install() {
+ dodoc ${PN}/doc/{ChangeLog,c-hotkeys.pdf}
+ rm -rf ${PN}/doc README.csupport
+
+ vim-plugin_src_install
+}
diff --git a/app-vim/c-support/metadata.xml b/app-vim/c-support/metadata.xml
new file mode 100644
index 000000000000..d221a8d4b42c
--- /dev/null
+++ b/app-vim/c-support/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>vim</herd>
+</pkgmetadata>