summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-python/pycuda/ChangeLog7
-rw-r--r--dev-python/pycuda/pycuda-9999.ebuild53
2 files changed, 59 insertions, 1 deletions
diff --git a/dev-python/pycuda/ChangeLog b/dev-python/pycuda/ChangeLog
index 43da7dde78cd..7a727cbfa05a 100644
--- a/dev-python/pycuda/ChangeLog
+++ b/dev-python/pycuda/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/pycuda
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pycuda/ChangeLog,v 1.1 2009/06/06 15:44:44 spock Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pycuda/ChangeLog,v 1.2 2009/08/09 08:44:46 spock Exp $
+
+*pycuda-9999 (09 Aug 2009)
+
+ 09 Aug 2009; Michał Januszewski <spock@gentoo.org> +pycuda-9999.ebuild:
+ Add a live git ebuild. Ebuild submitted by Justin T. Riley in bug #280576.
*pycuda-0.92 (06 Jun 2009)
diff --git a/dev-python/pycuda/pycuda-9999.ebuild b/dev-python/pycuda/pycuda-9999.ebuild
new file mode 100644
index 000000000000..c0ac321fc84b
--- /dev/null
+++ b/dev-python/pycuda/pycuda-9999.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pycuda/pycuda-9999.ebuild,v 1.1 2009/08/09 08:44:46 spock Exp $
+# Ebuild generated by g-pypi 0.2.1 (rev. 204)
+
+EAPI="2"
+
+inherit git distutils
+
+EGIT_REPO_URI="http://git.tiker.net/trees/pycuda.git"
+
+DESCRIPTION="Python wrapper for NVIDIA CUDA"
+HOMEPAGE="http://mathema.tician.de/software/pycuda"
+SRC_URI=""
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="examples"
+
+RDEPEND="=dev-python/pytools-9999
+ dev-libs/boost
+ >=dev-util/nvidia-cuda-toolkit-2.0
+ >=dev-python/numpy-1.0.4"
+
+DEPEND="${RDEPEND}"
+
+src_unpack() {
+ git_src_unpack
+ cd "${S}"
+}
+
+src_configure()
+{
+ ./configure.py --cuda-root="${ROOT}opt/cuda" --boost-python-libname=boost_python-mt --boost-thread-libname=boost_thread-mt --boost-compiler=gcc
+}
+
+src_install()
+{
+ distutils_src_install
+ insinto /usr/share/doc/${PF}
+ if use examples; then
+ doins -r examples || die
+ fi
+}
+
+pkg_postinst()
+{
+ distutils_pkg_postinst
+ if use examples; then
+ elog "Some of the examples provided by this package require dev-python/matplotlib."
+ fi
+}