summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net-print/cups/ChangeLog6
-rw-r--r--net-print/cups/cups-1.7.5.ebuild17
-rw-r--r--net-print/cups/cups-1.7.9999.ebuild17
-rw-r--r--net-print/cups/cups-9999.ebuild17
4 files changed, 50 insertions, 7 deletions
diff --git a/net-print/cups/ChangeLog b/net-print/cups/ChangeLog
index 64b735bd687e..b783a04938e5 100644
--- a/net-print/cups/ChangeLog
+++ b/net-print/cups/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-print/cups
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-print/cups/ChangeLog,v 1.627 2014/09/06 18:56:00 dilfridge Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-print/cups/ChangeLog,v 1.628 2014/09/06 19:30:17 dilfridge Exp $
+
+ 06 Sep 2014; Andreas K. Huettel <dilfridge@gentoo.org> cups-1.7.5.ebuild,
+ cups-1.7.9999.ebuild, cups-9999.ebuild:
+ Pass correct parameters regarding libusb to configure, bug 513552
*cups-1.7.9999 (06 Sep 2014)
diff --git a/net-print/cups/cups-1.7.5.ebuild b/net-print/cups/cups-1.7.5.ebuild
index 526a360a5116..9c80b660c447 100644
--- a/net-print/cups/cups-1.7.5.ebuild
+++ b/net-print/cups/cups-1.7.5.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-print/cups/cups-1.7.5.ebuild,v 1.1 2014/09/06 18:49:59 dilfridge Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-print/cups/cups-1.7.5.ebuild,v 1.2 2014/09/06 19:30:17 dilfridge Exp $
EAPI=5
@@ -192,6 +192,20 @@ multilib_src_configure() {
)
fi
+ # the following is needed only because of bug 513552
+ # and replaces a simpler
+ # $(multilib_native_use_enable usb libusb)
+ #
+ if use usb && multilib_is_native_abi; then
+ myconf+=(
+ --enable-libusb=yes
+ )
+ else
+ myconf+=(
+ --enable-libusb=no
+ )
+ fi
+
# need to override KRB5CONFIG for proper flags
# https://www.cups.org/str.php?L4423
econf \
@@ -213,7 +227,6 @@ multilib_src_configure() {
$(multilib_native_use_enable pam) \
$(use_enable static-libs static) \
$(use_enable threads) \
- $(multilib_native_use_enable usb libusb) \
--disable-dnssd \
$(multilib_native_use_with java) \
--without-perl \
diff --git a/net-print/cups/cups-1.7.9999.ebuild b/net-print/cups/cups-1.7.9999.ebuild
index 32446973ffdd..b6ba9f54dd67 100644
--- a/net-print/cups/cups-1.7.9999.ebuild
+++ b/net-print/cups/cups-1.7.9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-print/cups/cups-1.7.9999.ebuild,v 1.1 2014/09/06 18:56:00 dilfridge Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-print/cups/cups-1.7.9999.ebuild,v 1.2 2014/09/06 19:30:17 dilfridge Exp $
EAPI=5
@@ -192,6 +192,20 @@ multilib_src_configure() {
)
fi
+ # the following is needed only because of bug 513552
+ # and replaces a simpler
+ # $(multilib_native_use_enable usb libusb)
+ #
+ if use usb && multilib_is_native_abi; then
+ myconf+=(
+ --enable-libusb=yes
+ )
+ else
+ myconf+=(
+ --enable-libusb=no
+ )
+ fi
+
# need to override KRB5CONFIG for proper flags
# https://www.cups.org/str.php?L4423
econf \
@@ -213,7 +227,6 @@ multilib_src_configure() {
$(multilib_native_use_enable pam) \
$(use_enable static-libs static) \
$(use_enable threads) \
- $(multilib_native_use_enable usb libusb) \
--disable-dnssd \
$(multilib_native_use_with java) \
--without-perl \
diff --git a/net-print/cups/cups-9999.ebuild b/net-print/cups/cups-9999.ebuild
index 6bd2523e2586..1e8ca65b58f8 100644
--- a/net-print/cups/cups-9999.ebuild
+++ b/net-print/cups/cups-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-print/cups/cups-9999.ebuild,v 1.61 2014/09/06 18:56:00 dilfridge Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-print/cups/cups-9999.ebuild,v 1.62 2014/09/06 19:30:17 dilfridge Exp $
EAPI=5
@@ -192,6 +192,20 @@ multilib_src_configure() {
)
fi
+ # the following is needed only because of bug 513552
+ # and replaces a simpler
+ # $(multilib_native_use_enable usb libusb)
+ #
+ if use usb && multilib_is_native_abi; then
+ myconf+=(
+ --enable-libusb=yes
+ )
+ else
+ myconf+=(
+ --enable-libusb=no
+ )
+ fi
+
# need to override KRB5CONFIG for proper flags
# https://www.cups.org/str.php?L4423
econf \
@@ -213,7 +227,6 @@ multilib_src_configure() {
$(multilib_native_use_enable pam) \
$(use_enable static-libs static) \
$(use_enable threads) \
- $(multilib_native_use_enable usb libusb) \
--disable-dnssd \
$(multilib_native_use_with java) \
--without-perl \