summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net-libs/wvstreams/ChangeLog8
-rw-r--r--net-libs/wvstreams/files/wvstreams-4.0.1-wireless-user.patch11
-rw-r--r--net-libs/wvstreams/files/wvstreams-4.0.2-wireless-user.patch11
-rw-r--r--net-libs/wvstreams/wvstreams-4.0.1-r2.ebuild3
-rw-r--r--net-libs/wvstreams/wvstreams-4.0.2.ebuild3
5 files changed, 33 insertions, 3 deletions
diff --git a/net-libs/wvstreams/ChangeLog b/net-libs/wvstreams/ChangeLog
index 5acd2a34682a..6c95d5df6a93 100644
--- a/net-libs/wvstreams/ChangeLog
+++ b/net-libs/wvstreams/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-libs/wvstreams
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/wvstreams/ChangeLog,v 1.49 2005/04/03 05:48:54 lu_zero Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/wvstreams/ChangeLog,v 1.50 2005/04/04 21:05:26 mrness Exp $
+
+ 04 Apr 2005; Alin Nastac <mrness@gentoo.org>
+ +files/wvstreams-4.0.1-wireless-user.patch,
+ +files/wvstreams-4.0.2-wireless-user.patch, wvstreams-4.0.1-r2.ebuild,
+ wvstreams-4.0.2.ebuild:
+ Fix compile error regarding __user declaration (#76943).
03 Apr 2005; Luca Barbato <lu_zero@gentoo.org> wvstreams-4.0.2.ebuild:
Updated SRC_URI and moved to vorbis useflag
diff --git a/net-libs/wvstreams/files/wvstreams-4.0.1-wireless-user.patch b/net-libs/wvstreams/files/wvstreams-4.0.1-wireless-user.patch
new file mode 100644
index 000000000000..79acbedf4543
--- /dev/null
+++ b/net-libs/wvstreams/files/wvstreams-4.0.1-wireless-user.patch
@@ -0,0 +1,11 @@
+diff -Nru wvstreams-4.0.1.orig/linuxstreams/wvinterface.cc wvstreams-4.0.1/linuxstreams/wvinterface.cc
+--- wvstreams-4.0.1.orig/linuxstreams/wvinterface.cc 2004-11-18 16:15:05.000000000 +0200
++++ wvstreams-4.0.1/linuxstreams/wvinterface.cc 2005-04-04 23:04:09.079108128 +0300
+@@ -21,6 +21,7 @@
+ #include <errno.h>
+ #include <linux/sockios.h>
+
++#include <linux/compiler.h>
+ #define _LINUX_IF_H /* Hack to prevent loading linux/if.h */
+ #include <linux/wireless.h>
+
diff --git a/net-libs/wvstreams/files/wvstreams-4.0.2-wireless-user.patch b/net-libs/wvstreams/files/wvstreams-4.0.2-wireless-user.patch
new file mode 100644
index 000000000000..6ba608656fee
--- /dev/null
+++ b/net-libs/wvstreams/files/wvstreams-4.0.2-wireless-user.patch
@@ -0,0 +1,11 @@
+diff -Nru wvstreams-4.0.2.orig/linuxstreams/wvinterface.cc wvstreams-4.0.2/linuxstreams/wvinterface.cc
+--- wvstreams-4.0.2.orig/linuxstreams/wvinterface.cc 2005-03-24 04:01:23.000000000 +0200
++++ wvstreams-4.0.2/linuxstreams/wvinterface.cc 2005-04-04 23:06:23.927608040 +0300
+@@ -21,6 +21,7 @@
+ #include <errno.h>
+ #include <linux/sockios.h>
+
++#include <linux/compiler.h>
+ #define _LINUX_IF_H /* Hack to prevent loading linux/if.h */
+ #include <linux/wireless.h>
+
diff --git a/net-libs/wvstreams/wvstreams-4.0.1-r2.ebuild b/net-libs/wvstreams/wvstreams-4.0.1-r2.ebuild
index e06cfd7ec113..8df4b210c331 100644
--- a/net-libs/wvstreams/wvstreams-4.0.1-r2.ebuild
+++ b/net-libs/wvstreams/wvstreams-4.0.1-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/wvstreams/wvstreams-4.0.1-r2.ebuild,v 1.6 2005/03/24 01:50:27 weeve Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/wvstreams/wvstreams-4.0.1-r2.ebuild,v 1.7 2005/04/04 21:05:26 mrness Exp $
inherit eutils
@@ -39,6 +39,7 @@ src_unpack() {
unpack ${A} ; cd ${S}
epatch ${FILESDIR}/${P}-linux-serial.patch
+ epatch ${FILESDIR}/${P}-wireless-user.patch
epatch ${FILESDIR}/${P}-without-pam.patch
if useq tcltk; then
diff --git a/net-libs/wvstreams/wvstreams-4.0.2.ebuild b/net-libs/wvstreams/wvstreams-4.0.2.ebuild
index cddf95f3b8c8..277283e9f74d 100644
--- a/net-libs/wvstreams/wvstreams-4.0.2.ebuild
+++ b/net-libs/wvstreams/wvstreams-4.0.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/wvstreams/wvstreams-4.0.2.ebuild,v 1.3 2005/04/03 05:48:54 lu_zero Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/wvstreams/wvstreams-4.0.2.ebuild,v 1.4 2005/04/04 21:05:26 mrness Exp $
inherit eutils
@@ -39,6 +39,7 @@ src_unpack() {
unpack ${A} ; cd ${S}
epatch ${FILESDIR}/${P}-linux-serial.patch
+ epatch ${FILESDIR}/${P}-wireless-user.patch
epatch ${FILESDIR}/${P}-speex-const.patch
if useq tcltk; then