summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-admin/apache-tools/ChangeLog7
-rw-r--r--app-admin/apache-tools/apache-tools-2.2.10.ebuild3
-rw-r--r--app-admin/apache-tools/apache-tools-2.2.11.ebuild3
-rw-r--r--app-admin/apache-tools/apache-tools-2.2.8.ebuild90
-rw-r--r--app-admin/apache-tools/apache-tools-2.2.9.ebuild90
5 files changed, 10 insertions, 183 deletions
diff --git a/app-admin/apache-tools/ChangeLog b/app-admin/apache-tools/ChangeLog
index 9cfbe44db3ad..c43dfc6ba110 100644
--- a/app-admin/apache-tools/ChangeLog
+++ b/app-admin/apache-tools/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-admin/apache-tools
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/apache-tools/ChangeLog,v 1.58 2009/05/02 13:28:29 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/apache-tools/ChangeLog,v 1.59 2009/07/05 16:07:10 hollow Exp $
+
+ 05 Jul 2009; Benedikt Böhm <hollow@gentoo.org>
+ -apache-tools-2.2.8.ebuild, -apache-tools-2.2.9.ebuild,
+ apache-tools-2.2.10.ebuild, apache-tools-2.2.11.ebuild:
+ symlink htdigest, bug #219515
02 May 2009; Jeroen Roovers <jer@gentoo.org> apache-tools-2.2.11.ebuild:
Stable for HPPA (bug #265705).
diff --git a/app-admin/apache-tools/apache-tools-2.2.10.ebuild b/app-admin/apache-tools/apache-tools-2.2.10.ebuild
index 7501027a7fa8..aa734cd6b21a 100644
--- a/app-admin/apache-tools/apache-tools-2.2.10.ebuild
+++ b/app-admin/apache-tools/apache-tools-2.2.10.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/apache-tools/apache-tools-2.2.10.ebuild,v 1.7 2009/01/23 11:28:48 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/apache-tools/apache-tools-2.2.10.ebuild,v 1.8 2009/07/05 16:07:10 hollow Exp $
inherit flag-o-matic eutils
@@ -85,6 +85,7 @@ src_install () {
# make htpasswd accessible for non-root users
dosym /usr/sbin/htpasswd /usr/bin/htpasswd
+ dosym /usr/sbin/htdigest /usr/bin/htdigest
dodoc "${S}"/CHANGES
}
diff --git a/app-admin/apache-tools/apache-tools-2.2.11.ebuild b/app-admin/apache-tools/apache-tools-2.2.11.ebuild
index b389c0e9e919..be82861bd076 100644
--- a/app-admin/apache-tools/apache-tools-2.2.11.ebuild
+++ b/app-admin/apache-tools/apache-tools-2.2.11.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/apache-tools/apache-tools-2.2.11.ebuild,v 1.7 2009/05/02 13:28:29 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/apache-tools/apache-tools-2.2.11.ebuild,v 1.8 2009/07/05 16:07:10 hollow Exp $
inherit flag-o-matic eutils
@@ -85,6 +85,7 @@ src_install () {
# make htpasswd accessible for non-root users
dosym /usr/sbin/htpasswd /usr/bin/htpasswd
+ dosym /usr/sbin/htdigest /usr/bin/htdigest
dodoc "${S}"/CHANGES
}
diff --git a/app-admin/apache-tools/apache-tools-2.2.8.ebuild b/app-admin/apache-tools/apache-tools-2.2.8.ebuild
deleted file mode 100644
index 5497125d7bdb..000000000000
--- a/app-admin/apache-tools/apache-tools-2.2.8.ebuild
+++ /dev/null
@@ -1,90 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/apache-tools/apache-tools-2.2.8.ebuild,v 1.9 2008/06/15 15:40:46 hollow Exp $
-
-inherit flag-o-matic eutils
-
-DESCRIPTION="Useful Apache tools - htdigest, htpasswd, ab, htdbm"
-HOMEPAGE="http://httpd.apache.org/"
-SRC_URI="mirror://apache/httpd/httpd-${PV}.tar.bz2"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 s390 sh sparc x86 ~x86-fbsd"
-IUSE="ssl"
-RESTRICT="test"
-
-RDEPEND="=dev-libs/apr-1*
- =dev-libs/apr-util-1*
- dev-libs/libpcre
- ssl? ( dev-libs/openssl )
- !<www-servers/apache-2.2.4"
-
-DEPEND="${RDEPEND}"
-
-S="${WORKDIR}/httpd-${PV}"
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
-
- # Apply these patches:
- # (1) apache-tools-Makefile.patch:
- # - fix up the `make install' for support/
- # - remove envvars from `make install'
- epatch "${FILESDIR}"/${PN}-Makefile.patch
-}
-
-src_compile() {
- local myconf=""
- cd "${S}"
-
- # Instead of filtering --as-needed (bug #128505), append --no-as-needed
- # Thanks to Harald van Dijk
- append-ldflags -Wl,--no-as-needed
-
- if use ssl ; then
- myconf="${myconf} --with-ssl=/usr --enable-ssl"
- fi
-
- # econf overwrites the stuff from config.layout, so we have to put them into
- # our myconf line too
-
- econf \
- --sbindir=/usr/sbin \
- --with-perl=/usr/bin/perl \
- --with-expat=/usr \
- --with-z=/usr \
- --with-apr=/usr \
- --with-apr-util=/usr \
- --with-pcre=/usr \
- ${myconf} || die "econf failed!"
-
- cd support
- emake || die "emake support/ failed!"
-}
-
-src_install () {
- cd "${S}"/support
-
- make DESTDIR="${D}" install || die "make install failed!"
-
- # install manpages
- doman "${S}"/docs/man/{dbmmanage,htdigest,htpasswd,htdbm}.1 \
- "${S}"/docs/man/{ab,htcacheclean,logresolve,rotatelogs}.8
-
- # Providing compatiblity symlinks for #177697 (which we'll stop to install
- # at some point).
-
- for i in $(ls "${D}"/usr/sbin 2>/dev/null); do
- dosym /usr/sbin/${i} /usr/sbin/${i}2
- done
-
- # Provide a symlink for ab-ssl
- if use ssl ; then
- dosym /usr/sbin/ab /usr/sbin/ab-ssl
- dosym /usr/sbin/ab /usr/sbin/ab2-ssl
- fi
-
- dodoc "${S}"/CHANGES
-}
diff --git a/app-admin/apache-tools/apache-tools-2.2.9.ebuild b/app-admin/apache-tools/apache-tools-2.2.9.ebuild
deleted file mode 100644
index 56d1f1a9163d..000000000000
--- a/app-admin/apache-tools/apache-tools-2.2.9.ebuild
+++ /dev/null
@@ -1,90 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/apache-tools/apache-tools-2.2.9.ebuild,v 1.9 2008/10/25 21:56:33 vapier Exp $
-
-inherit flag-o-matic eutils
-
-DESCRIPTION="Useful Apache tools - htdigest, htpasswd, ab, htdbm"
-HOMEPAGE="http://httpd.apache.org/"
-SRC_URI="mirror://apache/httpd/httpd-${PV}.tar.bz2"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 s390 sh sparc ~sparc-fbsd x86 ~x86-fbsd"
-IUSE="ssl"
-RESTRICT="test"
-
-RDEPEND="=dev-libs/apr-1*
- =dev-libs/apr-util-1*
- dev-libs/libpcre
- ssl? ( dev-libs/openssl )
- !<www-servers/apache-2.2.4"
-
-DEPEND="${RDEPEND}"
-
-S="${WORKDIR}/httpd-${PV}"
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
-
- # Apply these patches:
- # (1) apache-tools-Makefile.patch:
- # - fix up the `make install' for support/
- # - remove envvars from `make install'
- epatch "${FILESDIR}"/${PN}-Makefile.patch
-}
-
-src_compile() {
- local myconf=""
- cd "${S}"
-
- # Instead of filtering --as-needed (bug #128505), append --no-as-needed
- # Thanks to Harald van Dijk
- append-ldflags -Wl,--no-as-needed
-
- if use ssl ; then
- myconf="${myconf} --with-ssl=/usr --enable-ssl"
- fi
-
- # econf overwrites the stuff from config.layout, so we have to put them into
- # our myconf line too
- econf \
- --sbindir=/usr/sbin \
- --with-z=/usr \
- --with-apr=/usr \
- --with-apr-util=/usr \
- --with-pcre=/usr \
- ${myconf} || die "econf failed!"
-
- cd support
- emake || die "emake support/ failed!"
-}
-
-src_install () {
- cd "${S}"/support
-
- make DESTDIR="${D}" install || die "make install failed!"
-
- # install manpages
- doman "${S}"/docs/man/{dbmmanage,htdigest,htpasswd,htdbm}.1 \
- "${S}"/docs/man/{ab,htcacheclean,logresolve,rotatelogs}.8
-
- # Providing compatiblity symlinks for #177697 (which we'll stop to install
- # at some point).
-
- for i in $(ls "${D}"/usr/sbin 2>/dev/null); do
- dosym /usr/sbin/${i} /usr/sbin/${i}2
- done
-
- # Provide a symlink for ab-ssl
- if use ssl ; then
- dosym /usr/sbin/ab /usr/sbin/ab-ssl
- dosym /usr/sbin/ab /usr/sbin/ab2-ssl
- fi
-
- # make htpasswd accessible for non-root users
- dosym /usr/sbin/htpasswd /usr/bin/htpasswd
-
- dodoc "${S}"/CHANGES
-}