summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--games-board/gnono/gnono-0.0.3.ebuild10
-rw-r--r--games-board/slibo/slibo-0.4.4.ebuild11
-rw-r--r--games-emulation/mamory/mamory-0.2.11.ebuild10
-rw-r--r--games-engines/exult/exult-1.00.ebuild8
4 files changed, 19 insertions, 20 deletions
diff --git a/games-board/gnono/gnono-0.0.3.ebuild b/games-board/gnono/gnono-0.0.3.ebuild
index c707493170ab..25ba36f6a159 100644
--- a/games-board/gnono/gnono-0.0.3.ebuild
+++ b/games-board/gnono/gnono-0.0.3.ebuild
@@ -1,12 +1,12 @@
-# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-board/gnono/gnono-0.0.3.ebuild,v 1.1 2003/09/10 17:46:27 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-board/gnono/gnono-0.0.3.ebuild,v 1.2 2004/02/29 10:29:08 vapier Exp $
inherit games
DESCRIPTION="rewrite of Windows card game WUNO"
-SRC_URI="ftp://ftp.paw.co.za/pub/PAW/sources/${P}.tar.gz"
HOMEPAGE="http://www.paw.co.za/projects/gnono/"
+SRC_URI="ftp://ftp.paw.co.za/pub/PAW/sources/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
@@ -20,11 +20,11 @@ DEPEND="gnome-base/gnome-libs
=x11-libs/gtk+-1.2*"
src_compile() {
- egamesconf `use_enable nls`
+ egamesconf `use_enable nls` || die
emake || die
}
src_install() {
- einstall
+ einstall || die
prepgamesdirs
}
diff --git a/games-board/slibo/slibo-0.4.4.ebuild b/games-board/slibo/slibo-0.4.4.ebuild
index 94513a27a1d0..8c30bc71a1d9 100644
--- a/games-board/slibo/slibo-0.4.4.ebuild
+++ b/games-board/slibo/slibo-0.4.4.ebuild
@@ -1,17 +1,16 @@
-# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-board/slibo/slibo-0.4.4.ebuild,v 1.2 2003/12/01 08:07:33 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-board/slibo/slibo-0.4.4.ebuild,v 1.3 2004/02/29 10:29:26 vapier Exp $
inherit kde
-
need-kde 3
DESCRIPTION="A comfortable replacement for the xboard chess interface"
-SRC_URI="mirror://sourceforge/slibo/${P}.tar.bz2"
HOMEPAGE="http://slibo.sourceforge.net/"
+SRC_URI="mirror://sourceforge/slibo/${P}.tar.bz2"
LICENSE="GPL-2"
-KEYWORDS="x86"
SLOT="0"
+KEYWORDS="x86"
-DEPEND="${DEPEND} dev-db/sqlite"
+DEPEND="dev-db/sqlite"
diff --git a/games-emulation/mamory/mamory-0.2.11.ebuild b/games-emulation/mamory/mamory-0.2.11.ebuild
index b70881b2d1a6..401878408525 100644
--- a/games-emulation/mamory/mamory-0.2.11.ebuild
+++ b/games-emulation/mamory/mamory-0.2.11.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header:
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/mamory/mamory-0.2.11.ebuild,v 1.4 2004/02/29 10:33:53 vapier Exp $
inherit games
@@ -10,7 +10,7 @@ SRC_URI="mirror://sourceforge/mamory/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="~x86 ~amd64 ~alpha ~hppa ~mips ~sparc"
+KEYWORDS="x86"
DEPEND=""
RDEPEND=""
@@ -22,8 +22,8 @@ src_compile() {
src_install() {
egamesinstall || die
- mv ${D}/${GAMES_PREFIX}/include ${D}/usr/
- dodoc AUTHORS ChangeLog README TODO || die "dodoc failed"
- dohtml DOCS/mamory.html || die "dohtml failed"
+ mv ${D}/${GAMES_PREFIX}/include ${D}/usr/ || die "mv failed"
+ dodoc AUTHORS ChangeLog README TODO
+ dohtml DOCS/mamory.html
prepgamesdirs
}
diff --git a/games-engines/exult/exult-1.00.ebuild b/games-engines/exult/exult-1.00.ebuild
index 2442d65767af..1d074dba6ff2 100644
--- a/games-engines/exult/exult-1.00.ebuild
+++ b/games-engines/exult/exult-1.00.ebuild
@@ -1,15 +1,15 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-engines/exult/exult-1.00.ebuild,v 1.3 2004/02/03 01:08:57 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-engines/exult/exult-1.00.ebuild,v 1.4 2004/02/29 10:32:28 vapier Exp $
inherit games
DESCRIPTION="an Ultima 7 game engine that runs on modern operating systems"
-SRC_URI="mirror://sourceforge/exult/${P}.tar.gz"
HOMEPAGE="http://exult.sourceforge.net/"
+SRC_URI="mirror://sourceforge/exult/${P}.tar.gz"
-SLOT="0"
LICENSE="GPL-2"
+SLOT="0"
KEYWORDS="x86 ppc ~sparc"
RDEPEND=">=media-libs/libsdl-1.2*
@@ -25,7 +25,7 @@ pkg_setup() {
}
src_compile() {
- egamesconf
+ egamesconf || die
emake || die
}