summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2010-01-15 04:42:59 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2010-01-15 04:42:59 +0000
commitfa8fd0487905da8f259535b0502d61f97a645d08 (patch)
treea237f462852cf7b1ca12ad61b3552c91f23ab8cf /xfce-extra
parentAdjust xfce mask more, porting app by app (diff)
downloadgentoo-2-fa8fd0487905da8f259535b0502d61f97a645d08.tar.gz
gentoo-2-fa8fd0487905da8f259535b0502d61f97a645d08.tar.bz2
gentoo-2-fa8fd0487905da8f259535b0502d61f97a645d08.zip
Backport upstream patch for >= exo 0.5.1.
(Portage version: 2.2_rc61/cvs/Linux x86_64)
Diffstat (limited to 'xfce-extra')
-rw-r--r--xfce-extra/thunar-media-tags-plugin/ChangeLog9
-rw-r--r--xfce-extra/thunar-media-tags-plugin/files/thunar-media-tags-plugin-0.1.2-exo_and_thunarx.patch92
-rw-r--r--xfce-extra/thunar-media-tags-plugin/thunar-media-tags-plugin-0.1.2-r1.ebuild29
3 files changed, 129 insertions, 1 deletions
diff --git a/xfce-extra/thunar-media-tags-plugin/ChangeLog b/xfce-extra/thunar-media-tags-plugin/ChangeLog
index 09a2ff09a4b3..d0c85ca28a68 100644
--- a/xfce-extra/thunar-media-tags-plugin/ChangeLog
+++ b/xfce-extra/thunar-media-tags-plugin/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for xfce-extra/thunar-media-tags-plugin
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/xfce-extra/thunar-media-tags-plugin/ChangeLog,v 1.4 2010/01/15 03:00:54 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/xfce-extra/thunar-media-tags-plugin/ChangeLog,v 1.5 2010/01/15 04:42:58 ssuominen Exp $
+
+*thunar-media-tags-plugin-0.1.2-r1 (15 Jan 2010)
+
+ 15 Jan 2010; Samuli Suominen <ssuominen@gentoo.org>
+ +thunar-media-tags-plugin-0.1.2-r1.ebuild,
+ +files/thunar-media-tags-plugin-0.1.2-exo_and_thunarx.patch:
+ Backport upstream patch for >= exo 0.5.1.
15 Jan 2010; Samuli Suominen <ssuominen@gentoo.org>
thunar-media-tags-plugin-0.1.2.ebuild:
diff --git a/xfce-extra/thunar-media-tags-plugin/files/thunar-media-tags-plugin-0.1.2-exo_and_thunarx.patch b/xfce-extra/thunar-media-tags-plugin/files/thunar-media-tags-plugin-0.1.2-exo_and_thunarx.patch
new file mode 100644
index 000000000000..72430d915449
--- /dev/null
+++ b/xfce-extra/thunar-media-tags-plugin/files/thunar-media-tags-plugin-0.1.2-exo_and_thunarx.patch
@@ -0,0 +1,92 @@
+diff -ur thunar-media-tags-plugin-0.1.2.orig/configure.in thunar-media-tags-plugin-0.1.2/configure.in
+--- thunar-media-tags-plugin-0.1.2.orig/configure.in 2007-01-20 17:29:39.000000000 +0200
++++ thunar-media-tags-plugin-0.1.2/configure.in 2010-01-15 06:33:45.000000000 +0200
+@@ -64,9 +64,8 @@
+ dnl ***********************************
+ dnl *** Check for required packages ***
+ dnl ***********************************
+-XDT_CHECK_PACKAGE([EXO], [exo-0.3], [0.3.1.3])
+-XDT_CHECK_PACKAGE([THUNARX], [thunarx-1], [0.2.3svn-r20526])
+-XDT_CHECK_PACKAGE([THUNARVFS], [thunar-vfs-1], [0.2.3svn-r20526])
++XDT_CHECK_PACKAGE([EXO], [exo-1], [0.5.1])
++XDT_CHECK_PACKAGE([THUNARX], [thunarx-2], [1.1.0])
+ XDT_CHECK_PACKAGE([TAGLIB], [taglib], [1.4])
+
+ dnl ***********************************
+Only in thunar-media-tags-plugin-0.1.2: foo.diff
+Only in thunar-media-tags-plugin-0.1.2: foo.patch
+diff -ur thunar-media-tags-plugin-0.1.2.orig/thunar-plugin/audio-tags-page.c thunar-media-tags-plugin-0.1.2/thunar-plugin/audio-tags-page.c
+--- thunar-media-tags-plugin-0.1.2.orig/thunar-plugin/audio-tags-page.c 2006-09-11 12:40:56.000000000 +0300
++++ thunar-media-tags-plugin-0.1.2/thunar-plugin/audio-tags-page.c 2010-01-15 06:36:58.000000000 +0200
+@@ -32,7 +32,6 @@
+ #include <taglib/tag_c.h>
+
+ #include <exo/exo.h>
+-#include <thunar-vfs/thunar-vfs.h>
+
+ #include <audio-tags-page.h>
+
+@@ -977,8 +976,8 @@
+
+ gchar *mimetype;
+
+- ThunarVfsInfo *vfs_info;
+- gchar *filename;
++ GFileInfo *fileinfo;
++ const char *filename;
+ gchar *filesize;
+
+ g_return_val_if_fail (page != NULL || IS_AUDIO_TAGS_PAGE (page), FALSE);
+@@ -1007,9 +1006,9 @@
+
+ /* Additional information */
+ mimetype = thunarx_file_info_get_mime_type (page->file);
+- vfs_info = thunarx_file_info_get_vfs_info (page->file);
+- filename = vfs_info->display_name;
+- filesize = thunar_vfs_humanize_size (vfs_info->size, NULL, 0);
++ fileinfo = thunarx_file_info_get_file_info (page->file);
++ filename = g_file_info_get_display_name (fileinfo);
++ filesize = g_format_size_for_display (g_file_info_get_size (fileinfo));
+
+ /* Create layout table */
+ table = gtk_table_new (7, 2, FALSE);
+@@ -1121,8 +1120,8 @@
+ g_free (filesize);
+ g_free (mimetype);
+
+- thunar_vfs_info_unref (vfs_info);
+-
++ g_object_unref (fileinfo);
++
+ return TRUE;
+ }
+
+Only in thunar-media-tags-plugin-0.1.2/thunar-plugin: audio-tags-page.c.orig
+diff -ur thunar-media-tags-plugin-0.1.2.orig/thunar-plugin/Makefile.am thunar-media-tags-plugin-0.1.2/thunar-plugin/Makefile.am
+--- thunar-media-tags-plugin-0.1.2.orig/thunar-plugin/Makefile.am 2006-06-08 16:04:45.000000000 +0300
++++ thunar-media-tags-plugin-0.1.2/thunar-plugin/Makefile.am 2010-01-15 06:34:48.000000000 +0200
+@@ -8,7 +8,7 @@
+ -DPACKAGE_LOCALE_DIR=\"$(localedir)\" \
+ $(PLATFORM_CPPFLAGS)
+
+-extensionsdir = $(libdir)/thunarx-1
++extensionsdir = $(libdir)/thunarx-2
+ extensions_LTLIBRARIES = \
+ thunar-media-tags-plugin.la
+
+@@ -25,7 +25,6 @@
+ $(EXO_CFLAGS) \
+ $(PLATFORM_CFLAGS) \
+ $(THUNARX_CFLAGS) \
+- $(THUNARVFS_CFLAGS) \
+ $(TAGLIB_CFLAGS) \
+ $(TAGLIBC_CFLAGS)
+
+@@ -34,7 +33,6 @@
+ -export-dynamic \
+ -module \
+ $(THUNARX_LIBS) \
+- $(THUNARVFS_LIBS) \
+ $(TAGLIB_LIBS) \
+ $(TAGLIBC_LIBS) \
+ $(PLATFORM_LDFLAGS)
diff --git a/xfce-extra/thunar-media-tags-plugin/thunar-media-tags-plugin-0.1.2-r1.ebuild b/xfce-extra/thunar-media-tags-plugin/thunar-media-tags-plugin-0.1.2-r1.ebuild
new file mode 100644
index 000000000000..3cc8269488b5
--- /dev/null
+++ b/xfce-extra/thunar-media-tags-plugin/thunar-media-tags-plugin-0.1.2-r1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/xfce-extra/thunar-media-tags-plugin/thunar-media-tags-plugin-0.1.2-r1.ebuild,v 1.1 2010/01/15 04:42:58 ssuominen Exp $
+
+EAPI=2
+EAUTORECONF=yes
+inherit xfconf
+
+DESCRIPTION="Thunar media tags plugin"
+HOMEPAGE="http://www.xfce.org/"
+SRC_URI="mirror://xfce/src/thunar-plugins/${PN}/0.1/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~ia64-linux ~x86-linux"
+IUSE="debug"
+
+RDEPEND=">=xfce-base/exo-0.5.1
+ >=xfce-base/thunar-1.1.0
+ >=media-libs/taglib-1.4"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+pkg_setup() {
+ DOCS="AUTHORS ChangeLog README TODO"
+ XFCONF="--disable-dependency-tracking
+ $(use_enable debug)"
+ PATCHES=( "${FILESDIR}/${P}-exo_and_thunarx.patch" )
+}