summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2009-10-24 17:29:42 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2009-10-24 17:29:42 +0000
commit26c4f71f95570d6a0cb41a6c728da95e16c70607 (patch)
treea509f87aa6f35406a1995df13182204ce056baa1 /xfce-extra
parentStable on alpha, bug #289339 (diff)
downloadgentoo-2-26c4f71f95570d6a0cb41a6c728da95e16c70607.tar.gz
gentoo-2-26c4f71f95570d6a0cb41a6c728da95e16c70607.tar.bz2
gentoo-2-26c4f71f95570d6a0cb41a6c728da95e16c70607.zip
Fix configure.in to detect >=exo-0.5.
(Portage version: 2.2_rc46/cvs/Linux x86_64)
Diffstat (limited to 'xfce-extra')
-rw-r--r--xfce-extra/xfce4-clipman-plugin/ChangeLog7
-rw-r--r--xfce-extra/xfce4-clipman-plugin/files/xfce4-clipman-plugin-1.1.1-exo.patch13
-rw-r--r--xfce-extra/xfce4-clipman-plugin/xfce4-clipman-plugin-1.1.1.ebuild4
3 files changed, 22 insertions, 2 deletions
diff --git a/xfce-extra/xfce4-clipman-plugin/ChangeLog b/xfce-extra/xfce4-clipman-plugin/ChangeLog
index 83e451bc8e4d..ce23769a7248 100644
--- a/xfce-extra/xfce4-clipman-plugin/ChangeLog
+++ b/xfce-extra/xfce4-clipman-plugin/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for xfce-extra/xfce4-clipman-plugin
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/xfce-extra/xfce4-clipman-plugin/ChangeLog,v 1.13 2009/10/21 00:06:08 fauli Exp $
+# $Header: /var/cvsroot/gentoo-x86/xfce-extra/xfce4-clipman-plugin/ChangeLog,v 1.14 2009/10/24 17:29:41 ssuominen Exp $
+
+ 24 Oct 2009; Samuli Suominen <ssuominen@gentoo.org>
+ xfce4-clipman-plugin-1.1.1.ebuild,
+ +files/xfce4-clipman-plugin-1.1.1-exo.patch:
+ Fix configure.in to detect >=exo-0.5.
21 Oct 2009; Christian Faulhammer <fauli@gentoo.org>
xfce4-clipman-plugin-1.1.1.ebuild:
diff --git a/xfce-extra/xfce4-clipman-plugin/files/xfce4-clipman-plugin-1.1.1-exo.patch b/xfce-extra/xfce4-clipman-plugin/files/xfce4-clipman-plugin-1.1.1-exo.patch
new file mode 100644
index 000000000000..68ef900f8d49
--- /dev/null
+++ b/xfce-extra/xfce4-clipman-plugin/files/xfce4-clipman-plugin-1.1.1-exo.patch
@@ -0,0 +1,13 @@
+diff -ur xfce4-clipman-plugin-1.1.1.orig/configure.ac xfce4-clipman-plugin-1.1.1/configure.ac
+--- xfce4-clipman-plugin-1.1.1.orig/configure.ac 2009-09-30 19:04:22.000000000 +0300
++++ xfce4-clipman-plugin-1.1.1/configure.ac 2009-10-24 20:28:34.000000000 +0300
+@@ -63,7 +63,8 @@
+ dnl *** Check for required packages ***
+ dnl ***********************************
+ XDT_CHECK_PACKAGE([GIO], [gio-2.0], [2.16.0])
+-XDT_CHECK_PACKAGE([EXO], [exo-0.3], [0.3.0])
++XDT_CHECK_PACKAGE([EXO], [exo-0.3], [0.3.0], [],
++ [XDT_CHECK_PACKAGE([EXO], [exo-1], [0.5.0])])
+ XDT_CHECK_PACKAGE([GLIB], [glib-2.0], [2.16.0])
+ XDT_CHECK_PACKAGE([GDKX], [gdk-x11-2.0], [2.10.0])
+ XDT_CHECK_PACKAGE([GTK], [gtk+-2.0], [2.10.0])
diff --git a/xfce-extra/xfce4-clipman-plugin/xfce4-clipman-plugin-1.1.1.ebuild b/xfce-extra/xfce4-clipman-plugin/xfce4-clipman-plugin-1.1.1.ebuild
index 2df7d599105c..6e6805371532 100644
--- a/xfce-extra/xfce4-clipman-plugin/xfce4-clipman-plugin-1.1.1.ebuild
+++ b/xfce-extra/xfce4-clipman-plugin/xfce4-clipman-plugin-1.1.1.ebuild
@@ -1,8 +1,9 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/xfce-extra/xfce4-clipman-plugin/xfce4-clipman-plugin-1.1.1.ebuild,v 1.4 2009/10/21 00:06:08 fauli Exp $
+# $Header: /var/cvsroot/gentoo-x86/xfce-extra/xfce4-clipman-plugin/xfce4-clipman-plugin-1.1.1.ebuild,v 1.5 2009/10/24 17:29:41 ssuominen Exp $
EAPI=2
+EAUTORECONF=yes
inherit xfconf
DESCRIPTION="a simple cliboard history manager for Xfce4 Panel"
@@ -32,4 +33,5 @@ pkg_setup() {
DOCS="AUTHORS ChangeLog NEWS README TODO"
XFCONF="--disable-dependency-tracking
$(use_enable debug)"
+ PATCHES=( "${FILESDIR}/${P}-exo.patch" )
}