summaryrefslogtreecommitdiff
path: root/x11-wm
diff options
context:
space:
mode:
authorAron Griffis <agriffis@gentoo.org>2003-02-13 17:31:17 +0000
committerAron Griffis <agriffis@gentoo.org>2003-02-13 17:31:17 +0000
commitf660e4706cabd2682b402d21715e930330a8da5f (patch)
tree2488eec9b8750b1c90ab16590fa44ab18ae0a258 /x11-wm
parentUpdate Copyright years (diff)
downloadgentoo-2-f660e4706cabd2682b402d21715e930330a8da5f.tar.gz
gentoo-2-f660e4706cabd2682b402d21715e930330a8da5f.tar.bz2
gentoo-2-f660e4706cabd2682b402d21715e930330a8da5f.zip
Update to 2.4.15 (bug #14529) and add ~alpha
Diffstat (limited to 'x11-wm')
-rw-r--r--x11-wm/fvwm/ChangeLog7
-rw-r--r--x11-wm/fvwm/fvwm-2.4.15.ebuild56
2 files changed, 62 insertions, 1 deletions
diff --git a/x11-wm/fvwm/ChangeLog b/x11-wm/fvwm/ChangeLog
index 7111eed1ce89..75270698c1c2 100644
--- a/x11-wm/fvwm/ChangeLog
+++ b/x11-wm/fvwm/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-wm/fvwm
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-wm/fvwm/ChangeLog,v 1.11 2003/02/12 09:51:27 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/fvwm/ChangeLog,v 1.12 2003/02/13 17:31:17 agriffis Exp $
+
+*fvwm-2.4.15 (13 Feb 2003)
+
+ 13 Feb 2003; Aron Griffis <agriffis@gentoo.org> fvwm-2.4.15.ebuild :
+ Update to 2.4.15 (bug #14529) and add ~alpha
19 Dec 2002; Dean Bailey <alron@gentoo.org> : removed sparc64 keyword
diff --git a/x11-wm/fvwm/fvwm-2.4.15.ebuild b/x11-wm/fvwm/fvwm-2.4.15.ebuild
new file mode 100644
index 000000000000..86a898b2f70b
--- /dev/null
+++ b/x11-wm/fvwm/fvwm-2.4.15.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/fvwm/fvwm-2.4.15.ebuild,v 1.1 2003/02/13 17:31:17 agriffis Exp $
+
+inherit gnuconfig
+
+IUSE="ncurses gtk gnome"
+
+S=${WORKDIR}/${P}
+DESCRIPTION="an extremely powerful ICCCM-compliant multiple virtual desktop window manager"
+SRC_URI="ftp://ftp.fvwm.org/pub/fvwm/version-2/${P}.tar.bz2"
+HOMEPAGE="http://www.fvwm.org/"
+
+SLOT="0"
+KEYWORDS="~x86 ~sparc ~ppc ~alpha"
+LICENSE="GPL-2 FVWM"
+
+RDEPEND=">=dev-libs/libstroke-0.4
+ gtk? ( =x11-libs/gtk+-1.2* )
+ gnome? ( >=gnome-base/gnome-libs-1.4.1.2-r1 )
+ ncurses? ( >=sys-libs/readline-4.1 )"
+DEPEND="${RDEPEND} sys-devel/automake"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ use alpha && gnuconfig_update
+}
+
+src_compile() {
+ local myconf
+
+ use gnome \
+ && myconf="--with-gnome" \
+ || myconf="--without-gnome" \
+
+ automake
+
+ econf \
+ --enable-multibyte \
+ --libexecdir=/usr/lib \
+ ${myconf} || die
+
+ emake || die
+}
+
+src_install () {
+ make DESTDIR=${D} install || die
+
+ echo "#!/bin/bash" > fvwm2
+ echo "/usr/bin/fvwm2" >> fvwm2
+
+ exeinto /etc/X11/Sessions
+ doexe fvwm2
+}
+