summaryrefslogtreecommitdiff
path: root/x11-wm
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2015-02-25 18:14:43 +0000
committerTim Harder <radhermit@gentoo.org>2015-02-25 18:14:43 +0000
commit839006202074d11b5288bdffc03ddbb4b40c775f (patch)
treeafe63423992e7c71ecb5a82b0247d707136dabcd /x11-wm
parentAdd ruby22. Call rdoc via the recipe to avoid an rspec dependency. (diff)
downloadgentoo-2-839006202074d11b5288bdffc03ddbb4b40c775f.tar.gz
gentoo-2-839006202074d11b5288bdffc03ddbb4b40c775f.tar.bz2
gentoo-2-839006202074d11b5288bdffc03ddbb4b40c775f.zip
Version bump, disable docs until required sphinx extensions are in the tree.
(Portage version: 2.2.15/cvs/Linux x86_64, signed Manifest commit with key 4AB3E85B4F064CA3)
Diffstat (limited to 'x11-wm')
-rw-r--r--x11-wm/qtile/ChangeLog8
-rw-r--r--x11-wm/qtile/qtile-0.9.1.ebuild56
-rw-r--r--x11-wm/qtile/qtile-9999.ebuild22
3 files changed, 70 insertions, 16 deletions
diff --git a/x11-wm/qtile/ChangeLog b/x11-wm/qtile/ChangeLog
index ff47983b7304..77e7191beb7f 100644
--- a/x11-wm/qtile/ChangeLog
+++ b/x11-wm/qtile/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-wm/qtile
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-wm/qtile/ChangeLog,v 1.14 2015/01/20 15:53:12 radhermit Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/qtile/ChangeLog,v 1.15 2015/02/25 18:14:43 radhermit Exp $
+
+*qtile-0.9.1 (25 Feb 2015)
+
+ 25 Feb 2015; Tim Harder <radhermit@gentoo.org> +qtile-0.9.1.ebuild,
+ qtile-9999.ebuild:
+ Version bump, disable docs until required sphinx extensions are in the tree.
20 Jan 2015; Tim Harder <radhermit@gentoo.org> qtile-9999.ebuild:
Use https git repo URL.
diff --git a/x11-wm/qtile/qtile-0.9.1.ebuild b/x11-wm/qtile/qtile-0.9.1.ebuild
new file mode 100644
index 000000000000..898654fbfd9a
--- /dev/null
+++ b/x11-wm/qtile/qtile-0.9.1.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/qtile/qtile-0.9.1.ebuild,v 1.1 2015/02/25 18:14:43 radhermit Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_4} )
+
+inherit distutils-r1 virtualx
+
+if [[ ${PV} == 9999* ]] ; then
+ EGIT_REPO_URI="https://github.com/qtile/qtile.git"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/qtile/qtile/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+DESCRIPTION="A full-featured, hackable tiling window manager written in Python"
+HOMEPAGE="http://qtile.org/"
+
+LICENSE="MIT"
+SLOT="0"
+IUSE="test"
+# docs require sphinxcontrib-blockdiag and sphinxcontrib-seqdiag
+
+RDEPEND="
+ >=dev-python/cairocffi-0.6[${PYTHON_USEDEP}]
+ >=dev-python/cffi-0.8.2[${PYTHON_USEDEP}]
+ >=dev-python/six-1.4.1[${PYTHON_USEDEP}]
+ >=dev-python/xcffib-0.1.11[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep 'dev-python/trollius[${PYTHON_USEDEP}]' 'python2*')
+"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ dev-python/nose[${PYTHON_USEDEP}]
+ x11-base/xorg-server[kdrive]
+ )
+"
+
+RESTRICT="test"
+
+python_test() {
+ VIRTUALX_COMMAND="nosetests" virtualmake
+}
+
+python_install_all() {
+ local DOCS=( CHANGELOG README.rst )
+ distutils-r1_python_install_all
+
+ insinto /usr/share/xsessions
+ doins resources/qtile.desktop
+
+ exeinto /etc/X11/Sessions
+ newexe "${FILESDIR}"/${PN}-session ${PN}
+}
diff --git a/x11-wm/qtile/qtile-9999.ebuild b/x11-wm/qtile/qtile-9999.ebuild
index 72e680e0d9fc..c24f71b29601 100644
--- a/x11-wm/qtile/qtile-9999.ebuild
+++ b/x11-wm/qtile/qtile-9999.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-wm/qtile/qtile-9999.ebuild,v 1.11 2015/01/20 15:53:12 radhermit Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/qtile/qtile-9999.ebuild,v 1.12 2015/02/25 18:14:43 radhermit Exp $
EAPI=5
-PYTHON_COMPAT=( python{2_6,2_7} )
+PYTHON_COMPAT=( python{2_7,3_4} )
inherit distutils-r1 virtualx
@@ -20,40 +20,32 @@ HOMEPAGE="http://qtile.org/"
LICENSE="MIT"
SLOT="0"
-IUSE="doc test"
+IUSE="test"
+# docs require sphinxcontrib-blockdiag and sphinxcontrib-seqdiag
RDEPEND="
- dev-python/pygtk:2[${PYTHON_USEDEP}]
>=dev-python/cairocffi-0.6[${PYTHON_USEDEP}]
>=dev-python/cffi-0.8.2[${PYTHON_USEDEP}]
>=dev-python/six-1.4.1[${PYTHON_USEDEP}]
- >=dev-python/xcffib-0.1.10[${PYTHON_USEDEP}]
+ >=dev-python/xcffib-0.1.11[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep 'dev-python/trollius[${PYTHON_USEDEP}]' 'python2*')
"
-DEPEND="
+DEPEND="${RDEPEND}
dev-python/setuptools[${PYTHON_USEDEP}]
- doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
test? (
- ${RDEPEND}
dev-python/nose[${PYTHON_USEDEP}]
- dev-python/python-xlib[${PYTHON_USEDEP}]
x11-base/xorg-server[kdrive]
)
"
-# tests fail due to xauth errors from python-xlib
RESTRICT="test"
-python_compile_all() {
- use doc && emake -C docs html
-}
-
python_test() {
VIRTUALX_COMMAND="nosetests" virtualmake
}
python_install_all() {
local DOCS=( CHANGELOG README.rst )
- use doc && local HTML_DOCS=( docs/_build/html/. )
distutils-r1_python_install_all
insinto /usr/share/xsessions