summaryrefslogtreecommitdiff
path: root/x11-wm
diff options
context:
space:
mode:
authorMichael Weber <xmw@gentoo.org>2011-05-11 08:58:21 +0000
committerMichael Weber <xmw@gentoo.org>2011-05-11 08:58:21 +0000
commit7d62fe3b46677d0cf1b12a5ec2db78f293aa9b45 (patch)
tree9651d07ee9710c672748d7f0c11586a6532f312f /x11-wm
parentInitial commit, ebuild written by me. (diff)
downloadgentoo-2-7d62fe3b46677d0cf1b12a5ec2db78f293aa9b45.tar.gz
gentoo-2-7d62fe3b46677d0cf1b12a5ec2db78f293aa9b45.tar.bz2
gentoo-2-7d62fe3b46677d0cf1b12a5ec2db78f293aa9b45.zip
Version bump
(Portage version: 2.1.9.42/cvs/Linux x86_64)
Diffstat (limited to 'x11-wm')
-rw-r--r--x11-wm/stumpwm/ChangeLog9
-rw-r--r--x11-wm/stumpwm/stumpwm-0.9.7.ebuild50
2 files changed, 57 insertions, 2 deletions
diff --git a/x11-wm/stumpwm/ChangeLog b/x11-wm/stumpwm/ChangeLog
index e9dd69264324..6228eae244ff 100644
--- a/x11-wm/stumpwm/ChangeLog
+++ b/x11-wm/stumpwm/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-wm/stumpwm
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-wm/stumpwm/ChangeLog,v 1.4 2009/09/07 20:36:20 betelgeuse Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/stumpwm/ChangeLog,v 1.5 2011/05/11 08:58:21 xmw Exp $
+
+*stumpwm-0.9.7 (11 May 2011)
+
+ 11 May 2011; Michael Weber <xmw@gentoo.org> +stumpwm-0.9.7.ebuild:
+ Version bump (thanks to drg, bug 366769)
07 Sep 2009; Petteri Räty <betelgeuse@gentoo.org> stumpwm-0.9.2.ebuild:
Migrate to EAPI 2 in order to get rid of built_with_use.
diff --git a/x11-wm/stumpwm/stumpwm-0.9.7.ebuild b/x11-wm/stumpwm/stumpwm-0.9.7.ebuild
new file mode 100644
index 000000000000..d16a34d95013
--- /dev/null
+++ b/x11-wm/stumpwm/stumpwm-0.9.7.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/stumpwm/stumpwm-0.9.7.ebuild,v 1.1 2011/05/11 08:58:21 xmw Exp $
+
+EAPI="2"
+
+inherit common-lisp eutils
+
+DESCRIPTION="Stumpwm is a tiling, keyboard driven X11 Window Manager written entirely in Common Lisp."
+HOMEPAGE="http://www.nongnu.org/stumpwm/index.html"
+SRC_URI="http://download.savannah.nongnu.org/releases/stumpwm/${P}.tgz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+IUSE="sbcl clisp emacs doc"
+
+CLPACKAGE="stumpwm"
+
+DEPEND="dev-lisp/common-lisp-controller
+ virtual/commonlisp
+ dev-lisp/cl-ppcre
+ doc? ( sys-apps/texinfo )"
+
+# If clisp is selected, we need at least dev-lisp/clisp-2.38-r2
+
+RDEPEND="${DEPEND}
+ emacs? ( app-emacs/slime )
+ !clisp? ( !sbcl? ( !amd64? ( dev-lisp/cmucl ) ) )
+ clisp? ( >=dev-lisp/clisp-2.38-r2[X,-new-clx] )
+ sbcl? ( dev-lisp/sbcl dev-lisp/cl-clx )"
+
+src_configure() {
+ sed "s,@PACKAGE_VERSION@,$PV,g" version.lisp.in > version.lisp
+}
+
+src_compile() {
+ use doc && makeinfo stumpwm.texi
+}
+
+src_install() {
+ common-lisp-install *.lisp stumpwm.asd
+ common-lisp-system-symlink
+ dodoc README NEWS ChangeLog "${FILESDIR}/README.Gentoo" || die
+ use doc && doinfo stumpwm.info
+}
+
+pkg_postinst() {
+ common-lisp_pkg_postinst
+ cat "${FILESDIR}/README.Gentoo"
+}