summaryrefslogtreecommitdiff
path: root/x11-wm
diff options
context:
space:
mode:
authorTavis Ormandy <taviso@gentoo.org>2003-07-31 22:26:24 +0000
committerTavis Ormandy <taviso@gentoo.org>2003-07-31 22:26:24 +0000
commit7c0bd3f8b15913be919ba71cffbce8f64983f56c (patch)
tree42cabbd783e593352c8a1a7cdc37cda81ea3e64f /x11-wm
parentback-porting new fix to fvwm-2.4.16-r1 (diff)
downloadgentoo-2-7c0bd3f8b15913be919ba71cffbce8f64983f56c.tar.gz
gentoo-2-7c0bd3f8b15913be919ba71cffbce8f64983f56c.tar.bz2
gentoo-2-7c0bd3f8b15913be919ba71cffbce8f64983f56c.zip
typo
Diffstat (limited to 'x11-wm')
-rw-r--r--x11-wm/fvwm/Manifest2
-rw-r--r--x11-wm/fvwm/fvwm-2.5.7.ebuild201
2 files changed, 202 insertions, 1 deletions
diff --git a/x11-wm/fvwm/Manifest b/x11-wm/fvwm/Manifest
index 49d3afe1d3ef..32c1ee0d4963 100644
--- a/x11-wm/fvwm/Manifest
+++ b/x11-wm/fvwm/Manifest
@@ -1,7 +1,7 @@
MD5 616d23339ff772ad286c142eee37efc8 fvwm-2.4.15.ebuild 1167
MD5 a1b5e28dc1a3a1930c69abae86ac760d fvwm-2.4.16-r1.ebuild 4022
MD5 640cc8cf1c7b29a974fed717d4460794 fvwm-2.4.14.ebuild 1102
-MD5 68bf17ef6eb652db56613550d3ec89eb fvwm-2.5.7.ebuild 5977
+MD5 6330e5c47f6256b1fbb16e8516d094fc fvwm-2.5.7.ebuild 5977
MD5 9b68cbbbdaba95b23665ea98c695e57d fvwm-2.4.16.ebuild 1334
MD5 de100ca2eb91680cd31787b474a3d745 ChangeLog 3431
MD5 beaa1ad08ff661a32c25d1a51c879a8d metadata.xml 450
diff --git a/x11-wm/fvwm/fvwm-2.5.7.ebuild b/x11-wm/fvwm/fvwm-2.5.7.ebuild
new file mode 100644
index 000000000000..fbefba2b0df8
--- /dev/null
+++ b/x11-wm/fvwm/fvwm-2.5.7.ebuild
@@ -0,0 +1,201 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/fvwm/fvwm-2.5.7.ebuild,v 1.17 2003/07/31 22:26:15 taviso Exp $
+
+inherit gnuconfig
+
+IUSE="readline ncurses gtk stroke gnome rplay xinerama cjk perl nls png bidi doc imlib"
+
+S=${WORKDIR}/${P}
+DESCRIPTION="an extremely powerful ICCCM-compliant multiple virtual desktop window manager"
+SRC_URI="ftp://ftp.fvwm.org/pub/fvwm/version-2/${P}.tar.bz2"
+HOMEPAGE="http://www.fvwm.org/"
+
+SLOT="0"
+KEYWORDS="~x86 ~alpha"
+LICENSE="GPL-2 FVWM"
+
+RDEPEND="readline? ( >=sys-libs/readline-4.1
+ ncurses? ( >=sys-libs/ncurses-5.3-r1 )
+ !ncurses? ( >=sys-libs/libtermcap-compat-1.2.3 ) )
+ gtk? ( =x11-libs/gtk+-1.2*
+ imlib? ( >=media-libs/gdk-pixbuf-0.21.0
+ >=media-libs/imlib-1.9.14-r1 ) )
+ gnome? ( >=gnome-base/gnome-libs-1.4.1.2-r1 )
+ rplay? ( >=media-sound/rplay-3.3.2 )
+ perl? ( >=dev-lang/perl-5.6.1-r10 )
+ bidi? ( >=dev-libs/fribidi-0.10.4 )
+ png? ( >=media-libs/libpng-1.0.12-r2 )
+ stroke? ( >=dev-libs/libstroke-0.4 )
+ doc? ( >=media-libs/netpbm-9.12-r4 )
+ >=media-libs/fontconfig-2.1-r1
+ >=dev-libs/expat-1.95.6-r1
+ virtual/x11
+ virtual/xft"
+DEPEND="${RDEPEND}
+ >=sys-apps/sed-4
+ sys-devel/automake
+ sys-devel/autoconf
+ dev-util/pkgconfig"
+
+src_unpack() {
+ unpack ${A}
+
+ use alpha && gnuconfig_update
+
+ # CFLAGS containing comma will break this, so change it for !
+ sed -i 's#\x27s,xCFLAGSx,$(CFLAGS),\x27#\x27s!xCFLAGSx!$(CFLAGS)!\x27#' ${S}/utils/Makefile.am
+
+ # Xft detection is totally b0rked if using pkg-config, this update from cvs.
+ cp ${FILESDIR}/acinclude.m4 ${S}/acinclude.m4
+}
+
+src_compile() {
+ local myconf="--libexecdir=/usr/lib --enable-xft"
+
+ # use readline in FvwmConsole.
+ if ! use readline; then
+ myconf="${myconf} --without-readline-library"
+ else
+ myconf="${myconf} --with-readline-library"
+
+ # choose ncurses or termcap.
+ if use ncurses; then
+ myconf="${myconf} --without-termcap-library"
+ else
+ myconf="${myconf} --without-ncurses-library"
+ fi
+ fi
+
+ # fvwm configure doesnt provide a way to disable gtk support if the
+ # required libraries are found, this hides them from the script.
+ if ! use gtk; then
+ myconf="${myconf} --with-gtk-prefix=${T} --with-imlib-prefix=${T}"
+ else
+ if ! use imlib; then
+ myconf="${myconf} --with-imlib-prefix=${T}"
+ fi
+ fi
+
+ # link with the gnome libraries, for better integration with the gnome desktop.
+ if use gnome; then
+ myconf="${myconf} --with-gnome"
+ else
+ myconf="${myconf} --without-gnome"
+ fi
+
+ # rplay is a cool, but little used way of playing sounds over a network
+ # Fvwm support is pretty good.
+ if ! use rplay; then
+ myconf="${myconf} --without-rplay-library"
+ fi
+
+ # Install perl bindings for FvwmPerl.
+ if use perl; then
+ myconf="${myconf} --enable-perllib"
+ else
+ myconf="${myconf} --disable-perllib"
+ fi
+
+ # xinerama support for those who have multi-headed machines.
+ if use xinerama; then
+ myconf="${myconf} --enable-xinerama"
+ else
+ myconf="${myconf} --disable-xinerama"
+ fi
+
+ # multibyte character support, chinese/japanese/korean/etc.
+ if use cjk; then
+ myconf="${myconf} --enable-multibyte"
+ else
+ myconf="${myconf} --disable-multibyte"
+ fi
+
+ # bidirectional writing support, eg hebrew
+ if use bidi; then
+ myconf="${myconf} --enable-bidi"
+ else
+ myconf="${myconf} --disable-bidi"
+ fi
+
+ # png image support (very nice in fvwm)
+ if ! use png; then
+ myconf="${myconf} --without-png-library"
+ fi
+
+ # native language support
+ if use nls; then
+ myconf="${myconf} --enable-nls"
+ else
+ myconf="${myconf} --disable-nls"
+ fi
+
+ # support for mouse gestures using libstroke (very very cool)
+ if ! use stroke; then
+ myconf="${myconf} --without-stroke-library"
+ fi
+
+ # Xft detection is broken in this release, the fix is in cvs
+ # which ive installed here, rerun automake to sort the problem.
+ einfo "Fixing Xft detection, please wait..."
+ ( einfo " Running aclocal..."
+ aclocal
+ einfo " Running autoheader..."
+ autoheader
+ einfo " Running automake..."
+ automake --add-missing
+ einfo " Running autoreconf..."
+ autoreconf ) 2>/dev/null
+ einfo "Fixed."
+
+ # must specify PKG_CONFIG or Xft detection bombs.
+ econf ${myconf} PKG_CONFIG=/usr/bin/pkg-config || die
+ emake || die
+}
+
+src_install() {
+ make DESTDIR=${D} install || die
+
+ echo "#!/bin/bash" > fvwm2
+ echo "exec /usr/bin/fvwm2" >> fvwm2
+
+ exeinto /etc/X11/Sessions
+ doexe fvwm2
+
+ dodoc AUTHORS ChangeLog COPYING README NEWS docs/ANNOUNCE docs/BUGS \
+ docs/COMMANDS docs/DEVELOPERS docs/FAQ docs/error_codes docs/TODO \
+ docs/fvwm.lsm
+
+ # optional example scripts (generate dynamic menus - really awesome, try
+ # this out) :)
+ use doc && dodoc utils/fvwm_make_directory_menu.sh \
+ utils/fvwm_make_browse_menu.sh utils/quantize_pixmaps
+}
+
+pkg_postinst() {
+ local i
+ ewarn
+ ewarn "The Gentoo FVWM ebuild has been altered since the 2.4.x Branch."
+ ewarn "The following features that you did not request are now"
+ ewarn "controlled via USE flags, and not enabled automatically:"
+ use readline || ewarn " Readline support in FvwmConsole [readline]"
+ use ncurses || ewarn " Ncurses support in FvwmConsole [ncurses]"
+ use stroke || ewarn " Mouse Gestures [stroke]"
+ use xinerama || ewarn " Xinerama Support [xinerama]"
+ use cjk || ewarn " Multibyte Character Support [cjk]"
+ use perl || ewarn " FVWM Perl bindings [perl]"
+ use nls || ewarn " Native Language Support [nls]"
+ use png || ewarn " PNG Support [png]"
+ use bidi || ewarn " Bidirectional Language Support [bidi]"
+ use rplay || ewarn " RPlay Support in FvwmEvent [rplay]"
+ use gtk || ewarn " FvwmGTK (gtk+ support) [gtk]"
+ use imlib || ewarn " FvwmGTK (GDK image support) [imlib]"
+ ewarn
+ ewarn "If you require any of the features listed above, you should remerge"
+ ewarn "FVWM with the appropriate USE flags. Use this command to see the flags"
+ ewarn "available:"
+ ewarn " $ emerge -pv fvwm"
+ ewarn
+
+ for ((i=0;i<5;i++)); do echo -ne '\a'; sleep 1; done
+}