summaryrefslogtreecommitdiff
path: root/x11-wm
diff options
context:
space:
mode:
authorBen de Groot <yngwin@gentoo.org>2009-02-23 20:40:27 +0000
committerBen de Groot <yngwin@gentoo.org>2009-02-23 20:40:27 +0000
commit6356588c68c8931cf034b1557be3264359913208 (patch)
treebf0870085c52b9c0481cd00c03d1e564c2900938 /x11-wm
parentforce rev bump and disable python support to address security risk (CVE-2009-... (diff)
downloadgentoo-2-6356588c68c8931cf034b1557be3264359913208.tar.gz
gentoo-2-6356588c68c8931cf034b1557be3264359913208.tar.bz2
gentoo-2-6356588c68c8931cf034b1557be3264359913208.zip
Version bump
(Portage version: 2.2_rc23/cvs/Linux i686)
Diffstat (limited to 'x11-wm')
-rw-r--r--x11-wm/echinus/ChangeLog9
-rw-r--r--x11-wm/echinus/echinus-0.3.2.1.ebuild66
2 files changed, 73 insertions, 2 deletions
diff --git a/x11-wm/echinus/ChangeLog b/x11-wm/echinus/ChangeLog
index 15b2f8ec3403..d0cabd6d0408 100644
--- a/x11-wm/echinus/ChangeLog
+++ b/x11-wm/echinus/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-wm/echinus
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-wm/echinus/ChangeLog,v 1.3 2008/08/26 11:43:57 yngwin Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/echinus/ChangeLog,v 1.4 2009/02/23 20:40:27 yngwin Exp $
+
+*echinus-0.3.2.1 (23 Feb 2009)
+
+ 23 Feb 2009; Ben de Groot <yngwin@gentoo.org> +echinus-0.3.2.1.ebuild:
+ Version bump. Removing patch that has been applied upstream.
26 Aug 2008; Ben de Groot <yngwin@gentoo.org> echinus-0.3.1.ebuild:
Adding pkgconfig dep
diff --git a/x11-wm/echinus/echinus-0.3.2.1.ebuild b/x11-wm/echinus/echinus-0.3.2.1.ebuild
new file mode 100644
index 000000000000..1b22fec4b91a
--- /dev/null
+++ b/x11-wm/echinus/echinus-0.3.2.1.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/echinus/echinus-0.3.2.1.ebuild,v 1.1 2009/02/23 20:40:27 yngwin Exp $
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="A window manager for X in the spirit of dwm"
+HOMEPAGE="http://www.rootshell.be/~polachok/code/"
+SRC_URI="http://www.rootshell.be/~polachok/code/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="x11-libs/libX11
+ x11-libs/libXft"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ sed -i \
+ -e "s/CFLAGS = -Os/CFLAGS += -g/" \
+ -e "s/LDFLAGS = -s/LDFLAGS += -g/" \
+ config.mk || die "sed failed"
+}
+
+src_compile() {
+ emake CC=$(tc-getCC) || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" PREFIX="/usr" install || die "emake install failed"
+
+ insinto /usr/share/xsessions
+ doins "${FILESDIR}"/${PN}.desktop
+
+ doman ${PN}.1
+ dodoc README
+}
+
+pkg_postinst() {
+ if ! has_version x11-misc/dmenu; then
+ elog "Installing ${PN} without x11-misc/dmenu"
+ elog "To have a menu you can install x11-misc/dmenu"
+ elog "and use \"Echinus*spawn\" in echinusrc"
+ elog "to launch dmenu_run. Check echinus documentation for details."
+ elog ""
+ fi
+ # x11-misc/ourico is not in portage atm, this will change soon.
+ #if ! has_version x11-misc/ourico; then
+ # elog "Installing ${PN} without x11-misc/ourico"
+ # elog "To have a taskbar you can install x11-misc/ourico"
+ # elog ""
+ #fi
+ elog "A standard config file with its pixmaps has been installed to:"
+ elog "${PREFIX}/usr/share/examples/${PN}/"
+ elog "Copy this folder to ~/.${PN}/ and modify the echinusrc as you wish."
+ elog ""
+ elog "For changing the modkey you can use \"Echinus*modkey: X\""
+ elog "in echinusrc. Replace the X with the number you want to use,"
+ elog "1 is for Mod1Mask, 2 for Mod2Mask and so on."
+}