summaryrefslogtreecommitdiff
path: root/x11-wm
diff options
context:
space:
mode:
authorRomain Perier <mrpouet@gentoo.org>2009-11-06 15:43:39 +0000
committerRomain Perier <mrpouet@gentoo.org>2009-11-06 15:43:39 +0000
commit2f8bc543841bc3814c29d4eb7b989841aec14e8b (patch)
tree7529b441bd5eb78dd6a11e58072ea9dbd6308062 /x11-wm
parentKeywording for ppc. (diff)
downloadgentoo-2-2f8bc543841bc3814c29d4eb7b989841aec14e8b.tar.gz
gentoo-2-2f8bc543841bc3814c29d4eb7b989841aec14e8b.tar.bz2
gentoo-2-2f8bc543841bc3814c29d4eb7b989841aec14e8b.zip
Fix bug #292009, build fails on FreeBSD, include sys/wait.h instead of wait.h as described in POSIX specs, many thanks to aballier.
(Portage version: 2.2_rc48/cvs/Linux x86_64)
Diffstat (limited to 'x11-wm')
-rw-r--r--x11-wm/metacity/ChangeLog8
-rw-r--r--x11-wm/metacity/files/metacity-2.28.0-sys-wait-header.patch19
-rw-r--r--x11-wm/metacity/metacity-2.28.0.ebuild6
3 files changed, 31 insertions, 2 deletions
diff --git a/x11-wm/metacity/ChangeLog b/x11-wm/metacity/ChangeLog
index ac8929d76149..6f20de51db8d 100644
--- a/x11-wm/metacity/ChangeLog
+++ b/x11-wm/metacity/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-wm/metacity
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-wm/metacity/ChangeLog,v 1.239 2009/11/05 20:02:39 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/metacity/ChangeLog,v 1.240 2009/11/06 15:43:38 mrpouet Exp $
+
+ 06 Nov 2009; Romain Perier <mrpouet@gentoo.org>
+ metacity-2.28.0.ebuild,
+ +files/metacity-2.28.0-sys-wait-header.patch:
+ Fix bug #292009, build fails on FreeBSD, include sys/wait.h instead of
+ wait.h as described in POSIX specs, many thanks to aballier.
05 Nov 2009; Markus Meier <maekke@gentoo.org> metacity-2.26.0-r1.ebuild:
arm stable, bug #281427
diff --git a/x11-wm/metacity/files/metacity-2.28.0-sys-wait-header.patch b/x11-wm/metacity/files/metacity-2.28.0-sys-wait-header.patch
new file mode 100644
index 000000000000..5d7f4a14561e
--- /dev/null
+++ b/x11-wm/metacity/files/metacity-2.28.0-sys-wait-header.patch
@@ -0,0 +1,19 @@
+From: Alexis Ballier <aballier@gentoo.org>
+Date: Thu, 5 Nov 2009 19:48:41 +0100
+Subject: Include sys/wait.h instead of only wait.h as described in POSIX specs. Fixes build on FreeBSD.
+
+---
+ src/core/main.c | 2 +-
+ 1 files changed, 1 insertions(+), 1 deletions(-)
+
+--- a/src/core/main.c
++++ b/src/core/main.c
+@@ -58,7 +58,7 @@
+
+ #include <stdlib.h>
+ #include <sys/types.h>
+-#include <wait.h>
++#include <sys/wait.h>
+ #include <stdio.h>
+ #include <string.h>
+ #include <signal.h>
diff --git a/x11-wm/metacity/metacity-2.28.0.ebuild b/x11-wm/metacity/metacity-2.28.0.ebuild
index fa180c41e28d..2257bcd30895 100644
--- a/x11-wm/metacity/metacity-2.28.0.ebuild
+++ b/x11-wm/metacity/metacity-2.28.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-wm/metacity/metacity-2.28.0.ebuild,v 1.1 2009/10/29 22:41:43 eva Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/metacity/metacity-2.28.0.ebuild,v 1.2 2009/11/06 15:43:38 mrpouet Exp $
EAPI="2"
# debug only changes CFLAGS
@@ -75,4 +75,8 @@ src_prepare() {
# and try to restart metacity infinitively when compiz is started)
# patch import from upstream bug #588119.
epatch "${FILESDIR}/${P}-restartstylehint-when-replace.patch"
+
+ # Use sys/wait.h header instead of wait.h as described in posix specs,
+ # bug 292009
+ epatch "${FILESDIR}/${P}-sys-wait-header.patch"
}